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Web Self rollovers inform without clicking

A brief summary without having to click 
Alienskin.com’s product page (left) is set up 
neatly in a grid. Each product has a standalone 
page that provides the customer additional 
details. By using a self rollover, the customer 
gets a brief overview of the product (above, 
right) without having to commit to a click and  
be taken to a different page.

Normal state Over state

Self rollovers in Adobe GoLive  
Rollovers require a separate image for 
each rollover state: Normal, Over, Down, 
Click, Up, and Out. All images must have 
the same dimensions. Give your normal-
state image a name—say, product1.gif—
then name the remaining images based on 
their state (product1_over.gif, product1_
down.gif, etc.). Put them all in one folder. 
Drag the normal-state image to your Go-
Live page, and GoLive will automatically 
place and arrange the other states on the 
Rollovers & Actions palette (above).

Alien Skin Software displays a lot of products yet keeps their site beautifully uncluttered. To do this they 
use self rollovers—graphics that change to descriptive text when merely touched by the cursor.
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Type  Straighten that wiggly edge

Have you sometimes noticed that type aligned vertically doesn’t look that way? That’s because while 
your margin is straight, the alphabet isn’t, and its curves, crossbars and punctuation marks can create 
the appearance of misalignment. InDesign’s Optical Margin Alignment will fix that:

After optical alignment  
With the text cursor active anywhere in a story, select 
Type>Story>Optical Margin Alignment (left), and watch 
what happens—all those idiosyncratic bits get hung over 
the edge. What’s interesting is that the margin is now 
misaligned, yet it looks straight. The number you specify 
in the dialog governs the amount of adjustment; gener-
ally it should match the point size.

Before optical alignment 
Your computer says the margin’s 
aligned, but your eyes tell you some-
thing different. Letters and punctua-
tion marks have funny shapes that 
make the edge appear wiggly.

Listening 
talking
 Opening 
 “ Quotes” 

 Listening 
 talking
 Opening 
“Quotes” 

Vertical strokes align

Crossbars hang

Curves hang

Punctuation hangs 
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Photo cropping  Size and placement tell a story

The size and placement of your image can have a dramatic effect on its impact. Here, placing a small 
portrait at the bottom of an empty field is all it takes to create a layout that perfectly illustrates its words.

The power of empty space
This layout makes it easy to see that 
empty space isn’t empty but has mass, 
volume and real power. The huge black 
field ungulfs our unfortunate CEO and 
creates a sense of heaviness, isolation 
and distance. What makes this happen 
is her small size, extremely low place-
ment and faraway gaze. Her dark suit is 
a bonus, fading into the background and 
leaving her somber expression in sharp 
contrast. Headline and text styles must 
be plain and in a neutral position (no 
tension) to not steal attention.

Embattled and isolated, CEO Donna Anderson 
grapples with the fallout of failed acquisitions and 
a board that’s calling for her head.
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No scissors required! 
The scraps look pasted on, but that’s a 
computerized illusion—this announce-
ment is printed in one piece right 
on your desktop. Write some playful 
words, scan your paper, then in Photo-
shop cut it to pieces, apply drop shad-
ows, move each piece to its own layer, 
arrange and print. Try it!

Fill and apply a shadow.

Create a selection.

Write and scan the words.

Design  A card made of scraps

To announce the birth of their son Drew, our friends Dawn and Michael wanted to send an engaging, 
personal card—and what’s more personal than your own handwriting? We like what they made:

Front Inside

Handwritten “love” subs as a signature.
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Draw three rectangles with the Rounded Rect-
angle tool (left). In the Layers palette, double-click 
Layer 1 and rename it “Tabs.” Edit>Copy all three 
tabs. Next, apply a drop shadow: Go to Effect> 
Stylize>Drop Shadow, activate Preview, enter: 
Mode: Multiply; Opacity 50%; X Offset 0; Y Offset 
0p2; Blur: 0p2; Color Black. Click OK. Lock this 
layer. Next, click on the Create New Layer icon 
(inset), and name it “Highlight.” Go to Edit>Paste 
in Front. Finally, create 
a “Type” layer, set your 
type, and move this 
layer below the “High-
light layer.”

Adobe Illustrator  Old-fashioned tabs with a modern sheen

BMW’s Web banner (right) tells a clever pricing story 
using animated cash-register popups. We like its 
juxtaposition of styles—the old mechanical device, old 
typeface and antique color but drawn with a modern, 
plasticized sheen. Here’s how to duplicate it:

Create the curve for the highlight We need 
to draw a line that will bisect the three tabs. 
Select the “Highlight” layer. Using the Pen Tool, 
draw a smooth curve (above). Press the Shift key, 
select  the curve and all three tabs, and go to 
Window>Pathfinder. Click Divide (below) to divide 
the shapes into six segments.

Reveal the figures With the segments still 
selected, change their Fill color to white. Next, 
use the Direct Selection Tool (hollow arrow) to 
select the bottom segments, and press Delete. 
Finally, select the top segments and lower their 
opacity in the Window>Transparency dialog box. 
Here, we specified an opacity of 60%.

BMW Web advertising banner
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Embattled and isolated, CEO Donna Anderson 
grapples with the fallout of failed acquisitions and 
a board that’s calling for her head.
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Before & After magazine  
Before & After has been sharing its practical approach 
to graphic design since 1990. Because our modern world 
has made designers of us all (ready or not), Before & 
After is dedicated to making graphic design understand-
able, useful and even fun for everyone.  

John McWade Publisher and creative director
Gaye McWade Associate publisher
Vincent Pascual Staff designer
Dexter Mark Abellera Staff designer
 
Before & After magazine
323 Lincoln Street, Roseville, CA 95678 
Telephone 916-784-3880 
Fax 916-784-3995
E-mail mailbox@bamagazine.com  
www http://www.bamagazine.com

Copyright ©2006 Before & After magazine 
ISSN 1049-0035. All rights reserved 

You may pass along a free copy of this article to others 
by clicking here. You may not alter this article, and you 
may not charge for it. You may quote brief sections  
for review; please credit Before & After magazine, and  
let us know. To link Before & After magazine to your 
Web site, use this URL: http://www.bamagazine.com. 
For all other permissions, please contact us.

Subscribe to Before & After

Subscribe to Before & After, and become a 

more capable, confident designer for pennies 

per article. To learn more, go to  

http://www.bamagazine.com/Subscribe

E-mail this article

To pass along a free copy of this article to 
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Join our e-list
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For paper-saver format  
Print: (Specify pages 10–13)

For presentation format  
Print: (Specify pages 1–8)

Before & After is made to fit your binder

Before & After articles are intended for permanent reference. All are titled and numbered.  

For the current table of contents, click here. To save time and paper, a paper-saver format of this article, 

suitable for one- or two-sided printing, is provided on the following pages.
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 click
 

A
lienskin.com

’s product page (left) is set up 
neatly in a grid. Each product has a standalone 
page that provides the custom

er additional 
details. B

y using a self rollover, the custom
er 

gets a brief overview
 of the product (above, 

right) w
ithout having to com

m
it to a click and  

be taken to a different page.

N
o

rm
a

l sta
te

O
ve

r sta
te

S
e

lf ro
llo

ve
rs in

 A
d

o
b

e
 G

o
Live

  
R

ollovers require a separate im
age for 

each rollover state: N
orm

al, O
ver, D

ow
n, 

C
lick, U

p, and O
ut. A

ll im
ages m

ust have 
the sam

e dim
ensions. G

ive your norm
al-

state im
age a nam

e
—

say, product1.gif—
then nam

e the rem
aining im

ages based on 
their state (product1_over.gif, product1_
dow

n.gif, etc.). P
ut them

 all in one folder. 
D

rag the norm
al-state im

age to your G
o-

Live page, and G
oLive w

ill autom
atically 

place and arrange the other states on the 
R

ollovers &
 A

ctions palette (above).

A
lien

 Skin
 So

ftw
are d

isp
lays a lo

t o
f p

ro
d

u
cts yet keep

s th
eir site b

eau
tifu

lly u
n

clu
ttered

. To
 d

o
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ey 

u
se self rollovers—

grap
h

ics th
at ch

an
ge to
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escrip

tive text w
h

en
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erely to
u

ch
ed

 b
y th

e cu
rso

r.
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Type  Straigh
ten

 th
at w

iggly ed
ge

H
ave yo

u
 so

m
etim

es n
o

ticed
 th

at typ
e align

ed
 vertically d

o
esn’t lo

o
k th

at w
ay? T

h
at’s b

ecau
se w

h
ile 

yo
u

r m
argin

 is straigh
t, th

e alp
h

ab
et isn’t, an

d
 its cu

rves, cro
ssb

ars an
d

 p
u

n
ctu

atio
n

 m
arks can

 create 
th

e ap
p

earan
ce o

f m
isalign

m
en

t. In
D

esign’s O
p

tical M
argin

 A
lign

m
en

t w
ill fi

x th
at:

A
fte

r o
p

tica
l a

lig
n

m
e

n
t  

W
ith the text cursor active anyw

here in a story, select 
Type>

Story>
O

ptical M
argin A

lignm
ent (left), and w

atch 
w

hat happens—
all those idiosyncratic bits get hung over 

the edge. W
hat’s interesting is that the m

argin is now
 

m
isaligned, yet it looks straight. The num

ber you specify 
in the dialog governs the am

ount of adjustm
ent; gener-

ally it should m
atch the point size.

B
e

fo
re

 o
p

tica
l a

lig
n

m
e

n
t 

Your com
puter says the m

argin’s 
aligned, but your eyes tell you som

e-
thing different. Letters and punctua-
tion m

arks have funny shapes that 
m

ake the edge appear w
iggly.

Listening 
talking
 O

pening 
 “ Q

uotes” 

 Listening 
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pening 
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uotes” 

Vertical strokes align

C
rossbars hang

C
urves hang

P
unctuation hangs  

Photo cropping  Size an
d

 p
lacem

en
t tell a story

T
h

e size an
d

 p
lacem

en
t o

f yo
u

r im
age can

 h
ave a d

ram
atic effect o

n
 its im

p
act. H

ere, p
lacin

g a sm
all 

p
o

rtrait at th
e b

o
tto

m
 o

f an
 em

p
ty fi

eld
 is all it takes to

 create a layo
u

t th
at p

erfectly illu
strates its w

o
rd

s.

Th
e

 p
o

w
e

r o
f e

m
p

ty sp
a

ce
This layout m

akes it easy to see that 
em

pty space isn’t em
pty but has m

ass, 
volum

e and real pow
er. The huge black 

field ungulfs our unfortunate C
EO

 and 
creates a sense of heaviness, isolation 
and distance. W

hat m
akes this happen 

is her sm
all size, extrem

ely low
 place-

m
ent and faraw

ay gaze. H
er dark suit is 

a bonus, fading into the background and 
leaving her som

ber expression in sharp 
contrast. H

eadline and text styles m
ust 

be plain and in a neutral position (no 
tension) to not steal attention.
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N
o

 scisso
rs re

q
u

ire
d

! 
The scraps look pasted on, but that’s a 
com

puterized illusion—
this announce-

m
ent is printed in one piece right 

on your desktop. W
rite som

e playful 
w

ords, scan your paper, then in P
hoto-

shop cut it to pieces, apply drop shad-
ow

s, m
ove each piece to its ow

n layer, 
arrange and print. Try it!

Fill and apply a shadow
.

C
reate a selection.

W
rite and scan the w

ords.

D
esign  A

 card
 m

ad
e of scrap

s

To
 an

n
o

u
n

ce th
e b

irth
 o

f th
eir so

n
 D

rew
, o

u
r frien

d
s D

aw
n

 an
d

 M
ich

ael w
an

ted
 to

 sen
d

 an
 en

gagin
g, 

p
erso

n
al card

—
an

d
 w

h
at’s m

o
re p

erso
n

al th
an

 yo
u

r ow
n

 h
an

d
w

ritin
g? W

e like w
h

at th
ey m

ad
e:

F
ro

n
t

In
sid

e

H
a

n
d

w
ritte

n
 “love” subs as a signature.

D
ra

w
 th

re
e

 re
cta

n
g

le
s w

ith the R
ounded R

ect-
angle tool (left). In the Layers palette, double-click 
Layer 1 and renam

e it “Tabs.” Edit>
C

opy all three 
tabs. N

ext, apply a drop shadow
: G

o to Effect>
 

Stylize>
D

rop Shadow
, activate P

review
, enter: 

M
ode: M

ultiply; O
pacity 50%

; X
 O

ffset 0; Y
 O

ffset 
0p2; B

lur: 0p2; C
olor B

lack. C
lick O

K
. Lock this 

layer. N
ext, click on the C

reate N
ew

 Layer icon 
(inset), and nam

e it “H
ighlight.” G

o to Edit>
Paste 

in Front. Finally, create 
a “Type” layer, set your 
type, and m

ove this 
layer below

 the “H
igh-

light layer.”

A
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ld
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 sh
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C
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 cu
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 h

ig
h

lig
h

t W
e need 

to draw
 a line that w

ill bisect the three tabs. 
Select the “H

ighlight” layer. U
sing the P

en Tool, 
draw

 a sm
ooth curve (above). P

ress the Shift key, 
select the curve and all three tabs, and go to 
W

indow
>

Pathfinder. C
lick D

ivide (below
) to divide 

the shapes into six segm
ents.

R
e

ve
a

l th
e

 fi
g

u
re

s W
ith the segm

ents still 
selected, change their Fill color to w

hite. N
ext, 

use the D
irect Selection Tool (hollow

 arrow
) to 

select the bottom
 segm

ents, and press D
elete. 

Finally, select the top segm
ents and low

er their 
opacity in the W

indow
>

Transparency dialog box. 
H

ere, w
e specified an opacity of 60%

.
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