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	      Chapter
	      1


Introduction



Mac OS X Lion represents the pinnacle of software engineering. I confidently assert this as somebody who’s not only used every operating system on practically every type of computer but also written entire magazines and books about them.[1]


Put simply, OS X “just works,” and like millions of others, I value that. Whenever I use a Windows computer, with its stubborn pauses and its tendency to make users jump through hoops, I’m reminded of the luxury in store whenever I boot my Mac. 

But as much as I enjoy fuss-free computing, I’m also a tweaker. It’s in my nature to try and find secret settings and hidden features. I’m addicted to the Wow! moment of uncovering something new and cool, often something nobody else knows about. 

This is what inspired me to write Mac Kung Fu. No other book has the same obsessive depth, and no other author has the same drive to raid the catacombs of OS X to find fascinating treasure.

The 300+ tips you’ll find over the coming pages had to fulfill one or more of the following criteria to find their way into this book:


	
They had to be genuinely useful for Mac newcomers and old hands alike (even Mac experts will find lots to enjoy here).



	
They had to genuinely improve the way you use your Mac. 



	
They had to show the amazing things that can be done with a Mac computer using OS X.



	
They had to be fun and interesting.





Over four hundred tips were written initially, which were then whittled down to the three hundred or so gems in the book. Not all the tips are barnstormers. Some point out very subtle tricks. But even these could change the way you work. 

Throughout the book I assume you know the basics of Mac operation, something that usually comes after a week or two of using a Mac if you’re a newcomer. In other words, I don’t waste time explaining the insanely obvious. But you will find many tips pointing out lesser-known features of OS X as well as tricks to refine your workflow, often exploiting hidden settings. This book is all about wringing every drop of usability from OS X.




1.1 How to Read This Book


		In a nutshell, Mac Kung Fu is a big book of tips. As such, I don’t recommend any particular way of reading it. You don’t need to be sitting beside your computer to do so. The whole point of Mac Kung Fu is that you can jump in anywhere. Start at the beginning, or start in the middle. You could even start at the end and work your way to the front. Just start reading. If you find a tip you like, then try it!

Some tips are more complex than others, and some involve editing system files. A good rule of thumb is that if you’re unsure about what you’re doing, then skip that particular tip and perhaps return to it later when you feel more confident.

The tips were written for OS X Lion. That isn’t to say many won’t work on previous releases of OS X, such as Snow Leopard. However, I’ve only tested the tips against OS X Lion, and much of the terminology changed in the Lion release. If you do intend to use the book with an older release, some common sense will go a long way.




1.2 For All Macs—No Add-Ons Required!

All this book requires is a Mac computer running OS X Lion. Nothing else. You might own a MacBook, MacBook Pro, MacBook Air, iMac, Mac Mini, or Mac Pro. It doesn’t matter, although a handful of tips talk about getting the most from portable Macs. 

None of the tips require you to buy more software. All the tips enhance, harness, or tweak built-in functionality. A small fraction of the tips discuss downloading some add-in software to add vital functionality that’s missing from OS X, but the software mentioned is always free of charge.




1.3 Acknowledgments


		Thanks go to the Pragmatic Programmers for not slamming the door in the face of a crazy guy who suggested a one-chapter book full of things he thinks are cool. Thanks also to Jackie Carter, my editor, plus the people at the Pragmatic Bookshelf, who are among the most switched-on individuals I’ve ever met. 
	


		I’m also grateful to the technical reviewers who put this book through its paces prior to its release and who often suggested important improvements. My gratitude goes out to Daniel Bretoi, Patrick Burleson, Bill Dudney, Isaac Dudney, Kevin W. Gisi, Jon Kurz, Wesley Matlock, Angela Murtha, Mike Riley, and Matt Swain. 
	

Finally, thanks to the beta testers who took a chance on this book before it was officially published. Your errata comments made Mac Kung Fu a stronger book.
	




1.4 Sharing


		If you’d like to share some of the tips from this book on your blog, then feel free. It’s unlikely my publisher will be too happy if you take liberties, but sharing a couple of tips you’ve found useful can only be a good thing. If you do, it would be great if you could mention the book and provide a link to the book’s official web page—http://pragprog.com/book/ktmack/mac-kung-fu.
	




Keir Thomas

November 2011
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	      Chapter
	      2


Getting the Most from the Tips



There are over three hundred tips in this book, and you can jump in anywhere. They’re in no particular order, and you don’t have to start at the beginning! If you’re looking for tips on a particular topic or function of OS X Lion, use the index at the back of the book.

Mixed in with the tips are a series of sidebars that concisely explain features of OS X Lion you might have overlooked. The goal is simply to introduce you to key productivity features of OS X.

Here are some notes to help you get the most from the tips.




2.1 Activating Secret Settings via Typed Commands

Some tips involve typing configuration commands within a Terminal window in order to activate secret or experimental settings. Unfortunately, there’s no way to avoid this. 

If you’ve never used the command line before, this can be a little daunting, but don’t worry—it’s surprisingly straightforward. Just type what you see, then hit Return. Make sure you type the command exactly as it appears on the page. Of course, if you’re reading Mac Kung Fu as an eBook on your Mac,[2] you can simply copy and paste the command straight into the Terminal window.

Most of these commands make changes only to your user account. Other users won’t be affected. Tips that affect the entire system are clearly marked!

After hitting Return when you are typing commands, you won’t see anything like “Command completed!” or “OK.” If you see no feedback, that’s a good sign—it means everything worked. If there’s an error, it probably means you’ve mistyped. OS X is usually clever enough not to make any changes should that happen. Just try again. 

Sometimes commands are too long to fit on one line of the book—an inherent limitation of both printed and electronic books. In such a case, the remainder of the line is indented beneath it, and you should type the entire line, hitting Return only at the end.

Usually you’ll be shown the command that activates the secret feature discussed in the tip, followed by the command that turns it off again should you wish to do so. 




2.2 Using the Apple and Application Menus

Some tips refer to the Apple menu. Other tips refer to the application menu. The Apple menu is the menu at the top left of the screen, signified appropriately enough by the Apple logo. 

The application menu is the menu to the right of this, usually named after the application in question and in bold text. 

The main menu simply refers to the entire menu along the top of the screen.




2.3 Making a Time Machine Backup

It’s generally good advice to make use of the Time Machine backup utility, if you aren’t already doing so (see ​Exploring OS X Lion: Time Machine​). Even better advice is to have Time Machine perform a backup before undertaking some tips in this book that tweak system files. To do so, click the Time Machine icon at the top right of the screen and select Back Up Now from the menu that appears.
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Figure 1. Activating right-clicking with an Apple mouse








2.4 Using the Mouse or Trackpad

Some tips require you to right-click to access special, context-sensitive menus. If you’re using a standard PC mouse with two (or more) buttons, you’ll find the right mouse button works fine. If you’re using an Apple-manufactured mouse or trackpad, there are a variety of ways of right-clicking, as follows:


	
Hold down Control and left-click in the usual way.



	
If you’re using a trackpad, bunch two fingers together and click.



	
If you’re using an Apple Magic Mouse, open System Preferences (Apple menu→System Preferences), click the Mouse icon, then put a check alongside Secondary Click. From then on you can depress the top-right side of the mouse to right-click.



	
If you’re using an Apple mouse (formerly called the Apple Mighty Mouse), open System Preferences (Apple menu→System Preferences), click the Mouse icon, and change the dropdown menu pointing to the top right of the mouse to read Secondary Button. See Figure 1, ​Activating right-clicking with an Apple mouse​.





New iMacs come with a Magic Mouse, which can be identified by its entirely smooth surface. Desktop Mac users with older computers might have an Apple mouse, which features a scroll ball.

Several tips in this book make reference to trackpad gestures. In nearly all cases these require a multitouch trackpad, such as the standalone Magic Trackpad or the glass “buttonless” trackpads that have been featured in the MacBook range since late 2008.




2.5 Having an Admin Account

Most tips presented here assume you will be using an admin account. This is the standard type of account created when you first set up your Mac. If you share your Mac with somebody else, the other user might have created a standard account or even one managed with parental controls for you to use. You’ll need to speak with this person about getting a full admin account before proceeding with the tips.




2.6 Logging Out and Back In 

Sometimes you’ll have to log out and then back in again to make the changes active. To do this, save all your files, click the Apple menu, and then choose the Log Out option. On the main login screen that subsequently appears, click the icon representing your user account and enter your password when prompted. 




2.7 Using Program Windows

In this book I make frequent reference to common program window elements. Most are obvious, but to avoid confusion and get more details, see the following list and check out Figure 2, ​Program window controls referenced in this book​:


	
Tabs: Clicking each tab button takes you to a different sheet with a different page of options. The current tab button is darkened.



	
Checkboxes: Clicking puts a check in the box, activating that particular feature. Clicking again removes the check, deactivating that feature. Multiple checkboxes can be selected.



	
Radio buttons: Like checkboxes, clicking in the circle activates that feature. The difference is that with radio buttons, you can select only one choice within the options offered.



	
Dropdown lists: Clicking a dropdown list shows a menu from which you can select an option. 



	
Padlock: When the padlock is locked in a System Preferences window, only trivial options can be edited. Clicking the padlock will prompt you for your login password and allow access to all other options.
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Figure 2. Program window controls referenced in this book








2.8 Using the Mac Keyboard and Shortcuts

Lastly, a word about the Mac keyboard. Over the years, the various Mac modifier keys have been renamed a few times, leading to some confusion. Further confusion is caused by the fact that different countries refer to the keys in different ways.

Throughout this book I simply refer to the keys by the names that appear on modern American English Mac keyboards—Command or Option, for example. 

If you see something like Command+Space, that’s an instruction to hold down the Command key and then hit Space. Another example is Option+Command+D, which is an instruction to hold down Option and Command before hitting the D key.

For reference purposes you might find the following table useful. It explains the location and alternative names of the Mac’s various function keys.




	
Key


	
Description







	

Command



	
The key immediately to the left and right of the spacebar on most Mac keyboards. Sometimes this is labeled with the word Cmd instead. This is the Mac’s primary modifier key. It features the ⌘ symbol, and on older keyboards it also uses the  symbol. Because of this it’s sometimes referred to in the wider world as the Apple key.





	

Option



	
The key on the second left (and second right) of the spacebar on most Mac keyboards, also sometimes labeled Alt and features the ⌥ symbol on older Mac keyboards.





	

Control



	
The Control key at the bottom left of most Mac keyboards (and sometimes duplicated at the bottom right of the main keyboard, depending on the model of keyboard). Sometimes labeled Ctrl and indicated by the ⌃ symbol in Mac programs. 





	

Fn



	
The Function key, at the bottom left of MacBook keyboards and also the Apple wireless keyboard; at the left of the home key cluster on full-sized aluminum keyboards. Switches the hotkeys that do things like adjust screen brightness so that they operate like traditional F1, F2, F3 buttons, etc. It also modifies various other keys.





	

Shift



	
The Shift keys, on the first-from-bottom row of the keyboard, at the left and right. The keys sometimes feature the ⇧ symbol.





	

Tab



	
The Tab key, located to the left of the main QWERTY row of keys. Sometimes has the symbol ⇥.





	

Return



	
The Return/Enter key, used to end a line of text and begin a new one, as well as to complete typed commands. Sometimes has the symbol ↩.





	

Delete



	
The Delete key, used to erase a character behind the cursor and located at the top right of the main keyboard beneath the Eject key. (This is different from the forward delete key, indicated by a ⌫ symbol and found on full-sized Mac keyboards within the home key cluster.)





	

Eject



	
The Eject key, located at the top right of the main keyboard and featuring the standard eject symbol. Used to eject CDs/DVDs from the CD/DVD-ROM drive.





	
Cursor keys


	
The cursor keys (indicated by arrow symbols like ←, →, ↑, and ↓) are located at the bottom right of portable Mac keyboards and Apple wireless keyboards and in the right-hand third of wired keyboards.







Several tips in this book refer to default OS X Lion keyboard shortcuts for Mission Control. If you’ve upgraded from OS X Snow Leopard, you might find some shortcuts are slightly different. To switch to the defaults, open System Preferences (Apple menu→System Preferences), click the Keyboard icon, then ensure the Keyboard Shortcuts tab is selected. In the list on the left, select Mission Control and then click the Restore Defaults button. You can then quit System Preferences.



Footnotes



	
[2]

	
Amazon offers a Mac version of its Kindle software: http://www.amazon.com/gp/kindle/mac.
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The Tips







	Tip 1
	See the iTunes Track in the Dock




Here’s a handy little tweak for the Dock that will cause a pop-up window to momentarily appear each time iTunes begins playing a new track (see Figure 3, ​A pop-out window showing the current iTunes track​). It’s so useful that it’s hard to believe it isn’t activated by default or is at least an official preference option. But it isn’t. 

Quit iTunes if it’s open, then open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock itunes-notifications -bool TRUE;killall Dock​





Then start iTunes and try playing a track. Neat, eh? The pop-up fades away after a few seconds.

To add the iTunes icon to the pop-up window, type the following into a Terminal window:



	 
	
​defaults write com.apple.dock notification-always-show-image -bool TRUE;​




	 
	
​        killall Dock​





To deactivate the pop-up at a later date, quit iTunes again, then open a Terminal window and type the following two lines:



	 
	
​defaults delete com.apple.dock itunes-notifications​




	 
	
​defaults delete com.apple.dock notification-always-show-image;killall Dock​
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Figure 3. A pop-out window showing the current iTunes track











	Tip 2
	Turn Off Fade and Pop-Up Animated Effects




Call me a cynic, but it feels like OS X is a little showy with its visual effects. Dialog boxes and some program windows pop onto the screen from nowhere. This design mirrors the iPod and iPad user experience. On a larger screen, however, the effect can be unsettling.

Wouldn’t it be nice if things just appeared on screen with no fuss, like they did in the good old days?

Here’s how you can turn off the majority of OS X’s visual effects.

Pop-Up Windows and Dialogs

To turn off dialog boxes and windows that spring out from the middle of the screen, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write -g NSAutomaticWindowAnimationsEnabled -bool FALSE​





Then log out and back in again for the changes to take effect.

To restore the effect, open a Terminal window and type the following, logging out and back in again afterward to make the changes take effect:



	 
	
​defaults delete -g NSAutomaticWindowAnimationsEnabled​





Quick Look

Quick Look windows appear when you select a file and hit Space. They show a preview of the file’s contents. You can stop Quick Look windows from springing up from the file in question by typing the following into a Terminal window (this change will also remove the effect of the Quick Look window shrinking back into the file):



	 
	
​defaults write com.apple.finder QLPanelAnimationDuration -int 0;killall​




	 
	
​        Finder​





The change will take effect immediately. To restore the effect, open a Terminal window and type the following (again, the change will take effect immediately):



	 
	
​defaults delete com.apple.finder QLPanelAnimationDuration;killall Finder​





Mission Control

To turn off the Mission Control zoom effects that appear whenever it’s activated and deactivated, open a Terminal window and type the following:



	 
	
​defaults write com.apple.dock expose-animation-duration -int 0;killall Dock​





The changes take effect immediately. Note that this also removes the animated effect of windows zooming out of the way when Show Desktop is activated (usually via the “finger spread” trackpad gesture).

To revert to the default animated Mission Control effects, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock expose-animation-duration;killall Dock​





File and Print Dialog Boxes

To stop the Save and Print dialog boxes from sliding out and down from the title bar of each application, open a Terminal window and type the following:



	 
	
​defaults write -g NSWindowResizeTime -float 0.01​





You’ll need to log out and in again for the changes to take effect.

If you wish to reintroduce the visual effects at a later date, type the following, logging out and back in again afterward for the changes to take effect:



	 
	
​defaults delete -g NSWindowResizeTime​






Exploring OS X Lion: Quick Look


Quick Look is a simple feature that lets you instantly preview the contents of files without having to open them in an application. To use Quick Look, just select a file in a Finder window or on the desktop and hit Space (or right-click the file and select Quick Look from the menu that appears). Its contents will be instantly viewable in a pop-up window that will disappear if you hit Space again or click the close button.

Quick Look understands most commonly used files, including Microsoft Office and iWork documents, images, and movies. The document formatting within Office documents isn’t always great, but you can at least get an idea of the file’s contents.

You select several documents at once and take a Quick Look at them as described above (hit Space or right-click and select Quick Look). They’ll be arranged in a gallery within the Quick Look window, so you can rapidly glance through their contents.





Launchpad

A hidden setting can be tweaked to make Launchpad appear and disappear instantly. To activate it, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following two lines, hitting Return after each:



	 
	
​defaults write com.apple.dock springboard-show-duration -int 0​




	 
	
​defaults write com.apple.dock springboard-hide-duration -int 0;killall Dock​





The changes take effect instantly. To revert to the previous animated effect, open a Terminal window again and type the following two lines:



	 
	
​defaults delete com.apple.dock springboard-show-duration​




	 
	
​defaults delete com.apple.dock springboard-hide-duration;killall Dock​





You can also reduce the amount of time the individual app list pages of Launchpad take to scroll in and out. Open a Terminal window and type the following if you want the pages to slide in and out instantly:



	 
	
​defaults write com.apple.dock springboard-page-duration -int 0;killall Dock​





The changes take effect immediately. To revert back to the default, open a Terminal window and type the following: 



	 
	
​defaults delete com.apple.dock springboard-page-duration;killall Dock​





Dock

The Dock can be hidden so that it slides off the screen when not being used. This saves a little screen space. Nudging the cursor against the edge of the screen where the Dock is normally positioned will make it slide back into view again. To turn this feature on or off, right-click the dashed lines between the main Dock icons and the stacks and select Turn Hiding On or Turn Hiding Off. 

To make the Dock instantly leap back into view when it’s needed, rather than slide, open a Terminal window and type the following:



	 
	
​defaults write com.apple.dock autohide-time-modifier -int 0;killall Dock​





To revert back to the default sliding effect, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock autohide-time-modifier;killall Dock​











	Tip 3
	Start Apps Without the Mouse




A quick way to start an app that you don’t have in the Dock is to hit Command+Space and begin typing its name. Command+Space activates the Spotlight search tool, and this will autocomplete the program name after just a few letters, selecting it automatically. All you need do is hit Return to run the app. I often use this to start programs I already have in the Dock if I don’t want to take my hands off the keyboard.







	Tip 4
	Select Text Within a Quick Look Preview Window




If you use Quick Look to view any files that feature text—such as PDFs or Word documents—you’ll notice that 	you can’t click and drag to highlight text. Clicking anywhere on the Quick Look window simply moves it around.

However, a secret setting will let you click and drag as usual to highlight text, and you can use the standard key combination of Command+C to copy text. The Quick Look window can still be moved around the screen by clicking and dragging its title bar, as with any other program window.

To activate the setting, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.finder QLEnableTextSelection -bool TRUE;killall​




	 
	
​        Finder​





The changes take effect immediately. To deactivate the setting, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.finder QLEnableTextSelection;killall Finder​











	Tip 5
	Make Resizing Windows Easier




You can resize any program window by hovering the mouse cursor over any of its borders until it changes to an arrow cursor and then clicking and dragging. However, it can be very difficult to get the mouse cursor in exactly the right spot.

Tweaking the following secret setting will increase the area in which the resizing cursor will activate. Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write -g AppleEdgeResizeExteriorSize 10​





Then log out and back in again for the changes to take effect. You should now find that the cursor changes to the resize cursor when it’s close to the outside edge of a window and no longer has to be precisely placed on the very edge.

To revert to the default setting, open a Terminal window and type the following:



	 
	
​defaults delete -g AppleEdgeResizeExteriorSize​





Log out and back in again for the changes to take effect.

For easier resizing of windows, you can also hold down either Option or Shift (or both) as you click and drag any edge. The latter causes windows to contract vertically at both sides as you click and drag (a concertina effect), while the former shrinks the entire window—the equivalent of clicking and dragging a corner. Used together they cause the window to shrink into or out of its center point.







	Tip 6
	Get to the Dock During Full-Screen Mode




Many Mac apps, such as Safari and Mail, can run in full-screen mode, in which case they occupy a Mission Control space all of their own. Switching an app to full-screen mode is usually done by clicking the small icon at the top right corner of the program window. Full-screen mode hides the menu bar at the top of the screen, along with the Dock. You can make the menu bar appear again by pushing your mouse cursor against the top edge of the screen and waiting for a second, but the same doesn’t work with the Dock. Push it against the Dock’s usual location on the screen and it resolutely refuses to appear. 

In fact, it will appear, but you have to perform an odd little trick—push the mouse cursor against the edge of the screen where the Dock is normally positioned, then pause for a second before pushing again. This will cause the Dock to move into view. It takes a little bit of practice, so give it a go!







	Tip 7
	Switch Desktop Space by Nudging




If you use more than one desktop space, you might already know that if you click and drag program windows to the far right (or left) side of a screen, you can “nudge” the window into the next desktop space. To do this, drag the window so that the mouse cursor cannot move any further against the screen edge.

There’s a one- or two-second delay before OS X switches to the neighboring desktop space, and you can speed this up using a hidden setting, as follows:



	 
	
​defaults write com.apple.dock workspaces-edge-delay -float 0;killall Dock​





The desktop space will now change as soon as you touch the edge of the screen. I find this useful, but if you’d like a split-second delay before the desktop space switches, try the following:



	 
	
​defaults write com.apple.dock workspaces-edge-delay -float 0.15;killall Dock​





To revert to the default second or two delay at a later date, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock workspaces-edge-delay;killall Dock​











	Tip 8
	Protect USB Memory Sticks with a Password




Lots of people use USB memory sticks to transfer data from one computer to another or just to keep their files with them at all times.

OS X Lion lets you format a USB memory stick so that its contents are encrypted. You’ll need to enter a password whenever it’s inserted.
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Figure 4. Creating a password-protected USB memory stick





Essentially this turns any USB stick into a ultrasecure portable file storage device, of the type often sold at a premium. However, bear in mind that the memory stick will only work on Macs also running OS X Lion and not on Macs running earlier versions of OS X or on PCs running Windows or Linux. To those operating systems, the memory stick will appear to be unformatted or corrupted. For a way of creating a cross-platform encrypted archive that you can store on a USB memory stick, see Tip 110, ​Create Encrypted Archives for All Computers​. 

For this tip to work, you’ll need a memory stick of any size. Be aware that files already on the stick will be deleted during the formatting process, so you should temporarily copy them to a safe location and then copy them back once the following procedure is finished.


	
Start by opening Disk Utility (Finder→Applications→Utilities→Disk Utility) and then insert the USB memory stick you intend to use.



	
Look for the memory stick’s entry in the list of disks on the left side of the Disk Utility window. It will probably be identified by its size. Select the entry, but make sure that you select the disk itself and not the partition(s), which will be listed below and indented slightly. For example, see Figure 4, ​Creating a password-protected USB memory stick​.



	
Click the Erase tab in the Disk Utility window. In the dropdown menu alongside the Format heading, select Mac OS Extended (Journaled, Encrypted). In the Name field, type whatever you wish to call the memory stick. This name will appear in Finder’s sidebar whenever you insert the stick in future.



	
Click the Erase button. You’ll be prompted to enter a password and verify it by typing it again immediately below. It’s important that you don’t forget this password! If you do there is absolutely no way of recovering the contents of the memory stick—they’re lost forever. However, you will be able to reformat the memory stick so you can keep using it. Because of the risk, it’s a good idea to type something in the Hint field that might provide a clue to what the password is—the hint will appear in future should you get stuck when entering the password.



	
When you are done, click the Erase button in the dialog box. Erasing, partitioning, and encrypting will take a minute or two depending on the size of the memory stick. Once you’re done, the new memory stick will be ready for use. You can copy files to it by selecting its entry in the sidebar of Finder. You can also close Disk Utility. 





From now on you can use the encrypted memory stick just like any other memory stick. Before physically unplugging it, be sure to eject it by clicking the Eject button next to the disk’s entry within Finder.

When you insert the memory stick, you’ll be prompted for the password. If when prompted for the password, you put a check in the box next to Remember the Password in My Keychain, you’ll never be prompted for the password again on that computer. However, if it’s inserted into another Mac, the password prompt will appear. Therefore, you’ll have a USB memory stick that—essentially—works seamlessly on your computer but whose data is inaccessible to anyone else.

Note that the steps outlined in this tip are not limited to USB memory sticks. You could encrypt an entire portable USB, Firewire, or Thunderbolt hard disk in this way, making it so that the contents will only be accessible upon entry of a password. Bear in mind that accessing an encrypted drive might be a little slower. However, this effect is only likely if you regularly save large files such as movies there. 







	Tip 9
	Where Does Your Wallpaper Live?




This is a quirky but potentially useful tip that will make your Mac tell you the file location of the wallpaper you’re currently using.

Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock desktop-picture-show-debug-text -bool TRUE;​




	 
	
​        killall Dock​





You should now find the filename and path of the wallpaper across the middle of the desktop—even when you access Mission Control and Dashboard.

To revert back to having no filename and path displayed, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock desktop-picture-show-debug-text;killall Dock​











	Tip 10
	Summarize Any Document




Some word processors include text-summarizing tools that can take salient points from several paragraphs (or even pages) and present them in a single paragraph or series of paragraphs. The summary is often a bit hit-and-miss, but it can be a good place to start if you lack the time to do the full job yourself. Your Mac includes a built-in tool to do this.

Setting Up the Service

Some initial setup is needed before you can make regular use of this tool. Open System Preferences (Apple menu→System Preferences), click the Keyboard icon, and ensure the Keyboard Shortcuts tab is activated. In the list on the left, select Services. Then put a check next to Summarize under the Text heading in the list on the right. Close System Preferences.

Summarizing Text

From now on, to summarize text just highlight the text in the program window and click the application menu, followed by Services, and then the Summarize entry. Not all apps are compatible with Services and therefore won’t offer this feature—Microsoft Word 20 is OK, but Word 2008 is a particularly annoying offender. However, it works fine in built-in OS X apps as well as in most Adobe apps that deal with text, like InDesign.

To use the Summary tool, click the Sentences or Paragraphs radio buttons to choose between summarizing text as a series of discrete sentences or as a series of paragraphs. The Summary Size slider adjusts the length of the summary, that is, it adjusts how much of the original text remains within the summary.







	Tip 11
	Activate Stacks and Mission Control by a Gesture




This is a neat little hack that lets you activate stacks within the Dock by hovering over it and making the scroll gesture on a multitouch trackpad or Magic Mouse or by rolling the scroll wheel on a mouse. 

Do the same trick while hovering the mouse cursor over an app icon in the Dock, and App Exposé will activate. You will see open program windows for that particular app and—with compatible apps—the app’s document history. This is similar to the App Exposé option within the More Gestures section of the Trackpad entry within System Preferences.

However, in each case, once you’ve activated the secret setting, you need to scroll up to activate (that is, to make the stack expand), and then scroll down to deactivate (to make the stack hide again). You’ll need to scroll a substantial amount to activate the feature so that OS X knows you’re doing it on purpose and not accidentally. In other words, you’ll need to flick the scroll wheel up rather than just rotate it a few clicks. 

To activate this hidden feature, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock scroll-to-open -bool TRUE;killall Dock​





The changes take effect immediately. To deactivate this feature, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock scroll-to-open;killall Dock​











	Tip 12
	Quickly Create a List of Files




Need to quickly create a text list of file and folder names within a directory? Open the directory in Finder and select all (Command+A), then copy to the clipboard (Command+C). Then open TextEdit, switch to plain text mode (Format→Make Plain Text, or Command+Shift+T) and hit Command+V to paste. Don’t worry—you won’t paste the actual files into the document. Instead, you’ll see a text list of the files and folders. This will work in any text-mode editor as well as in some word processors, such as Microsoft Word.







	Tip 13
	Take Ultimate Control of Scrolling




Here’s a series of tips designed to give you more control over scrolling within Finder windows or when scrolling through documents and web pages.

Turning Off Inverted Scrolling

Compared to other operating systems, OS X inverts scrolling when you turn the mouse wheel or use the two-finger scroll gesture on a multitouch trackpad or Magic Mouse. It’s entirely possible to get used to this, but if you just can’t, here’s how to turn it off, listed by pointing device:


	
Apple Magic Mouse: Open System Preferences (Apple menu→System Preferences), click the Mouse icon, then select the Point & Click tab. Remove the check next to Scroll Direction: Natural. The changes will take effect immediately.



	
Other Mice (including the Apple mouse): Open System Preferences (Apple menu→System Preferences), click the Mouse icon, and remove the check next to Move Content in the Direction of Finger Movement when Scrolling or Navigating. The changes will take effect immediately.



	
Trackpad: Open System Preferences (Apple menu→System Preferences), click the Trackpad icon, then select the Scroll & Zoom tab. Remove the check next to Scroll Direction: Natural. The changes will take effect immediately.





Always Showing Scrollbars

OS X Lion hides scrollbars when they’re not in use. To always show them, open System Preferences (Apple menu→System Preferences), click the General icon, and then click the radio button alongside the Always entry next to Show Scroll Bars.

Turning Off Inertia Scrolling

OS X Lion tries to mirror the experience of using an iPad or iPhone, and this includes inertia scrolling, where the page scrolls rapidly should you flick two fingers across a multitouch trackpad or Magic Mouse surface. What’s actually happening is that the trackpad or mouse is sensing any acceleration in the finger gesture before you lift your finger from the surface. As such, it’s not perfect and you might see acceleration occurring accidentally. Additionally, I find inertia scrolling gives me slight motion sickness on bigger screens.

It’s possible to turn off inertia scrolling within System Preferences, but it’s buried within the Universal Access pane. Start System Preferences (Apple menu→System Preferences) and click the Universal Access icon. Then click the Mouse & Trackpad tab and select the Trackpad Options button. In the dialog box that appears, select Without Inertia from the dropdown list next to the Scrolling checkbox.

This method only turns off inertia for trackpads, however. To turn it off for all pointing devices, including mice, open Terminal (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write -g AppleMomentumScrollSupported -bool FALSE​





Log out and back in again for the change to take effect.

To reenable inertia scrolling, either repeat the steps above to activate it within System Preferences or open a Terminal window and type the following, logging out and back in again for the change to take effect:



	 
	
​defaults delete -g AppleMomentumScrollSupported​





Scrolling Horizontally Using PC Mice

Newer Apple mice have special scroll balls or small trackpads that allow both vertical and horizontal scrolling. Most standard PC mice simply have a scroll wheel that allows only vertical scrolling. However, to scroll horizontally using any mouse, just hold down Shift while turning the wheel. 

Jumping to a New Location Using the Scroll Bars

You can scroll up or down a page in the document or website you’re viewing by clicking the area above or below the scroller in the scrollbar. Usually this will cause the application to scroll page by page. Sometimes, however, you might want to simply jump to a new location in the document without having to scroll one page at a time. To do so, move the cursor to where you want to jump on the scrollbar, hold down Option, and click the mouse button. This will cause the slider to jump instantly to that spot. 

This can be very useful if you want to jump to the beginning or end of a document—just hold down Option and click at the top or bottom of the scroll bar range.

Slowing Down Scrolling

Holding down Option while you click and drag the scroller (the little bar that shows your position within a document in the scrollbar) will slow down scrolling. It’s best shown in practice, so give it a try—grab the scroller in any open window displaying a large file, then hold Option and drag. You see that as well as slowing down, scrolling becomes more fluid, making it easier to read the window contents as they scroll by.







	Tip 14
	Access All Keyboard Functions




Modern Mac portables and the Apple wireless keyboard only have a Delete key, which will delete characters behind the cursor. However, by holding down the Fn key (bottom left of the keyboard), you can turn the Delete key into a forward delete key, which, just like on a full-sized keyboard, will delete characters in front of the cursor.

While we’re on the subject, pressing the Fn key at the same time as the up/down cursor keys will turn them into Page Up/Page Down keys. Holding Fn while hitting the left and right cursor keys transforms them into Home and End keys, respectively, which will either scroll to the beginning/end of the document or move the cursor to the beginning/end of the line, depending on which application you’re using.







	Tip 15
	Fix Ugly Fonts on External Displays




If you attach a non-Apple external display, you might find fonts look a little faint or gritty because the font antialiasing hasn’t been correctly set. The fix is easy—open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following, logging out and back in afterward for the changes to take effect:



	 
	
​defaults -currentHost write -g AppleFontSmoothing -int 2​





Should this method not work for you or if you’re unhappy with the results, open a Terminal window and type the following, logging out and back in again for the changes to take effect:



	 
	
​defaults -currentHost delete -g AppleFontSmoothing​
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Figure 5. Inserting various symbols via keyboard combinations











	Tip 16
	Easily Type Common Symbols and Characters




Here’s how to insert commonly used symbols and characters into your text documents, as shown in Figure 5, ​Inserting various symbols via keyboard combinations​. See also Tip 42, ​Type Diacritical Characters Easily​. Note that this tip assumes you are using a US English keyboard.

Apple symbol

Hit Shift+Option+K to insert an Apple logo () into your text. Bear in mind that the symbol probably won’t appear in documents or emails opened on other operating systems, such as Windows or Linux. Instead, these systems will probably display a square, indicating a missing character. Some Linux systems might display a symbol representing an apple, but not the Apple logo.

Copyright

Hit Option+G to insert a copyright symbol (©) into your text. Typing (c) will achieve the same result in most applications (you’ll need to hit Space after typing for the symbol to appear).

Currency

The dollar sign is typed by hitting Shift+4, as marked on the key. Here’s how to type other common currency symbols:


	
Cent (¢): Option+4




	
Pound sterling (£): Option+3




	
Japanese Yen (¥): Option+Y




	
Euro (€): Shift+Option+2.





Dashes and Ellipses

To type an en dash, hit Option+-. To insert the longer em dash, hit Shift+Option+-.

To type an ellipsis character, that is, three periods in a row that indicate an omission, hit Option+;.

Math Symbols

Many mathematical symbols are easily accessible via marked keys (to insert a less-than symbol, for example, hit Shift+,). However, to insert other mathematical symbols, you’ll need to hit the following key combos:


	
Approximately (≈): Option+X




	
Degree (°): Shift+Option+8




	
Division (÷): Option+/




	
Infinity (∞): Option+5




	
Less than or equal to (≤) and greater than or equal to (≥): Option+, and Option+., respectively.



	
Not equals (≠): Option+=




	
Pi (π): Option+P.



	
Plus/minus (±): Shift+Option+=




	
Square root (√): Option+V




	
Sum (∑): Option+W






Trademark


Option+2 will produce the trademark symbol (™). Typing tm followed by a space will do the same thing in most apps. Option+R inserts the registered trademark symbol (®). Typing (r) will also insert the symbol within most apps.







	Tip 17
	Automatically Rename Photos




Digital cameras seem to like filenames such as DSCF0407.JPG. I don’t know about you, but I prefer names such as Disneyland Vacation 023.jpg. Renaming each and every file can be somewhat annoying, but a quick and easy solution is to use Automator to do it for you (to learn what Automator is, see ​Exploring OS X Lion: Automator​). Here are the steps:


	

	      Create the folder to store the photos. This can be
	      anywhere and called anything you choose. Then copy the
	    image files into it. Make sure you only copy and don’t move the files—keep the originals safe until you’re sure the renaming has worked correctly! 



	
Start the Automator program. It’s among the first programs listed in the Applications view of Finder—its icon is a robot.



	
In the Choose a Type for Your Document dialog that appears, click the Application icon (again, the icon that’s a robot) and then click the Choose button. 



	
The Automator program window is a little daunting, but
	    you can ignore most of it. In the Library list at the
	    left of the Automator program window, select Files &
	    Folders, and then in the list to the right,
	    select Rename Finder Items. Click and drag this menu entry to
	    the right of the program window and release over the
	    spot that reads Drag Actions or Files Here to Build Your
	    Workflow.



	
In the dialog box that appears, you’ll be asked if
	    you want to add an additional action to copy the renamed files. You
	    don’t need to do this, so click the Don’t Add
	    button.



	
You’ll see a new element on screen, headed Add
	    Date or Time. There, click the
	    dropdown that reads Add Date or Time and
	    select Replace Text.



	
You’ll now need to use Finder to browse the store of photographs
	    you want to rename in order to gather
	    some information. Look at the typical filenames
	    generated by your camera and work out which part you
	    wish to replace with your own text. For example, photos
	    from my camera always have a filename that begins with DSCF,
	    followed by a sequential number, followed by the
	    .jpg file extension. A typical filename might be
	    DSCF0404.JPG. In that case, I’d like replace DSCF with
	    something more descriptive, such as the location of the
	    vacation I was taking. 



	
Go back to the Automator program window and in the
	    Find: field of your new action, enter the text you’d like replaced in the
	    filename. (To continue my example, I would type
	    DSCF.) In the Replace: field, type the text you want to
	    appear instead. For example, for my most recent
	    vacation, I might type Disneyland Vacation. See Figure 6, ​Renaming files automatically using Automator​. 
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Figure 6. Renaming files automatically using Automator







	
Once you’ve entered your replacement text, click File→Save and then give
	    your new Automator Action a name. Anything will do, such
	    as Rename Pictures. Choose somewhere to save it to, such
	    as the desktop.



	
Once saved, you can quit the Automator
	    program. There’s no need to click the Run button or
	    test anything. 



	
Your new Automator action icon will be where you
	    saved it, and you can identify it by the same robot icon
	    as the Automator application itself. All you need to do
	    now is drag and drop the image(s) you copied earlier onto the icon. They
	    will instantly be renamed within the folder. Once you are 
	    finished, you can either leave the Automator
action where it is for future use or delete it.











	Tip 18
	Empty the Trash—Securely





  Whenever you empty the Trash, the files are deleted in the standard way, that is, the OS X filesystem makes the space they occupied available for another use. However, the actual content of the files sticks around on the disk until it’s overwritten, and it can be recovered using one of the many third-party file recovery tools available.

To avoid this you can securely empty the Trash, which involves writing over the data with zeroes so that it can’t be recovered (at least outside of a high-tech crime lab), although bear in mind that the files might still exist in your Time Machine backup (see Tip 212, ​Make Time Machine Forget a File​).


Securely Emptying the Trash

To securely empty the Trash, simply click and hold the Trash icon in the Dock until the context menu appears. Let go of the mouse button and then hold down the Command key. The menu will change to read Secure Empty Trash. Click to do so. You can also open a Finder window and click the Secure Empty Trash entry on the Application menu.

Be aware that deleting files securely takes significantly longer than deleting unsecurely. With a very full Trash can, it might take hours. The work of securely emptying the Trash will take place in the background, however. 

Always Emptying the Trash Securely

To always securely empty the Trash, open a Finder window and click the Application menu, then Preferences. Then click the Advanced tab and put a check next to Empty Trash Securely.


Exploring OS X Lion: Mission Control


Mission Control is a multifaceted tool intended to give you a birds-eye view of your applications, among other things. It can be activated by clicking its icon on the Dock or by swiping three fingers up on a multitouch trackpad. It can also be activated by hitting the keyboard hotkey (usually the F3 key) or by tapping Control+Up.

Mission Control shows miniaturized previews of all active program windows so you can see at a glance what files you have open. More importantly, you can click any to bring it to the fore, ready for use. 

But that’s not all Mission Control does. It also lets you add spaces and switch between them. Spaces are additional desktops that slide in and out to replace your main desktop. You could create a new space just for web browser windows, for example, and another just for your mail program. To create a new space in Mission Control, move the cursor to the top right of the screen, where you’ll see a plus icon appear. Click it to create a new space. You can switch between spaces by clicking their thumbnail previews at the top of the screen when Mission Control is active or by holding down Control and tapping the left and right cursor keys. You can also brush three fingers left and right on a multitouch trackpad to switch spaces.

Mission Control also allows quick access to the Dashboard, which is a separate space containing nothing but widgets—small programs with specific functions, such as showing the weather. To access the Dashboard, first activate Mission Control and then click the Dashboard thumbnail at the top left of the screen.

See Tip 25, ​Be a Mission Control Power User​.











	Tip 19
	Personalize Every Icon




Any file can have a custom image assigned to it as its icon—from applications to files to desktop shortcuts—folders too. Here’s how:

Using an Image as an Icon


	
Open the image you want to use as an icon in Preview. Select all (Command+A) and then copy it to the clipboard (Command+C). Close Preview.



	
Click the file whose icon you want to replace and hit Command+I to view the file’s info. In the window that appears, click the icon preview at the very top left. This will highlight the icon. Hit Command+V to paste in the new icon image. The change should take place instantly. 





To restore the original icon, repeat the step to open the file’s info window and again select the icon so it’s highlighted, but this time hit the Delete key. 

Using Icons from Other Files

You can also copy and paste icons from one file to another. Just open the info panel for each file, as described earlier, then highlight the icon in the first file by clicking it. Hit Command+C to copy the icon. Click to highlight the icon in the other info window that you want to replace, then hit Command+V.  

Using this tip you can personalize the entire OS X interface. You can find icon replacements online at a variety of sources.[3] Usually, replacement icons can simply be dragged and dropped onto the icon preview at the top left in the info window, without the need to open and copy them first in Preview. 







	Tip 20
	Discover the Version Numbers of Software




If you want to check the version of an application, you can start it up and click the application’s menu, then click About. Another, quicker way is to select the application in the Applications list in Finder and hit Command+I to bring up the info window. It will be listed under the General heading.







	Tip 21
	Use Dashboard Widgets on the Desktop




Unlike Microsoft Windows, OS X uses the Dashboard space to present applets to the user (known as widgets in Mac-speak). However, with a little hacking you can also put widgets on the desktop. It’s not quite like Windows because the widgets stay on top of every other window, rather than on just the desktop, but for those with large monitors it’s an excellent way of keeping useful widgets like the time and date visible at all times.

Setting Up

To get Dashboard widgets on your desktop, it’s first necessary to turn off the Dashboard being managed by Mission Control. To do this, open System Preferences (Apple menu→System Preferences) and then click the Mission Control icon. Remove the check next to Show Dashboard as a Space. Note that in future to bring up the Dashboard you’ll need to use the keyboard hotkey, if your keyboard features it, or hit F12 (Fn+F12 if you’re using a portable Mac or Mac aluminum keyboard). 

To activate desktop widgets, open a Terminal window (Finder→Applications→Utilities→Terminal) and then type the following at the command prompt:



	 
	
​defaults write com.apple.dashboard devmode -bool TRUE;killall Dock​





The Dock will temporarily slide out of view and the wallpaper might vanish for a second or two, but don’t worry; they’ll come back within seconds. 

Using Desktop Widgets

To bring a Dashboard widget to the desktop, access the Dashboard by hitting the keyboard hotkey or F12 (Fn+F12 on MacBooks or Mac aluminum keyboards) and click and hold the widget you’d like to bring to the desktop. Then, while holding the mouse button down, hit F12 again (or Fn+F12) and hey, presto—you have a Dashboard icon on the desktop.

To put the widget back on the Dashboard, simply repeat the procedure in reverse—click and hold the widget on the desktop, hit F12 (or Fn+F12) to start the Dashboard, and then release the mouse button. 

Deactivating

To turn off desktop Dashboard icons at a later date, either reactivate Mission Control’s management of the Dashboard, as described earlier, or open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dashboard devmode;killall Dock​





Note that after making this change, any widgets left on your desktop will stick around until you manually move them back to the Dashboard, as described previously. However, it will be impossible to move any new widgets to the desktop.







	Tip 22
	Add Folders of Images for Use as Wallpaper




Copy your downloaded wallpaper images to their permanent location on your computer (that is, within your Documents folder, for example) and then open System Preferences (Apple menu→System Preferences) and the Desktop & Screen Saver panel. Select the Desktop tab, then just click and drag the folder onto the left pane of the System Preferences window, under the iPhoto heading. This will instantly add the files to the list of available wallpapers and can be done with any folder containing images.  

To remove the folder at a later date, again open the Desktop & Screen Saver pane within System Preferences, select the folder in the list, and click the minus symbol button. 







	Tip 23
	Screengrab to the Clipboard Rather Than to a File




The Mac OS has sophisticated built-in screen capture software (see Tip 131, ​Take a Picture of the Screen​), which outputs a file to the desktop. To capture a screen to the clipboard instead of creating a file so you can then paste the snapshot into your own document or image, hold down Control in addition to the standard capture shortcuts. For example, Shift+Control+Command+3 will capture the entire screen to the clipboard. Shift+Control+Command+4 will let you click and drag to capture a portion of the screen to the clipboard.







	Tip 24
	Put Notebooks in Deep Sleep to Save Power




Mac notebooks use magnetic case closing mechanisms to keep the lid shut, rather than physical clasps. This makes opening them much more convenient but it also means they can open themselves sometimes, while in a travel bag, for example. Once open, they can switch themselves on and thus waste battery life. They might even create a hazard during a flight if the wireless hardware activates. 

If this is a problem for you, you can set your MacBook to hibernate to disk when the lid is closed, rather than simply go into sleep mode. This turns the computer off completely, rather than keeping the memory alive with a trickle of battery power. 

Setting Up

This tip changes a firmware setting for the entire computer, so it will affect all users.

Open a Terminal window and type the following:



	 
	
​sudo pmset -a hibernatemode 25​





You’ll need to enter your login password when prompted. The changes should take effect right away.

Putting to Sleep and Waking

Give your changes a try by closing the lid and waiting a minute or two for it to hibernate. Then wake your computer (remember, you’ll now need to press the power button each time). Waking a hibernated computer takes a few seconds longer as the RAM contents are read in from disk, but it’s still fast enough for everyday use. 

Putting Desktop Macs to Sleep

For what it’s worth, it isn’t just portable Macs that hibernate—desktop Macs support it too. Once you’ve changed the setting as described earlier, click Apple menu→Sleep to hibernate. After a minute or so the computer will completely power down. To wake the computer from hibernation, depress the power button as usual.

For desktop Macs that take a long time to boot from cold, hibernating can save a few seconds each time you boot.

Restoring the Original Setting

To return to the standard sleep mode at a later date, open a Terminal window and type the following:



	 
	
​sudo pmset -a hibernatemode 3​











	Tip 25
	Be a Mission Control Power User




Mission Control is the Mac feature that, among other things, shows small previews of all open program windows (see ​Exploring OS X Lion: Mission Control​). Although seemingly simple, there’s a handful of useful tricks that can make it the center of your Mac universe, as follows.

Using Quick Look Windows

Quick Look also works in Mission Control. In this case, Quick Look expands windows so it’s possible to fully see their contents. Simply hover the mouse cursor over the window preview you’re interested in and hit Space. Hitting Space again will cause the Quick Look preview to shrink back. 

Moving All Windows at Once

Windows can be moved from space to space by dragging them onto the desktop thumbnails along the top of the screen. You can move all the windows of a particular app to a new space by clicking and dragging the program’s icon to the alternative space. The icon appears beneath the window previews. 

Navigating Easily Using the Keyboard

I prefer to activate Mission Control by holding Control and tapping the up cursor key. Keeping Control depressed, I can then use the left and right cursor keys to switch between desktop spaces within Mission Control (for what it’s worth, holding Control and tapping left and right when Mission Control isn’t active will also switch desktop spaces.)

After you’ve switched to Mission Control, holding Option when clicking a different desktop space thumbnail with the mouse will switch to that space so you can see its apps, but the space won’t be activated.

By typing the first few letters of the name of each window, that is, the first word in the title bar of the window, you can move the selection highlight to it. For example, typing Apple will switch to a web browser visiting http://apple.com. Typing Trackpad will switch the highlight to System Preferences when the Trackpad configuration panel is open. However, in my tests this was difficult to master and somewhat unreliable.

Switching Between Apps in App Exposé mode

Mission Control also features App Exposé mode. This mode is like having a personalized Mission Control that only shows the open program windows of a single application, and—in certain apps—shows thumbnails of recently opened apps at the bottom of the screen. 

Once Mission Control is active, you can tap ` (that’s the backtick key, left of the top number row on most keyboards, but sometimes left of Z) to cycle through open apps in App Exposé mode. Just keep tapping it to switch between open apps. However, beware that if an app is active but doesn’t have any files open, all you’ll see is a blank screen, which can be a little confusing.

Hitting Tab will cycle through the apps in the opposite direction but only after the backtick has been hit to activate App Exposé.


Command+Tab will bring up the standard task switcher despite the fact that you’re still in Mission Control; however, selecting an app within the switcher list will show its program windows in App Exposé mode again. 

Note that while in App Exposé mode, the left and right cursor keys will move the highlight between the recently opened files’ thumbnails at the bottom of the screen (if there are any). Hitting Return will then open the highlighted file for editing or viewing.

Unclustering Apps

By hovering the mouse cursor over a cluster of program windows and scrolling up on a multitouch trackpad or Magic Mouse (or scrolling up the mouse wheel with other mice), you can cause the cluster to expand, showing more detail in those behind the main window. 

This trick can be enhanced with a small tweak to a hidden system setting. To make clustered windows expand to full size (similar to using Quick Look, as above) rather than merely a little larger than they normally are, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock expose-cluster-scale -float 1;killall Dock​





The changes take effect immediately. A variation of this tweak is to substitute a value of 0.6 rather than 1 in the line above. This will cause the windows to expand to a larger size than the default but not to 100 percent of their normal dimensions. 

To undo the tweak at a later date, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock expose-cluster-scale;killall Dock​











	Tip 26
	Fix a Slow Boot-Up




If you find there’s a huge delay after the desktop first appears until the computer becomes usable, try cleaning up your desktop by removing as many files, folders, and aliases as you can without impeding your workflow. Either create folders and file things away in them, or put things where they’re supposed to go in your Documents, Movies, etc. folders. Try to have as few icons on your desktop as possible, and definitely try to avoid any that might be automatically turned into thumbnail previews, such as movies and pictures, because this adds to OS X’s workload when it’s already busy loading the system at boot time.

You can turn off icon thumbnailing by right-clicking a blank spot on the desktop and selecting Show View Options. In the dialog that appears, remove the check next to Show Icon Preview. Close the dialog box. The changes take effect immediately.

Also consider pruning the number of programs that start when you boot—see Tip 44, ​Control What Apps Start When Your Mac Boots​.







	Tip 27
	Know Exactly Where You Are in Finder




Finder can show the path to the currently browsed folder (that is, something like Lion→Users→John→Music→MP3 collection). Just click View→Show Path Bar. However, there’s a slight problem—the path is listed from the root of the hard disk up to the current directory. If all you ever do is browse your home directory, then this information isn’t much use and the display can get bunched up very quickly. Luckily there’s a secret setting you can use to cause the path bar to relate everything it shows to your home folder. In other words, should you browse your Pictures folder, the path bar will read something like John→Pictures, rather than Lion→Users→John→Pictures.

Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.finder PathBarRootAtHome -bool TRUE;killall Finder​





The changes will take effect immediately. See Figure 7, ​Improving the Finder path bar: Before and after​. Should you wish at a later date to revert to the default path bar, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.finder PathBarRootAtHome;killall Finder​
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Figure 7. Improving the Finder path bar: Before and after





Bonus tip: Files can be dragged and dropped onto any entry within the path bar to move the file to that location (hold Option before releasing the mouse button to copy the file instead).

For details of how to show the path in the title bar of Finder windows, which can be useful for power users, see Tip 64, ​Show Full Paths in the Title Bar of Finder​.







	Tip 28
	Tweak Launchpad Visual Effects




Here are some tweaks for Launchpad.

Changing the Background Effect

Launchpad uses the desktop wallpaper as a backdrop but blurs it slightly. If you activate Launchpad and hit Command+B, you can cycle through different backdrop effects—a black and white version of the wallpaper; a blurred black and white version of the wallpaper; and no blurring at all, so you simply see the full-color wallpaper. Tap Command+B one more time to restore the default blurred effect.

Adding a Different Transition Effect

By hitting Command+M, you can activate a curious motion blur effect that appears when you move between the various pages of Launchpad. You can turn it off by hitting Command+M again. 

Altering the Background Blurring

You can also alter the degree to which the background blurs. This can create a more subtle effect than the default. To do so, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following, this time replacing X with any number between 0 and 255 (0 is no blur, while 255 is maximum blur):



	 
	
​defaults write com.apple.dock springboard-blur-radius -int 150;killall Dock​





Experiment a little with different settings. Generally speaking, values between 1 and 10 produce the most subtle effects. To revert to the default degree of blur at any point, open a Finder window and type the following:



	 
	
​defaults delete com.apple.dock springboard-blur-radius;killall Dock​











	Tip 29
	Get Better Battery Life on MacBooks




Here are a few tips for getting maximum life from your MacBook, MacBook Pro, or MacBook Air.

Keeping the Display Dim

Modern Mac laptops use LED displays. Although it’s better than the older cold cathode technology when it comes to battery life, running a screen at full brightness will still drain your battery quickly. Whenever I’m using my MacBook Pro, I turn the screen down to as dim as possible, bearing in mind ambient conditions.

Although it’s not rigorously scientific, I used the free utility coconutBattery to find the battery drain on my MacBook Pro at the various screen brightness settings.[4] At maximum brightness the overall power draw on the battery was 16.1 watts. With just three bars showing in the onscreen brightness display—which is arguably the lowest setting at which the display is still usable in daylight—this figure dropped to just 11.5 watts. That’s an improvement in power consumption of about one-third.

Turning Off Keyboard Backlighting

Needless to say, switching off keyboard backlighting is also a good idea if your portable Mac is equipped with this feature. You can do this using the keyboard hotkeys—usually the F5 and F6 keys.

Turning Off Wireless

If you don’t need Wi-Fi or Bluetooth, you can also try turning them off to maximize battery life. To deactivate Wi-Fi, click its icon in the top right of the screen and select Turn Wi-Fi Off. To reactivate it at a later time, repeat the step and this time select Turn Wi-Fi On. To deactivate Bluetooth, open System Preferences (Apple menu→System Preferences), click the Bluetooth icon, and remove the check from the box labeled On. To reactivate Bluetooth later on, repeat the step and ensure the On box is checked. 







	Tip 30
	Apply High-Quality Special Effects to Images




Install the free-of-charge Xcode developer toolkit via the App Store (see Tip 315, ​Continue Your Mac Adventure: Some Must-Have Apps​), then open Finder and hit Shift+Command+G. In the dialog box that appears, type /Developer/Applications/Graphics Tools/. Then double-click Core Image Fun House. This is a small program designed to showcase to programmers OS X’s built-in visual effects, but it also lets anybody apply the effects to images. It’s rather like options typically offered on the Filters or Effects menu of popular image editing apps.

When the program runs, you’ll be prompted to open an image. Once you do so, a floating palette window will let you choose effects to apply (if the palette isn’t visible, click Window→Effect Stack). Simply click the plus button alongside the Image checkbox to bring up a list of effects you can apply to the image. Most of the effects typically found in image editing apps are offered, and once applied, the program will also offer a variety of sliders that will let you adjust the intensity or nature of the effect.

When you’ve finished applying effects, click File→Save As and give the changed file a new name.
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Figure 8. Creating “crazy text“ emails











	Tip 31
	Create “Crazy” Emails




Here’s a fun trick that can be used to send entertaining emails to people on special occasions, such as birthdays.

Open a Finder window, hit Shift+Control+G, then type /Library/Scripts/Mail Scripts/Crazy Message Text.scpt. Double-click the file that’s highlighted in the Finder window. This will open AppleScript Editor, but you can ignore it and simply press the Run button on the AppleScript Editor toolbar. Then follow the prompts in the dialog boxes that appear. Eventually you should end up with something similar to Figure 8, ​Creating “crazy text“ emails​.

You can quit AppleScript Editor once the program has finished. Be sure to check out the other scripts in the /Library/Scripts/Mail Scripts folder. Although they’re intended primarily to show AppleScript’s potential integration with the Mail app, many are very useful in their own right. You can use each the same way—double-click them and click the Run button in the AppleScript Editor window that appears. 


Exploring OS X Lion: Spotlight


Spotlight is OS X’s instant search tool, but it goes far beyond mere files. It indexes emails you receive, for example, and web pages you’ve recently visited. Instant message chats are cataloged. In fact, Spotlight’s goal is to index all information you interact with on your Mac. To see the type of things that are indexed, click the Spotlight icon within System Preferences (Apple menu→System Preferences) and select the Search Results tab. Here you can also tell Spotlight not to index certain types of files by removing the check alongside their entries in the list.

Spotlight also indexes the contents of documents, as well as any other information about them. This means you can search for documents that contain a particular term, such as the name of a project you’re working on. Any documents that contain text are indexed—word processing documents, spreadsheets, and so on.

To access Spotlight, click the magnifying glass icon at the very top right of the screen, or hit Command+Space. Type the search query and then look through the pop-out list of results for what you’re looking for.

Pause the selection highlight over an entry in the list and a Quick Look window will pop out the side of the list, showing a preview of the document.

To open any document, just highlight it and hit Return.











	Tip 32
	Choose What Music to Play—Via a Screen Saver




The iTunes Artwork screen saver is built into OS X and can be chosen using the Desktop & Screen Saver pane within System Preferences (Apple menu→System Preferences). However, it has a feature that elevates it above a mere display of album cover art—hovering your mouse over an individual cover image will reveal a play button, allowing you to start playing that album (or start the track if the image represents a single song). It doesn’t matter if iTunes is not already running—clicking the play button will start iTunes in the background. If iTunes is already playing music, your selected track will override it.

To quit the screen saver, click the Exit button at the bottom right or hit any key.







	Tip 33
	Create a Totally Secure Store for Personal Files




Encrypting data is a good idea if you use a portable Mac because it’ll mean that even if a thief or hacker gets hold of the data, he or she won’t be able to do anything with it. The type of encryption offered by OS X is theoretically unbreakable.

Using FileVault

Perhaps the most comprehensive solution is to enable FileVault full-disk encryption in the Security pane of System Preferences (Apple menu→System Preferences), which ensures that all data on your hard disk is encrypted. However, this can result in about 10 percent slower disk access compared to an unencrypted disk—not enough to notice during everyday use, but it will affect periods of prolonged disk access, such as when you’re booting up. 

Encrypted Archives

As an alternative to FileVault, you can create an encrypted archive. This is like a container file that you can save files into, a little like a USB memory stick except it’s just a file. You can mount and unmount the file whenever you want to add, remove, or view files within it. Mounting is done by simply double-clicking the file and entering the password when prompted. To unmount it, just click the Eject icon next to its entry in the sidebar of Finder—just like you eject a USB memory stick when you’ve finished with it.

Because it’s just a file, the encrypted archive can be transferred to a USB memory stick and should be compatible with other Mac computers (including those running recent versions of OS X, such as Lion and Snow Leopard). Once the encrypted archive is created, you can rest safe in the knowledge that—without the password—absolutely nobody will be able to access the data inside it.

Creating an Encrypted Archive: Step by Step

Here are the steps required to create a password-protected archive:


	
Start Disk Utility, which you can find in the Utilities folder within the Applications view of Finder.



	
On the Disk Utility toolbar, click the New Image button.



	
In the dialog box, type a filename for the archive into the Save As field, and beneath that choose a location where you want to save the archive. Type the same name in the Name field below—this is what’ll appear in Finder whenever you mount your new archive. 



	
In the Format dropdown list, select MS-DOS (FAT). This gives you the ability to create smaller archive containers compared to using Mac disk formats. Don’t worry if this sounds less than perfect—FAT is the same disk format used on USB memory sticks and photographic memory cards. Your Mac is 100 percent compatible with it.



	
In the Size dropdown, select an archive size. Even if they’re empty, OS X archives are still full size. In other words, a 2.5 MB archive will always be 2.5 MB, even if there’s only a tiny 10 KB file in it, and they don’t expand and contract to fit their contents. Choose a size that fits your needs. 



	
In the Encryption dropdown list, select 256-Bit AES Encryption. This is an extremely secure form of encryption that’s as strong and unbreakable as you could need. It’s a little slower if you’re saving massive files to archives, so if you intend to encrypt huge video files and are also impatient, you might like to select the 128-Bit AES Encryption option. This choice is also extremely secure. 



	
Leave the other fields as they are, and click the Create button to begin making the archive.



	
Soon after this, you’ll be prompted to create the password for the archive. You’ll need to type it twice. Don’t forget this password! If you do you’ll never be able to access its contents again. The form of encryption used by OS X is unbreakable. 



	
By checking Remember Password in My Keychain, you can avoid being prompted for the password each time you mount the archive. However, this will mean anybody with access to your computer (for example, somebody walking past) can also mount the archive without being prompted for a password. Once you’re done, click the OK button. 



	
The archive will now be created. To test it, double-click the archive image and enter the password when prompted. It’ll appear as a volume in Finder and will be listed under the Devices heading in exactly the same way as if you’ve inserted a memory stick or a digital camera, and you can drag/drop files into it. 





Don’t forget to eject the disk image after you’ve finished using it by clicking the Eject icon next to its entry in Finder. 

Creating Aliases

You can create aliases to any file within the archive which, when double-clicked, will automatically mount the archive, prompt you for a password (if it’s not in the keychain), and load the file. To do so, drag and drop a file from the archive to the desktop, but before releasing the mouse button, press and hold Option+Command. When you release the mouse button, an alias to the file will be created. However, don’t forget to eject the archive when you’ve finished working on the file!







	Tip 34
	See Every Single Wi-Fi Detail




Once you’ve joined a wireless network, hold down the Option key and click the Wi-Fi icon at the top right of the screen. Along with the usual options of switching networks, you’ll be shown a list of interesting technical details about the connection. 

Checking Signal Strength

For information about signal strength, pay particular attention to the line labeled RSSI (received signal strength indication), about halfway down the list. It’ll probably be a minus figure, like -40 or -73. The closer this figure is to zero, the stronger the signal. So, -30 is better than -50. The scale is from -100 to zero. My experience is that networks beyond -80 are impossible to connect to, but your mileage may vary. See Figure 9, ​Viewing the technical details of a Wi-Fi connection​.

Checking Data Transfer Speeds

The transmit rate figure is also worth paying attention to. It tells you the maximum data speed possible with the connection. For example, at the moment my MacBook Pro’s transmit rate figure reads 54, indicating a 54 Mbit/s connection speed and also indicating I’m connected to the Wi-Fi base station using 802.11g—the older but still widely-used Wi-Fi standard. Using a more modern 802.11n router over a good connection, the transmit rate figure will read anything up to 300, indicating speeds of up to 300 Mbit/s.

Performing a Wi-Fi Diagnostic

Elsewhere in OS X there’s a hidden Wi-Fi diagnostics tool that lets you monitor the performance of the connection, among other things. It’s primarily for those who understand the technical details of how Wi-Fi works, however. To access it, open a Finder window and hit Shift+Command+G and type /System/Library/CoreServices. Then double-click the Wi-Fi Diagnostics entry in the list of files. Click the Learn More button in the program interface to discover what each available option in the program offers. It’s possible to monitor signal strength and noise level using the Monitor Performance option, for example, or to capture raw frames.
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Figure 9. Viewing the technical details of a Wi-Fi connection











	Tip 35
	Quickly Switch Between Input and Output Audio 




Smaller MacBooks come with a single 3.5 mm audio jack, which has the dual purpose of being a line-in audio port and a headphone socket. You can switch between the two modes using the Sound component within System Preferences (Apple menu→System Preferences)—select whichever entry you want from the dropdown menu alongside Use Audio Port For. However, a quicker way to switch is to hold down the Option key and click the volume control icon at the top right of the screen. Then select either Input or Output from the menu that appears.

Note that you can only switch modes if there’s nothing plugged into the socket at the time, such as a pair of headphones.







	Tip 36
	Turn Launchpad into a Personalized App Launcher




Launchpad is the tool that presents a full-screen list of the apps that are installed on your system. Any new apps you install get added to it. The intention is to mirror the experience of using an iPad or iPhone.

If you’re not a fan of Launchpad, keep reading, because tweaking a system file can turn it into something different entirely—a completely personalized full-screen app launcher that contains only the apps you want and nothing else.

Setting Up

To do this we need to radically edit a system database file. The change only affects your user account, but this tip is not without risk. Make a Time Machine backup before starting. 

To make the change, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following, making sure to type the lines exactly as printed. Because of page width limitations, the first command, which should be typed on one line, is split into two. Just continue typing the text on the second line after the first.



	 
	
​sqlite3 ~/Library/Application\ Support/Dock/*.db "DELETE from apps; DELETE​




	 
	
​        from groups WHERE title<>''; DELETE from items WHERE rowid>2;"​




	 
	
​killall Dock​





Populating the New Launchpad

If you activate Launchpad, you should find that it’s empty. You can now fill the Launchpad with your own selection of apps by clicking and dragging them from the Applications list within Finder onto the Dock’s Launchpad icon (clicking and dragging app icons from the Dock to the Launchpad icon will not work).

Note that any new apps you download via the App Store will still be added to your new Launchpad. Unfortunately, there’s no way to avoid this.

Reverting to the Default Launcher

If at any point in the future you want to revert back to a default Launchpad setup showing all your apps, just open a Terminal window and type the following to rebuild the Launchpad from scratch:



	 
	
​defaults write com.apple.dock ResetLaunchPad -bool TRUE;killall Dock​





You might have to give the system a few seconds to rebuild the list of apps from scratch, but you’ll see a progress display when you activate Launchpad. Note that unlike other defaults write commands in this book, there’s no need to undo or remove this configuration tweak—that’s done automatically by the Launchpad reset procedure.







	Tip 37
	Add Word Count to TextEdit




TextEdit is good enough for most light word processing tasks, but it lacks one key feature that students in particular might miss: word count.

Adding a Word Count Feature

This feature can be added using a little AppleScript, as follows (with many thanks to tip creator Mike Riley, author of fellow Pragmatic Bookshelf title Programming Your Home):


	
Start AppleScript Editor, which you’ll find in the Utilities folder within the Applications view of Finder.



	
Type the following code into the main editing area of AppleScript Editor:



	 
	
​tell application "TextEdit"​




	 
	
​set wc to count words of document 1​




	 
	
​if wc is equal to 1 then​




	 
	
​set txt to " word."​




	 
	
​else​




	 
	
​set txt to " words."​




	 
	
​end if​




	 
	
​set result to (wc as string) & txt​




	 
	
​display dialog result with title "Word Count" buttons {"OK"} default​




	 
	
​        button "OK"​




	 
	
​end tell​







	
Click the Compile button on the toolbar to check the code. If you get an error reported, check to ensure you’ve typed everything correctly.



	
Click File→Save As and, in the Save As dialog box, hit Shift+Control+G, then type ~/Library/Scripts/, then hit the Go button.



	
Give the script the filename Word Count, then click the Save button.



	
Ensuring the AppleScript Editor program window is still active, click the program’s menu, then select the Preferences entry. In the dialog box that appears, ensure the General tab is selected and put a check next to the Show Script Menu in Menu Bar heading. This will add a new icon to the top right of the screen. The number of words will appear in a pop-up dialog box.



	
Quit AppleScript Editor.





Using the Word Count Feature

When using TextEdit to perform a word count on a document, click the new Scripts icon at the top right of the screen and click the Word Count entry, which will probably be at the bottom of the list.

Removing the Word Count Feature

To remove the word count feature, open a Finder window, hit Shift+Command+G, then enter ~/Library/Scripts/, before hitting the Go button. Then delete the Word Count file.

Open AppleScript Editor once again, open its preferences dialog box, and remove the check next to Show Script Menu in Menu Bar.







	Tip 38
	Press-and-Hold for Mission Control




Here’s a cool trick that could be useful if you use hotkeys or keyboard shortcuts to activate Mission Control, the Dashboard, or Launchpad.

You might be used to tapping a hotkey once to activate that function and then tapping it again to deactivate. However, if you press and hold a hotkey, that particular function will only remain active for as long as you hold down the key. For example, press and hold the Mission Control/Exposé hotkey, and it will disappear as soon as you take your finger off the key. Give it a try!







	Tip 39
	Open Spotlight Results in Any App




Any entry in Spotlight’s list of results can be clicked and dragged onto a Dock icon in order to open it in that particular application. For example, you could drag a word processing document in the list of results onto TextEdit’s Dock icon to stop it automatically opening in Microsoft Word. 

You can also drag and drop files from Spotlight’s list of results to the desktop or to any open Finder window to instantly create a copy. Hold down Option+Command and you’ll create an alias to the original file instead. 







	Tip 40
	View a Quick Calendar




Although OS X has a built-in calendar application in the form of iCal, I sometimes find myself simply wanting a calendar view of forthcoming months so I can see what day a certain date falls on. There are two ways of getting this on OS X.

Using Dashboard

If you switch to the Dashboard, you can use the iCal widget to view the current month. This is a default widget that should already be set to Show, but it can also be chosen from the widget selection—click the plus icon at the bottom left, then click and drag the widget to the Dashboard.

Creating at the Command Line

I also make use of an old Unix command-line tool called cal that’s included by default with OS X. Open a Terminal window (Finder→Applications→Utilities→Terminal) and simply type cal at the command prompt to see the current month in a calendar view. To see another month, type the short version of its name along with the year. For example, to see June 2012, I’d type cal jun 2012. To see an entire year, just type in cal 2013.







	Tip 41
	Where Do Files Found by Spotlight Live?




One slight irritation when searching for a file via Spotlight is that there’s no clear indication of where each file is located on your hard disk. However, if you hold Option+Command for a few seconds after the pop-out file preview appears, the file’s location will appear at the bottom of the preview pop-out.

Hold down Command on its own and you’ll see either the date the file was last modified, if it’s a file that OS X doesn’t natively understand, or a very brief extract from the file showing the search term in situ, if the file is one that’s understood and indexed by Spotlight. Wait for a second more and you’ll be shown the path to the file. 







	Tip 42
	Type Diacritical Characters Easily




Here are a variety of ways to type the occasional non-English language character or symbol into text using the majority of word processors and editors. Note that this tip assumes a US English keyboard is being used. 

Using the Character Palette

In most text editing applications, you can click Edit→Special Characters to bring up the Character Palette, from which you can choose non-English letters or symbols (in Microsoft Word, click Insert→Symbol, or Insert→Symbol→Symbol Browser in Word 20). Double-click the letter to insert it into the text.

Pressing and Holding

Another technique that works with some built-in Mac apps, like TextEdit and Mail, is to simply hold down the standard English version of the key for a few seconds. Doing this will cause a pop-out menu of accented variations to appear, and you can use the left and right cursor keys to move the selection highlight between then, hitting Return or the down cursor key to insert the one you need. To insert é, for example, just press and hold E, then select é from the pop-out menu. For uppercase variations, just hold Shift plus the key in question. 

Typing Manually

However, you can also type the more commonly encountered foreign language characters on standard English Mac keyboards as follows (the following should work in virtually all Mac apps):


	
Acute accent: Hit Option+E and then type the letter. For example, for café, type c, a, f, Option+E, e. Hold Shift when typing the letter to add accents to uppercase letters.



	
Cedilla: Option+C. For example, for façade, type f, a, Option+C, a, d, e. For an uppercase version, hold Shift.



	
Common ligatures: For œ, hit Option+Q. For æ, type Option+' (that is, the apostrophe key). In both cases, hold Shift for uppercase versions. For example, to type œvere, type Option+Q, v, e, r, e. 



	
Circumflex: Option+I, followed by the letter. For example, for the word rôle, type r, Option+I, o, l, e. Hold Shift when typing the letter for uppercase versions.



	
Eszett: Option+S. For example, to type weiße, type w, e, i, Option+S, e.



	
Grave: Hit Option+` (the key above Tab on US English keyboards, and left of the Z key on other English keyboards) and then type the letter. For example, for città, you’d type c, i, t, t, Option+`, a. Hold Shift when typing the letter for uppercase versions.



	
Inverted punctation: For an inverted question mark, hit Option+? (that is, Option+Shift+?). For an inverted exclamation mark, hit Option+1—there’s no need to hold Shift.



	
Ringed A: For å, hit Option+A. Hold Shift for the uppercase version. 



	
Stroked O: Option+O. For example, for the name Jørgensen, type J, Option+O, r, g, e, n, s, e, n. Hold Shift for the uppercase version. 



	
Tilde: Option+N, followed by the letter. For example, to type España, type E, s, p, a, Option+N, n, a. Hold Shift when typing the letter for uppercase versions.



	
Umlaut: Option+U, followed by the letter. For example, to type über, type Option+U, u, b, e, r. Hold Shift when typing the letter for the uppercase version.











	Tip 43
	Automatically Create Links in Docs




If you’re a fan of TextEdit, the basic word processor provided with your Mac, then you might be interested in a hidden feature that will automatically turn web and email addresses into hyperlinks that, when subsequently clicked, will open the link in the default web browser or email client (this also works if the file is saved as an Office-compatible document and opened by a Windows user).

It’s always been possible to insert a link by highlighting any text and clicking Edit→Add Link, but this new method will create links automatically as soon as you type them.

To activate the feature, click Preferences on the application menu, and in the bottom of the dialog box that appears, put a check in the Smart Links box. Close the dialog box and then close and restart TextEdit for the changes to take effect. 







	Tip 44
	Control What Apps Start When Your Mac Boots




If you’re a convert from Windows, you might be used to periodically pruning the list of programs that start at login by editing the Startup folder on the Start menu. You can find the equivalent function on Macs by opening the Users & Groups component of System Preferences (Apple menu→System Preferences). Unlock System Preferences if necessary by clicking the lock icon at the bottom left (note that only system administrator-level accounts can change startup items), and then select your account in the list on the left. Then click the Login Items tab on the right. To remove a program from the list, select it and click the minus button beneath the list. 

Note that a check alongside an entry in the list has no bearing on whether it starts at login. The checkbox merely controls whether the program starts hidden, that is, whether the program starts with its window invisible (the equivalent of minimized under Windows). 

There are a variety of different ways to add a program so it starts when you log in:


	
Click the plus icon within the Login Items view and navigate to the program using the File Open dialog box.



	
Drag and drop icons from the Applications list within Finder on top of the startup application list within the Login Items view.



	
Right-click the program’s Dock icon and click Options→Open at Login.
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Figure 10. Graphing CPU load











	Tip 45
	Keep an Eye on CPU Load and Activity




To have a small floating window appear showing CPU activity at the present time, start Activity Monitor (Finder→Applications→Utilities→Activity Monitor) and click the window menu. Then select Floating CPU Window and choose from either horizontal or vertical displays. The floating window will appear at the bottom left of the screen, and you can click and drag to move it around.

On most modern Macs, you’ll see two or four charts, representing each of the cores in the processor. If you’re using a high-end Mac Pro system, you might have up to sixteen processing cores and therefore sixteen bar charts!

To get rid of the graph, select None from the Floating CPU Window menu.

To see a graph showing the CPU load over time, select the CPU History entry from the Window menu. To get rid of it, just click the close button on the window.

For examples of the various CPU load graph types, see Figure 10, ​Graphing CPU load​.







	Tip 46
	Create Document Templates and Boilerplate Text




Let’s say you’ve created a form letter that you periodically send out to different people, changing only the name and address details. Some word processors allow you to create document templates. These are master files that, when opened, will create a new file containing the document’s contents. But did you know that this feature is built into your Mac, and you can use it with any kind of file?

It’s also possible to automatically insert boilerplate (that is, stock phrase) text into a document or new email using OS X’s Text Substitution feature.

Creating and Using a Template

To create a template, simply create or locate an existing file, then save and close it. Locate the file using Finder and select it before hitting Command+I to bring up the File Info dialog box. Then put a check in Stationery Pad, under the General heading near the top of the dialog box.

From now on, whenever anybody double-clicks to open the file, a copy of the file will automatically be created and opened for editing  (usually with the filename of the original plus the word copy appended).

To open the original for editing at any stage, click and drag it straight to an application’s Dock icon or open it using the File→Open menu option within an application.

To return the file to being an ordinary nontemplate file, just repeat the steps above but remove the check from the Stationery Pad box.

Creating and Using Text Substitution Phrases

OS X includes the ability to autocorrect mistypes. For example, type “teh” and it will correct it to “the.” This feature is known as text substitution, and it can be subverted so you can insert just about any word, sentence, or paragraph—even a series of paragraphs—when you type a particular keyword. Here’s how to set it up: 


	
Open System Preferences (Apple menu→System Preferences), then click the Language & Text icon.



	
Click the Text tab, then in the list of substitutions on the left, click the plus button at the bottom.



	
In the Replace field, type the keyword you want to trigger the substitution. For example, if you wanted to insert a boilerplate paragraph of legalese, you could type legalbp. It’s important to choose a keyword that you’re not going to type in everyday use.



	
Hit Tab to move to the With field. Here’s where you should type (or paste in) the word, sentence, or paragraph(s) you want to appear when the keyword is typed (hit Option+Return for a line break and Option+Tab to indent the text). Don’t worry if the text you type doesn’t appear to fit in the small field—it will all be recorded. Hit Return when done.





 Repeat the steps above however many times are needed to store all the boilerplate phrases you want.

In any application where you want to use the substitutions, you must select the Text Replacement option on the Edit→Substitutions menu so that it has a check next to it. You only need to do this once. (Remove the check next to the entry to deactivate substitution for that app).

Note that any substitution won’t appear until you hit Space after typing the keyword.

In Mail, first click within the body of an email you’re composing before attempting to activate substitution. The To and Subject fields within a Mail compose window can have text substitution set independently of each other and independently of the mail body. 

To delete a substitution, again open System Preferences and navigate to the Text tab of the Language & Text pane. Select the entry in the list and click the minus button. To temporarily deactivate a substitution, simply remove the check next to it. 







	Tip 47
	Keep Your Mac Wide Awake




If you need to leave your Mac unattended for a while but want to temporarily stop it going into sleep mode, open a Terminal window and type the following:



	 
	
​pmset noidle​





For as long as the Terminal window is open and the command is still running, the computer won’t go to sleep. To end the wakefulness, either hit Control+C or simply close the Terminal window. 







	Tip 48
	Test Your Mac’s Memory Chips




Problems with the RAM inside your computer can manifest themselves as the random freezing of your computer or as frequent application crashes, especially when a lot of programs are open. 
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Figure 11. Testing a Mac’s memory





The Applications Install DVD that might have come with your Mac has a memory testing application, which you can access by inserting the DVD and holding D after you reboot, but many regard this as inadequate. Instead, you can use a third-party application called MemTest86. To run the test, you’ll need to burn the software to a blank CD-R or CD-RW disc and boot from it as follows (obviously, those with a newer Mac Mini or a MacBook Air will need to acquire an external CD-R/RW drive):


	
Head over to http://www.memtest.org and download a pre-built ISO. At the time of this writing this was described as Pre-Compiled Bootable ISO. Usually the ISO is compressed as a zip file, so double-click to unpack it.



	
Start Disk Utility (Finder→Applications→Utilities→Disk Utility) and on the menu, click Images→Burn. In the file browser window, select the ISO image you downloaded (it’ll probably be in your Downloads folder) and click the Burn button.



	
Insert a blank CD-R or CD-RW disc as prompted, and click the Burn button in the dialog.



	
Once the burning has finished (it’ll take less than a minute), reinsert the disc and then restart the computer (Apple menu→Restart).



	
Before the Apple logo appears, press and hold down C. This will force the computer to boot from the CD rather than from the hard disk.



	
For the basic memory test, which is good enough for all but certain specialized cases, MemTest86 is entirely automated and will start automatically after a few seconds. It’s simply a matter of waiting for it to finish, which could take a few hours. Keep an eye on the PASS figure at the top of the screen—for details, see Figure 11, ​Testing a Mac’s memory​. This will slowly creep from 0 percent to 100 percent. Note that when the test has reached 100 percent, the test will automatically restart and will continue to do so until you quit MemTest86. This allows “burn-in” testing to take place, whereby components can be stressed over a long period of time. Once a test run-through is complete, however, the program will display a “Pass complete” message at the bottom of the screen.



	
Keep an eye on the Errors column during testing, in the row in the middle of the screen. This displays a total of any errors that are found. Errors are also reported in the lower half of the screen, highlighted in red, along with details of the exact fault. Anything other than zero errors at the end of the test means that the memory is faulty. Modern computers are very good at tolerating minor RAM faults, and you might even experience years of unhindered computing, but ideally you should consider replacing the RAM as soon as possible.



	
To restart the computer at any time or when the test has finished, hit Esc (top left of the keyboard). If this doesn’t work, hold down the power key on the computer for five seconds to force the computer to turn off. Press the power button again as usual to start the computer. If you immediately click and hold the mouse button, the disc will be ejected before the computer boots.






Exploring OS X Lion: AirDrop


AirDrop lets you quickly share files with other Mac users who are nearby. Only certain recent models of Macs are compatible,[5] and they must also be running Mac OS X Lion. 

AirDrop requires no setup and no password, and it works even if you’re not connected to a wireless network. However, your computer’s Wi-Fi will have to be switched on for AirDrop to work. To do so, click the Wi-Fi icon at the top right of the desktop and select Turn Wi-Fi On.

How it works is simple. If you switch to browsing AirDrop within Finder, either by clicking the shortcut in the Finder sidebar or by clicking Go→AirDrop, your user account will join the AirDrop network and will be visible to others also browsing AirDrop from their Macs. Once you stop browsing AirDrop, your computer stops being visible.

All other Mac users running AirDrop in the vicinity will appear on your “radar” (and you on theirs) and will be identified by username, along with their personal login picture. You can transfer files or folders to another Mac by dragging and dropping them onto the other Mac’s icon. Recipients will be asked to confirm that they want to receive files. They can do the same to transfer files to you.

Received files appear in the Downloads folder.



http://support.apple.com/kb/HT4783














	Tip 49
	Create an OS X Lion Install DVD/Bootable USB Stick




OS X Lion is the first major release of OS X to be sold primarily through direct download from Apple via the App Store. Although it’s possible to buy a USB memory stick installer from Apple,[6] this option is intended only for atypical situations and is therefore quite expensive. Whatever the case, you can create your own installation DVD by locating a hidden file and burning it to disc.

You can also write it to a USB memory stick and boot from it, but the stick must be 4 GB or larger. Note Tip 112, ​Repair Your Mac—Even If the Disk Appears Trashed​, which explains how to create a recovery USB memory stick that can reinstall OS X, but in that case the necessary files are automatically downloaded when you come to reinstall OS X. This tip creates an install DVD/memory stick that can be used even if there’s no Internet connection.

Finding the File

Look in Applications within Finder for the Install Mac OS X Lion entry that appeared when you purchased Lion from the App Store. Right-click it and select Show Package Contents. Navigate to the SharedSupport folder and you’ll see a file called InstallESD.dmg. This 3.74 GB file is the entire Lion installation—you can ignore all the other files in the package. Hold down Option and click and drag this to the desktop to create a copy.

Burning a Disc

If you want to create a bootable DVD, start Disk Utility (Finder→Applications→Utilities→Disk Utility) and, in the Disk Utility program window, click the Burn button on the toolbar. Locate the InstallESD.dmg file using the dialog box that appears, click the Burn button, then insert a blank DVD/DVD-R disk when prompted and click Burn. The disc will now be created.  

Writing to a USB Memory Stick

Writing the file to a USB memory stick is a little more involved, as follows (note that the memory stick will be wiped during this procedure): 


	
Open Disk Utility (Finder→Applications→Utilities→Disk Utility), insert the USB memory stick, and select its entry in the disk listing on the left side of the window. Be sure to select the entry for the stick itself—usually identified by its size and model details—and not its partition, which is indented beneath it.



	
Click the Erase tab, then select Mac OS Extended (Journaled) in the Format dropdown list. Leave the Name field reading Untitled. Click the Erase button, then the Erase button in the dialog box that appears.



	
Once erasure is complete, click the Restore tab. Click and drag the InstallESD.dmg file from the desktop to the Source field within Disk Utility. Then click and drag the Untitled entry beneath the main USB stick to the Destination field. Click the Restore button, click Erase in the dialog box that appears, and type your login password when prompted.

 For an example taken from my test machine, see Figure 12, ​Creating a bootable Lion install USB stick​.
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Figure 12. Creating a bootable Lion install USB stick





It’ll take five to ten minutes to write to your USB memory stick. Watch the progress display in the bottom right of the screen. Once it’s finished, quit Disk Utility. 

Installing OS Lion

To install from either a DVD or a memory stick, insert either into the new computer, then restart the machine.


	
To install from a USB memory stick, hold the Option key when the computer starts and then select the USB stick from the menu that appears using the left/right cursor keys (hit Return to boot). Follow the onscreen installation instructions.



	
To install from a DVD, hold down C when the computer restarts, until the Apple logo and the boot-time progress indicator appears (the spinning circle). Then follow the onscreen installation instructions. Note that on my test system, it took  five to ten minutes for the install disk or DVD to boot.





Using a DVD or USB stick allows you to make a “clean install” of OS X without having to upgrade from a previous version.







	Tip 50
	Recover from Crashes and Lock-Ups




I’ve owned Macs since 2003 and I’ve only ever had one crash that’s rendered the computer completely unresponsive. All I did was press and hold the power button for five seconds. This forces the computer to switch off. 

If an application has become unresponsive (that is, the spinning mouse cursor (aka the beach ball of death) has appeared, indicating the computer is busy) but the rest of the system seems to be working fine, many users report that simply starting Activity Monitor somehow fixes things. To start Activity Monitor, open Finder and then click Applications→Utilities→Activity Monitor. Some users with troublesome systems keep Activity Monitor as an icon on the Dock for just such contingencies!







	Tip 51
	Share Your Address Book with Others




Macs use vCard files to store contact details, although end users aren’t aware of this because the files are invisibly handled by the Address Book application. The vCard system records all the details about a particular contact in a single file, and it’s an open file format that’s understood by many operating systems, including Windows (and Microsoft Outlook).

Exporting a Single Contact

To export a contact in order to send it to somebody, open the Address Book app (Finder→Applications→Address Book), and locate your contact in the list. Then simply click and drag the contact from the main list into a new email window, or click and drag to the desktop if you want to turn it into a file to send manually. 

Usually, all recipients need to do is double-click the vCard (vcf) file to import the data, but they might have to use a special import function of their email or chat client. They should check their documentation for instructions.

You can Quick Look a vcf just like any other file—select it and hit Space to see its contents.

Exporting Multiple Contacts

You can export many or even all of your contacts at once by either selectively clicking them (that is, holding down Command while selecting) or by selecting all by clicking one and hitting Command+A. Then click and drag to an email or the desktop as usual. All the details will be contained with a single vcf file. Note that Microsoft Outlook can’t deal with multiple contacts in a single file, but other Macs will be able to import the data just fine.







	Tip 52
	Change the Fonts Used in Finder




Here is a personalization tip with a little productivity usefulness thrown in. Like all Mac apps, the Finder uses the Lucida Grande font. However, you can change both the title bar font and also the font elsewhere in the program window, such as when displaying file and folder names. Doing so can improve at-a-glance viewing of Finder windows.  

Changing the Main Finder Font

To change the fonts used throughout Finder (except for icon view), open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.finder NSSystemFont -string AmericanTypewriter;​




	 
	
​        killall Finder​





I’ve specified the American Typewriter font, but the key is to type the whole name of the font as it is listed in applications like TextEdit, but remove any spaces between the words in the font name. So the American Typewriter font becomes AmericanTypewriter.

Changing the Title Bar’s Font

To specifically change the font of a title bar, type the following into a Terminal window:



	 
	
​defaults write com.apple.finder NSTitleBarFont -string ArialBlack;killall​




	 
	
​        Finder​





Here I’ve specified the Arial Black font, again removing the spaces between the words in the font title.

You might also want to increase the size of the title bar font. Use the following Terminal command to increase the point size to 16:



	 
	
​defaults write com.apple.finder NSTitleBarFontSize 16;killall Finder​





Reverting to Defaults

To remove your font choices within Finder and revert to the default Lucida Grande font, open a Terminal window and type the following four lines:



	 
	
​defaults delete com.apple.finder NSSystemFont​




	 
	
​defaults delete com.apple.finder NSTitleBarFont​




	 
	
​defaults delete com.apple.finder NSTitleBarFontSize​




	 
	
​killall Finder​











	Tip 53
	Stress Test Your Mac to Expose Faults




If your Mac has been experiencing random crashes, you might want to run a CPU stress test. This will load the processor to 100 percent, and you’ll therefore be able to determine if it’s faulty or, more likely, if the cooling system is faulty.

Testing

There are various ways of stress-testing a Mac, but the easiest way is as follows. Before starting, be sure to save any open files and close any unnecessary applications. If you’re using a portable Mac, attach the power cord.

Before starting, find out how many processor cores your Mac has. Unless you’re using a Mac Pro desktop system, the answer will either be two or four.  To see a quick trick to view the number of cores in the system, check out Tip 45, ​Keep an Eye on CPU Load and Activity​—just view the number of bars in the CPU performance graph; each represents a core of your CPU.

Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following at the command prompt:



	 
	
​yes > /dev/null​





Then hit Command+T to open a new tab in the Terminal window, and type the command one more time. If you have a four-core processor, repeat the step twice again so that four tabs are open running the command.

The yes command merely creates a stream of characters, but it does so as quickly as it can, to the extent that it soon consumes all the available processing power. Elements after the command direct the output of the yescommand to /dev/null, which is like a black hole in the system that consumes as much data as is thrown at it. 

Terminating the Test

Wait for a few minutes. You’ll probably hear your computer’s fans start to spin. This is normal, as is the computer getting hot. You might also find the computer becomes a little sluggish when responding to your interaction. 

If the computer hasn’t crashed after five minutes, terminate the test by closing the Terminal window (don’t worry about any warning that doing so will terminate currently running apps). If your Mac crashes or freezes up before you terminate the test, it’s very likely your computer has a fault that requires repair.







	Tip 54
	Tag Files for Faster Searches




Every single Mac file can be tagged, which will help Spotlight prioritize the files should you search for them. Tags are simply memorable words that are attached to the file. For example, suppose some friends send you a photograph of them. You can tag the file with their names, so that at a later point you can simply type their names as a search term with Spotlight rather than having to remember the photo’s filename. 

Folders can be tagged too, but this isn’t recursive—applying a tag to a folder won’t apply it to the files it contains.

Tagging Individual Files and Folders

To tag a file or folder, first select it and then hit Command+I to open the info window. Under the Spotlight Comments field at the top, type as many tags as you need, separating each word or phrase with a comma. For example, let’s say I received a photo of John Smith and Jill Jones on a water sports holiday in Aruba. I could type the following: John Smith, Jill Jones, water sports, swimming, snorkeling, scuba, holiday, Aruba.


 Once you’re done, simply close the info window. You can test the tags
	instantly by using them as search terms with Spotlight. Highlight any entry
	in the list of results and, when the Quick Look window appears, hold
	down Command to see the tags listed beneath the preview pop-out window.

You can tag any type of file in this way, including business documents. The only limitation is how much time you want to spend tagging! Folders can be tagged too, which saves the effort of individually tagging every file within them, although bear in mind that if files are moved out of the folder they will no longer have the tags applied.

Tagging Multiple Files

There’s no quick and easy way to tag multiple files, although you might like to try the following, which uses Automator (see ​Exploring OS X Lion: Automator​):


	
Start the Automator program. It’s among the first programs listed in the Applications view of Finder—its icon is a robot.



	
In the type chooser dialog that appears, click the Application icon (the icon is a robot here also) and then click the Choose button. 



	
The Automator program window is a little daunting, but you can ignore most of it. In the Search field, type Set Spotlight. This should thin the list of actions down to one choice. Click and drag this to the right of the window in the area that reads Drag Actions or Files Here to Build Your Workflow.



	
Don’t type anything in the New Spotlight Comments field. However, click the Options button and put a check next to Show This Action When the Workflow Runs.



	
Click File→Save to save your new Automator app. Save it to the desktop and call it something like Group Tagger.



	
Close Automator. Now and in the future, drag and drop the files you want to be tagged on top of your new app. A dialog box will pop up, asking what tags you want to apply. Type them as prompted, and when you click OK, the files will be tagged instantly and invisibly.





If you’d like to “suggest” default tags to be applied to the files, type them into the New Spotlight Comments field (instead of ignoring this field as instructed in the procedure). These comments will then appear in the dialog box that pops up, and users can either use them or choose to overwrite them with their own tags.







	Tip 55
	Get Back Your Library Folder!




Those who’ve been using a Mac for some time might have noticed that with the OS X Lion release, the Library folder within their user folder has vanished. It’s still there, of course. It’s just that Apple has decided you shouldn’t be confronted with it every day, so it’s hidden now. The Library folder is where all your personal app and OS X settings are stored. It’s not intended for the files there to be manipulated by anything other than apps, but often it’s useful to delve in there to remove an errant configuration file. 

Quickly Viewing the Library Folder

To quickly browse your Library folder, open a Finder window and click the Go menu. Then press and hold Option. You’ll see a new entry temporarily appear for the Library folder, which will disappear when you release Option.

Permanently Restoring Access

To return to viewing the Library folder permanently, open a Terminal window and type the following: 



	 
	
​chflags nohidden ~/Library/​





Then open Finder, hit Shift+Command+G and type ~ (tilde) in the dialog box that appears before hitting Go. This will display the contents of your home folder, with the Library now taking its place among the contents. Note that you’ll likely have to repeat the chflags command each time you install a major system update for OS X (that is, updating from 10.7.2 to 10.7.3, for example). 

Should you decide in future that the Library folder should be hidden again, open a Terminal window, but this time type the following:



	 
	
​chflags hidden ~/Library/​











	Tip 56
	Instantly Create Desktop Shortcuts to Files




With the title bar of any program that’s able to edit files (that is, an app like TextEdit rather than one like iTunes), you’ll see the name of the file currently being worked on—assuming you’ve saved it, of course!

To the left of this will be an icon representing the file. This is known as the proxy icon. Click and hold it for a few seconds without moving the mouse, and then drag the icon to the desktop or to a Finder window to instantly create an alias to that file. Aliases are essentially shortcuts pointing to a particular file that, when double-clicked, open the file. By holding down Option before releasing the mouse button, you’ll create a copy of the file instead.

If the file has been modified and not saved, the icon might appear grayed out and will stubbornly resist being clicked and dragged. This will probably be the case with older applications created before OS X Lion was released (that is, prior to mid-20). The solution is simply to save the file before clicking and dragging.

This works in most Mac applications, although in Microsoft Office apps you’ll need to hold Option+Command to create an alias. Note that if you click and drag the icon from the title bar of a Finder window instead of creating a shortcut, the currently browsed folder will be copied to the desktop.
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Figure 13. Activating a hidden Dock stack highlighting effect











	Tip 57
	Add a Cool Visual Effect to Dock Stacks




Stacks are the spring-loaded lists of files that appear whenever a folder on the Dock is clicked. Out of the box, Documents and Downloads are set up as stacks on the right of the Dock, near the Trash icon. You can add your own folders by dragging and dropping them there (release the mouse button only when the other folders have slid out of the way), but remember—you’re not copying the folder to the Dock. You’re only creating a shortcut there.

Activating Highlighting

To make stacks slightly easier to use, you can configure your Mac to highlight icons when your mouse cursor passes over them (the same highlight that appears if you open a stack and navigate to an entry in the list using the cursor keys—for an example, see Figure 13, ​Activating a hidden Dock stack highlighting effect​ ). Highlighting in this way is also quite a neat visual effect.

To make it happen, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock mouse-over-hilite-stack -bool TRUE;killall Dock​





The Dock will disappear for a split second, but don’t worry; that’s normal. Test your new setting by clicking on one of the stacks.

Deactivating Highlighting

To turn off the effect at any time, open a Terminal window once more and type the following:



	 
	
​defaults delete com.apple.dock mouse-over-hilite-stack;killall Dock​





Temporary Highlighting

There’s another way of enacting highlighting on a temporary basis if you don’t want to make the system configuration changes outlined above. Simply click and hold the Stack icon until the list expands. Then, without taking your finger off the mouse button, move it up into the Stack listing. Note that you’ll instantly select the item your mouse is hovering over when you release the mouse button.







	Tip 58
	Always See Details About Files on the Desktop




Click a blank spot on the desktop and hit Command+J. This will bring up the View dialog box. Put a check next to Show Item Info. You’ll then see useful details beneath each file. For example, documents will have their file size listed beneath. Images will show their physical dimensions. MP3 songs will show how long they are. Folders will show how many files they contain.

This works inside folders, too, provided icon mode is active (hit Command+1)—just open the folder in Finder, hit Command+J, and check Show Item Info. Each folder will remember the individual settings.







	Tip 59
	Shrink PDF Files




All applications capable of editing documents or pictures on a Mac can output files as PDFs. To do so, just click File→Print on the menu of the application, and click the PDF dropdown at the bottom left. Then select Save as PDF, and enter a filename as usual (be sure to add a pdf file extension if you want the file to be read on computers other than Macs).

However, PDFs created by Macs tend to be large. The solution is simple: repeat the steps above to output a PDF but choose the Open PDF in Preview option from the PDF dropdown list. Then, when the Preview window appears, click File→Export. In the Save As dialog box, click Reduce File Size under the Quartz Filter dropdown list.

Note that shrinking PDFs in this way will also reduce the quality of the images slightly.

This technique can also be used to shrink large PDF files you might have received by email. Just open then in Preview, export them, and choose the shrink option. However, if the PDF contains sophisticated functions such as security features, it may lose these functions in the shrinking procedure.







	Tip 60
	Turn On Key Repeat




With Lion, Apple made a break from years of computing development. As just one example, they deactivated key repeat in favor of a method of inserting accented or non-English characters (see Tip 42, ​Type Diacritical Characters Easily​). 

This technique of inserting foreign or accented characters only works in a handful of applications, including built-in Apple apps like Mail, Safari, and TextEdit. In other apps, holding down a key does nothing. 

If you find this feature annoying, it can be turned off so that keys will repeat in the standard way when held down. To do so, open Terminal (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write -g ApplePressAndHoldEnabled -bool FALSE​





Then log out and back in again for the changes to take effect.

To revert back to inserting accented or foreign letters on key hold, open a Terminal window and type the following:



	 
	
​defaults delete -g ApplePressAndHoldEnabled​











	Tip 61
	Quickly Rearrange Icons on a Toolbar




To quickly reposition an icon on the toolbar of most programs that allow toolbar reconfiguration, such as Finder or Preview, hold down Command for a few seconds and then click and drag the icon.







	Tip 62
	Save Text Snippets for Reuse




Here’s a neat trick for those who work with words on their Macs.

Creating a Clipping

If you highlight text in an application and click and drag it to a folder or to the desktop, the text is turned into a file. These are called text clippings, and they take their filename from the first few words of the excerpt. If there’s any formatting applied to the text, it will be saved too. This is an excellent way of filing away anything you’ve had to edit out of a document but want to keep for other purposes. 

Viewing and Inserting Clippings into Documents

To view the contents of the clipping, just double-click it or select it and hit Space to bring up Quick Look. Note that you won’t be able to edit the file. However, to reinsert the text into a document, just click and drag the clippings file on top of the program window after positioning the cursor where you’d like it to be inserted.


Exploring OS X Lion: Mac Server


Those interested in using OS X as a server can do so by purchasing the server upgrade via the Mac App Store. As well as adding server applications of various kinds, including calendar and wiki, the server upgrade adds several GUI user management and system monitoring tools to a standard OS X installation. It also adds support for the Xsan cluster file system.

Apple ceased production of dedicated Mac server hardware in 2010 and presently recommends either the Mac Pro or high-end Mac Mini desktop systems be used for those who require server hardware. 











	Tip 63
	Hide Files




There are two ways of making files invisible on your Mac. Neither are bulletproof and anybody with know-how would be able to uncover them in seconds. But for quietly hiding a file or two for a short period they’re worth considering. If you need to protect files from prying eyes, take a look at Tip 33, ​Create a Totally Secure Store for Personal Files​, and Tip 110, ​Create Encrypted Archives for All Computers​.

Hiding Files via Unix

Your Mac’s operating system, OS X, is actually a version of Unix. In Unix, you can make a file invisible by adding a period (.) in front of its filename, and this works on Macs too. This means the file won’t show up in Finder windows, in file open dialog boxes, or on the desktop. Those browsing at the command line won’t be able to see it unless they specifically request to view hidden files (that is, ls -a). 

For example, typing a filename of .document.docx when you’re saving a file will render it invisible. You’ll probably be warned that putting a period in front of a filename is reserved for system files, the type of file this technique is typically used to hide, but you can still choose to save the file. 

Hiding Files So Mac Apps Can’t See Them

The chflags can be used to hide files so they don’t show up in graphical user interface (GUI) applications. However, they’ll still be visible if anybody browses files using a Terminal window.

To hide files in this way, open a Terminal window (Finder→Applications→Utilities→Terminal) and use the chflags hidden command, specifying the file or folder name immediately afterward. For example, to hide secret.doc, type the following:



	 
	
​chflags hidden secret.doc​





To unhide the file so it’s visible via GUI software again, use the chflags nohidden command:



	 
	
​chflags nohidden secret.doc​





Viewing Hidden Files

So if a file is hidden, how can you see it in order to open it up again? In expanded file open/save dialog boxes, hitting Shift+Command+. (period) will display hidden items in the file listing. Hitting the key combo again will hide them. However, be aware that you’ll suddenly see lots of system files that are hidden in this way. (Steer clear of these—don’t delete or open them.)

The only way to see hidden files in Finder windows is to activate a secret setting that shows them alongside other files. This will cause them to always be visible within Finder windows and on the desktop,  although hidden files will have a washed-out appearance to indicate their status. Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.finder AppleShowAllFiles -bool TRUE;killall Finder​





Even after making this change, you’ll still have to hit Shift+Command+. within file open/save dialog boxes to see hidden files.

To revert back to hidden files being hidden within Finder, type the following:



	 
	
​defaults delete com.apple.finder AppleShowAllFiles;killall Finder​











	Tip 64
	Show Full Paths in the Title Bar of Finder




By default every Finder window displays the name of the current folder you’re browsing or its current mode (that is, if you’re using AirDrop, for example). To switch it to show the full path of the directory (that is, /Users/keir/Documents rather than just Documents), open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.finder _FXShowPosixPathInTitle -bool TRUE; killall​




	 
	
​        Finder​





Bear in mind that if you switch to the All My Files view in Finder, you’ll see a long path pointing towards /System/Library/CoreServices/Finder.app. This is simply where the All My Files function is stored.

To revert back to showing just the folder name, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.finder _FXShowPosixPathInTitle;killall Finder​











	Tip 65
	Control Hidden Screenshot Settings




Macs have powerful screenshot facilities built in, with which you can produce a snapshot of what’s on your monitor(s) at any given time (see Tip 131, ​Take a Picture of the Screen​). Here’s how you can tweak a few things relating to screenshots: the file type, where files are saved, and whether they have a shadow effect applied to them.

Changing the File Format

Files are saved in PNG format (portable network graphics; .png). This is as good as any for a file format, but you might find that people you work with demand JPEG or GIF files. To change the default file format, first look up the format you need in the left column of the table below, then open a Terminal window (Finder→Applications→Utilities→Terminal) and add it to the end of the following command:



	 
	
​defaults write com.apple.screencapture type -string​





Here are the format options:




	
Filetype


	
Description







	

BMP



	
Windows Bitmap; ideal for any type of image but produces large file sizes. Can’t be used online.





	

GIF



	
Graphics Interchange Format; used primarily for diagrams. Can be used online.





	

JPEG



	
Joint Photographics Expert Group file format; best for photographic images. Can be used online.





	

PDF



	
Portable Document Format; can be used for any type of image file. Most modern web browsers support PDF.





	

PNG



	
Portable Network Graphics; can be used for both photographs and diagrams but perhaps better suited to the latter. Can be used online.





	

TIFF



	
Tagged Image File Format; ideal for any kind of image but produces large file sizes. Popular in the publishing industry but can’t be used online.







For example, to change the default screenshot file format to GIF, you can type the following:



	 
	
​defaults write com.apple.screencapture type -string GIF​





Then log out and back in again.

To change back to the default PNG format, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.screencapture type​





Don’t forget to log out and back in again afterward.

Changing the File Save Location

You can also alter the default save location where your Mac places screenshots it captures. By default this is the desktop, but the following command will save them to the Documents folder, for example (replace USERNAME with your username):



	 
	
​defaults write com.apple.screencapture location /Users/USERNAME/Documents/​





You’ll need to log out and back in again for the change to take effect. To revert to the standard location (that is, the desktop), open a Terminal window and type the following, logging out and back in again afterward:



	 
	
​defaults delete com.apple.screencapture location​





Getting Rid of the Shadow

Screenshots always have a shadow effect applied to them. You can turn this off by altering a secret setting. Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.screencapture disable-shadow -bool TRUE​





Log in and out for the change to take effect.

To revert to screenshots having shadows once again, open a Terminal window again and type the following, logging out and back in again for the changes to take effect:



	 
	
​defaults delete com.apple.screencapture disable-shadow​











	Tip 66
	Create a Clever Color Picker App




This tip is primarily for web developers and graphic artists.

A lot of Mac apps feature the built-in OS X color picker tool. In TextEdit, for example, clicking the color chooser icon on the toolbar and then choosing Show Colors from the pop-out menu will display this tool. It’s a floating window showing a color wheel, although you can also switch to predefined palettes by clicking the relevant toolbar button on the floating window.
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Figure 14. Creating a homemade color picker app





Creating a Simple App

The color picker is not available as a standalone app, but it’s easy to turn it into one with a little AppleScript. This way it can be used whenever you need to choose a color and find the RGB (or CMYK) values. 

Open AppleScript Editor—it’s in Finder→Applications→Utilities. Then in the main code area, type the following:



	 
	
​choose color default color {65535, 65535, 65535}​





Click File→Save As; give your new app a name, such as Color Picker; and choose a location (you can save it in the Applications folder if you wish, alongside all your other apps). In the File Format dropdown list, select Application. Then click Save.

Your new app is now ready for use. When it’s running, you can close it by clicking either the Cancel or OK buttons—it doesn’t matter.

To see the RGB or CMYK values of a color, click the Color Sliders icon on the color picker window’s toolbar, and select RGB Sliders or CMYK Sliders from the dropdown list (see Figure 14, ​Creating a homemade color picker app​). If you want to sample colors anywhere on the screen to get their RGB or approximate CMYK values using the color picker tool,[7] click the magnifying glass icon on the toolbar and click the area in question. (Note that there’s already an app for sampling onscreen colors, available in the Utilities folder of Applications—DigitalColor Meter [sic].)

Creating a More Sophisticated App

A few extra lines of code can boost our new tool substantially and turn it into a web developer’s dream. The following AppleScript, when saved as an app as described earlier, will write the color value chosen to the clipboard as a hex value (that is, something like #6BACFF). This can then be pasted into HTML code, for example.



	 
	
​set chosencolor to choose color default color {65535, 65535, 65535}​




	 
	
​set the formattedColor to my hex(chosencolor)​




	 
	
​on hex(chosencolor)​




	 
	
​set the hex_list to {"0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "A",​




	 
	
​        "B", "C", "D", "E", "F"}​




	 
	
​set the the hex_value to ""​




	 
	
​repeat with i from 1 to the count of the chosencolor​




	 
	
​set this_value to (item i of the chosencolor) div 256​




	 
	
​if this_value is 256 then set this_value to 255​




	 
	
​set x to item ((this_value div 16) + 1) of the hex_list​




	 
	
​set y to item (((this_value / 16 mod 1) * 16) + 1) of the hex_list​




	 
	
​set the hex_value to (the hex_value & x & y) as string​




	 
	
​end repeat​




	 
	
​return ("#" & the hex_value)​




	 
	
​end hex​




	 
	
​set the clipboard to formattedColor​





Once you’ve typed the listing, click the Compile button to see if it’s correct. Then save the script as an app, and it’s ready for use. Simply choose a color and click the OK button. The RGB value will then be invisibly written to the clipboard, ready for pasting elsewhere.

Assigning a Custom Icon

There’s one final tweak you can make to perfect your new app—assign it an appropriate icon. To read how to change the icon of an app, see Tip 19, ​Personalize Every Icon​.

 Also, you’ll find an ideal image at: /System/Library/ColorPickers/NSColorPickerWheel.colorPicker/Resources/NSColorWheelImage.tiff. To open this file, start Preview, click File→Open, and then hit Shift+Command+G. Then type the path above, and click Open to open the file for viewing and converting into an icon, as described by the aforementioned tip.







	Tip 67
	Make a Time Machine Backup When No Disk Is Attached




When Time Machine is used on a portable Mac, such as a MacBook Air, OS X is clever enough to realize there are times when the computer won’t be attached to the Time Machine disk (or within range of the Time Capsule). Therefore it temporarily backs up to the computer’s hard disk, creating what are known as snapshots.

With desktop Macs like the iMac, this feature isn’t activated because it’s assumed the Time Machine disk will always be connected or that the computer will always be in range of the Time Capsule. But this might not always be the case. Perhaps you sometimes disconnect your Time Machine disk because you temporarily need the USB port it uses for other things, for example.

Enabling Local Snapshots

If your desktop machine is not always connected, you can enable the same local disk backup that portable Macs use. Open a Terminal window and type the following:



	 
	
​sudo tmutil enablelocal​





You’ll need to type your password when prompted. A new snapshot will be created within the hour, but if you’re impatient, you can force one to be made by typing the following at the Terminal window: 



	 
	
​tmutil snapshot​





Note that no indication is given that a snapshot is taking place. If you enter the Time Machine, snapshots are identified by gray bars in the time display against the right side of the screen. Regular backups are colored purple. 

Deactivating Local Snapshots

To deactivate the local backup feature, type the following:



	 
	
​sudo tmutil disablelocal​





All the local backup data will be deleted (this might take some time but will take place in the background), so ensure you create a new external backup of the system by attaching the Time Machine disk and clicking the Back Up Now option on the Time Machine menu. 
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Figure 15. Shrinking the Dock to minuscule size











	Tip 68
	Make the Dock Really, Really Small




You can shrink and enlarge the Dock by clicking and dragging the “Abbey Road” bar lines that separate the application icons from the stacks on the Dock (that is, the bars that look like the road crossing stripes on the Abbey Road album cover). Alternatively, you can open System Preferences, select the Dock preference pane, and click and drag the Size slider. 

However, your Mac will only let you shrink the Dock to a certain size. This setting is pretty small, but it’s possible to go even smaller. 

Shrinking the Dock

To shrink the Dock even more than is usually allowed, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock tilesize -int 8;killall Dock​





This will shrink the Dock to half of the supposedly smallest size—for an example, see Figure 15, ​Shrinking the Dock to minuscule size​. The number at the end of the command can range from 1 (too small to be useful) up to 16, which is the smallest size achievable by clicking and dragging to resize. You can set values higher than this too, but you might as well use the built-in Mac tools, such as the System Preferences tool. 

However, if used with Dock magnification (which you can set using the same Dock pane of System Preferences), it is entirely possible to use a tiny Dock size, especially if screen real estate is limited. 

Restoring a Normal Size

Using the Dock pane of System Preferences is the best way of returning the Dock to a normal size (just click and drag the size slider), although you can return the Dock to the default size by opening a Terminal window and typing the following: 



	 
	
​defaults delete com.apple.dock tilesize;killall Dock​











	Tip 69
	Use a Hidden Stacks List Mode




Stacks are the spring-out displays that appear when a folder in the Dock is clicked, such as Documents. There are three view modes that you can select by right-clicking the folder: Fan, Grid, and List.

Getting a Better List

As its name suggests, List view simply presents the files and folders in a rather dull list that you can scroll by nudging the mouse at the top and bottom of the list. To change List view to a rather more aesthetically pleasing display complete with a scroll bar that you can click and drag, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock use-new-list-stack -bool TRUE;killall Dock​





The Dock will disappear for a split second, but don’t worry—this is fine. You should be able to test the changes right away.

Tweaking the Size

You can increase or shrink the size of icons in the new look by activating the stack, then holding Command and tapping the minus and equals keys, which are on the top right of your keyboard, next to the main number row.

Reverting to Normal List Mode

To revert to the standard List view at any time, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock use-new-list-stack;killall Dock​











	Tip 70
	Quickly Open Files You’re Quick Looking At




If you’re viewing a file via Quick Look, double-clicking the window will open the file in the default viewer or editor. For example, double-clicking the Quick Look preview window while viewing a movie file will open the file in QuickTime Player.

You can also click the button at the top right, of course. Clicking and holding this button will display a list of other applications that can open the file—simply select one from the list to open the file in that app.







	Tip 71
	Hide Every Window




To send every program window that’s open to the Dock—apart from the one that you’re currently working in—hit Option+Command+H. To restore the program windows to the screen, you’ll need to click their individual Dock icons.

Hold down Option+Command and click on a blank spot on the desktop (such as the space on either side of the Dock) to instantly hide all windows except Finder windows, revealing the desktop. Click the Dock icon of each app to unhide it.







	Tip 72
	Work Better with Column View in Finder




Column view within Finder is probably my favorite way of browsing files. To access it, open a Finder window and click View→As Columns, or hit Command+3.

The only issue I sometimes have is that long filenames get truncated because of the narrow column widths. To get around this, I double-click the small double-bar icon at the bottom right of the column beneath the scroll bar (for an annotated example, see Figure 16, ​Resizing columns in Finder​). This double-bar icon can also be dragged to resize the column. Holding down Option while resizing columns will both resize all columns proportionately within the Finder window and cause Finder to remember the resizing the next time you open a Finder window, rather than resetting the column width. Double-clicking the double-bar icon will cause the column to revert to its default size once it’s been manually resized by clicking and dragging.
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Figure 16. Resizing columns in Finder











	Tip 73
	Reveal the Locations of Files in Spotlight and the Dock




Spotlight lets you find files in an instant and open them for editing or viewing. But what if you can remember the name of a file but not that of others you know are in the same folder, and it’s the other files you’re looking for? Wouldn’t it be useful to just instantly open the folder containing the file?

You can! In the list returned by Spotlight, hold down Command when clicking the entry. This will open a Finder window at the file or folder’s location, with the file highlighted. You can also highlight an entry in the list using the cursor keys and hit Command+R to reveal the file in Finder.

Holding down Command and clicking any icon in the Dock will have the same effect—a Finder window will open, showing its location. This can be very useful if you want to quickly open a Finder window showing Documents or Downloads—just hold Command and click the Documents or Downloads stack.







	Tip 74
	Make Finder Your Productivity Hub




Finder is much more flexible than you might realize. Its toolbar and sidebar offer significant potential for boosting productivity.

Creating a Copy of the Dock

You can drag and drop practically anything onto the Finder toolbar or sidebar to create a shortcut for quick access. For example, you can drag an application icon there, and it will act like an icon in the Dock, so you can click it to launch the app and drag and drop files onto it for opening. You can even replicate your Dock icons or the key applications you use daily if there’s enough space.

Finding Files and Storage Devices

You can also drag data files to the toolbar that, when clicked, will open instantly. Removable storage devices like USB memory sticks can also be dragged there—just click and drag their entry from beneath the Devices list in Finder.

Printing Easily

You can also add to the Finder toolbar a shortcut to your printer(s), which will let you drag and drop files to instantly print them or allow you to click the icon to see the print queue. Just open System Preferences (Apple menu→System Preferences), click Print & Scan, then drag and drop any of the printer(s) from the list to the toolbar or sidebar of any open Finder window.

Adding System Preferences Shortcuts

It’s also possible to add entries from within System Preferences to the Finder’s toolbar or sidebar. Follow the instructions in Tip 139, ​Get Quick Access to System Preferences Tools​. However, rather than dragging the pref files to the Dock, drag them to the Finder’s toolbar or sidebar instead.

Removing a Toolbar Entry

To remove an icon you’ve added, just hold down Command and drag the icon up and away from the toolbar in the case of toolbar icons, or to the left and away from Finder in the case of sidebar icons. The icon will disappear in a puff of smoke (literally, although don’t worry—only the shortcut will be deleted).

You can also delete default toolbar entries this way, such as the Search box, which will free up a lot more space for your own icons.

To restore the default set of icons to the Finder toolbar at any point, right-click in the toolbar area and then click Customize Toolbar in the menu that appears. Then in dropdown dialog box, drag and drop the default icon set to the toolbar over what’s already there.







	Tip 75
	Pool Printers for Quick Printing




This is a tip for anybody who uses a Mac on a network and prints to network printers or perhaps has several printers connected to the Mac via USB.

One of the biggest issues with using a shared printer is that it might be busy or just switched off. To overcome this, Macs let you pool printers. Once a pool is created, you can select the pool when printing and your Mac will send the job to the first printer it detects that isn’t already busy or offline.

Alas, printer pools aren’t perfect. You’re given no indication of which printer has printed the job. If you create a pool that, for example, includes printers on different floors of the building, then you’ll have to visit each until you find your output!

Creating a Pool

To create a printer pool, open the Print & Scan component of System Preferences. In the list of printers on the left, select the printers you want to include by holding down Shift or Command when selecting them (just as you do when selecting files). On the right of the panel, a new button will appear: Create Printer Pool. Clicking this will let you create the pool, and the final step is to give it a name. Once you’re done, you’ll see the printer pool appear in the list of printers on the left.

All you need do in the future is select the printer pool you created from the File→Print dialog box within any application. Printer pools have their own print queue, the icon for which will appear in the Dock when you print.

Deleting a Printer Pool

Deleting a pool is just like deleting any other printer: open System Preferences, select Print & Scan, select the printer pool in the list on the left, then click the minus button at the bottom of the list. Then click Delete Printer [sic] in the dialog box that appears. 







	Tip 76
	Instantly Shut Down, Reboot, or Put Your Mac to Sleep




A handful of keyboard shortcuts can be used to instantly shut down, restart, or put your Mac into sleep mode.

Shutting Down

To instantly shut down the computer, hit Control+Option+Command and the Eject button. You’ll be prompted to save any files open in your applications first.

Showing the Shutdown Dialog Box

To quickly bring up the Shutdown dialog box, which offers the choice to Restart, Sleep, or Shut Down the computer, hit Control and hit Eject.

Rebooting

To instantly reboot the computer, hold down just Control and Command before hitting Eject. You’ll be prompted to save any files open in your applications first.

Putting to Sleep

To quickly put any Mac into sleep mode—useful if you walk away from it for a few moments and want to avoid prying eyes—hold Option and Command together, and hit the Eject key (top right of the keyboard, or top right of the main keyboard area on aluminum keyboards). Waking the computer is easy—just hit a key or, in the case of a laptop whose lid has been closed, simply lift the lid.







	Tip 77
	View All of a Photo or Movie’s Hidden Info 




When you open an image in Preview or a movie in QuickTime Player, hitting Command+I will bring up the information window that will show every scrap of technical and metadata information about the file, including EXIF data in the case of images. Hit Command+I to hide the info window again.

Although it uses the same key combination, this data is far more detailed than the standard File Info dialog box that appears when you select a file and hit Command+I.







	Tip 78
	Print via Drag and Drop




Wouldn’t it be useful to be able to print a file instantly, without first having to open it and then click File→Print?

As you might expect, your Mac lets you do just that. Open System Preferences (Apple menu→System Preferences) and then click the Print & Scan entry. In the list of printers that appear on the left, simply select a printer and drag and drop it to the desktop. This will create a shortcut to the printer, which will probably be an icon photograph of your actual printer.

To instantly print any file, simply drag and drop a file on top of this new shortcut.

Double-click the new icon to view the print queue.







	Tip 79
	Use Spotlight like a Pro




Spotlight organizes results under section headings, but you can also force it to search only for certain types of files or for files with a certain characteristic.

Searching for Types of Files

To force Spotlight to search only for a particular type of file that matches your search term, such as images, type kind: and then the type of file you’re looking for. For example, to search only for audio files matching the word rock, I’d type the following:



	 
	
​kind:music rock​





To search for documents matching the word report, type:



	 
	
​kind:documents report​





You can see a full list of words that can be used in the following table. Remember that Finder includes a Spotlight search field at the top right of each file browser window, and this technique works there too. 




	

kind:modifier


	
Description







	

kind:alias



	
Returns only file aliases.





	

kind:app



	
Returns only applications within Spotlight results.





	

kind:bookmark



	
Returns only Safari bookmarks (not those of other browsers you may have installed).





	

kind:contact



	
Returns entries from the Address Book application.





	

kind:document



	
Returns documents, although this is a broad term applying to any file that is a container for text and not just office documents. You can use kind:word to return only Microsoft Word documents and kind:pages to return only iWork Pages documents.





	

kind:email



	
Returns only mail messages (kind:mail can also be used).





	

kind:event



	
Returns calendar entries from iCal.





	

kind:exe



	
Returns only developer files (files generated by Xcode, for example).





	

kind:folder



	
Returns only folders.





	

kind:font



	
Returns only fonts installed on the system.





	

kind:movies



	
Returns only movie files, as mov or avi files, or downloaded iTunes movies; to return only QuickTime movies, use kind:quicktime.





	

kind:music



	
Returns only audio files, such as MP3s or downloaded iTunes songs (kind:audio can also be used).





	

kind:pdf



	
Returns only PDF files.





	

kind:pic



	
Returns only images, such as JPEG or TIFF files (“kind:image” can also be used)—use kind:jpeg to return only JPG images  and kind:tif to return only TIFF images.





	

kind:preferences



	
Returns only System Preferences configuration tools.





	

kind:presentation



	
Returns only presentations (that is, Microsoft PowerPoint or iWork KeyNote files)—use kind:powerpoint to return only PowerPoint files and kind:keynote to return only KeyNote files.





	

kind:spreadsheet



	
Returns only spreadsheets (that is, Microsoft Excel or iWork Numbers files)—use kind:excel to return only Excel files and kind:numbers to return only iWork Numbers files.







Searching via Label

You can also use label: to search for color-labeled files (that is, files that you’ve applied a color to by right-clicking them and selecting a color under the Label heading—see Tip 90, ​Manage Project Files Using Color Labels​). label: needs to be followed by the name of the color. For example, to use Spotlight to search for files colored red, you’d type label:red. The choices are red, orange, yellow, green, blue, purple, and gray. 

Searching by Author

Using the author: keyword, you can specify the author of the document—the person who sent the email, for example, or the person listed within a Microsoft Office document as the author. Enclose the name in quotes if you specify more than one word: author:"keir thomas" will return documents and emails created by Keir Thomas, for example.

Limiting Spotlight Results to Particular Days

You can have Spotlight only return results for a particular day. To do so, type date: followed by today or yesterday in the search field to only see files created or modified today or yesterday. You can also specify a date: date:10/3/2011 will return files created or modified on 3 October 20, for example. (Those outside of the US should use native date formats instead: date:3/10/2011, for example.)

You can also specify date ranges: date:8/1/2011-8/31/2011 will return files created or modified in the month of August 20, for example.

Specifying Words NOT to Search For

Let’s say you’re using the Spotlight search tool to find emails mentioning getting an iPad as a present for your friend John. You perform a search using the keywords “ipad” and “john” and find that, along with the emails you’re looking for, there are also emails from Frank, discussing how cool the iPad is. You don’t want to see these.

To stop a particular word from appearing in Spotlight’s results, you can add a minus before it.

Using the example above, the following would return results that specifically don’t include any mention of Frank:



	 
	
​john ipad -frank​





Another way to refine searches is to use AND, OR, and NOT (these are known as Boolean operators). For example, to search for a message containing either the words “ipad” or “tablet,” you could type the following:



	 
	
​ipad AND tablet​





It’s important that AND, OR, and NOT are typed in uppercase, because otherwise Spotlight will consider them part of the search string.







	Tip 80
	Jump Between Views in Finder




Finder offers four separate ways of viewing your files and folders: Icon view, List view, Column view, and Cover Flow. You can switch between them using the icons on Finder’s toolbar (just above the file display area), but a quicker way to do so is to hold down Command and press 1, 2, 3, or 4 for Icon, List, Column, and Cover Flow views, respectively.







	Tip 81
	Reset Your Mac’s Hardware Settings




Sometimes your Mac’s hardware might start doing odd things. If you’re having hardware problems, you might try one of two methods to reset various hardware settings.

Resetting the System Management Controller

The System Management Controller (SMC) controls power management hardware and lights on your Mac. If your Mac has problems like blowing its fans at full speed, refusing to turn off when you close the lid (if it’s a portable Mac, of course), or odd behavior of LED lights (particularly those that show battery charge), then you might try resetting the SMC.

To do so on a portable Mac that has a battery that can’t be removed, shut down the computer and ensure the power cable is attached. Then hold down Shift+Control+Option and press the power button. Release, then restart your computer in the usual way.

On a Mac with a battery that can be removed, shut down the computer and remove the battery. Disconnect the power supply and then press and hold the power button for five seconds. Then reconnect, reattach everything, and boot as usual.

If you have an iMac or Mac Pro, simply shut down the computer and remove the power cable for at least fifteen seconds. Then reattach it and boot as usual.  

Resetting the Parameter RAM

The Parameter RAM (PRAM) holds hardware settings that are set by the user and that are carried across reboots, such as the speaker volume or the key repeat rate. If you have problems such as your computer displaying a question mark each time it boots, external monitors not working as they should, or the computer seems unable to remember the sound settings across each boot, then you might like to try resetting the PRAM. To do this, reboot and—before the Apple logo appears and you hear the boot-time chime—hold down Command and Option, then hold P and R. The system will restart. Release all keys and let the computer boot as usual.


Exploring OS X Lion: iCloud


iCloud seamlessly synchronizes via the Internet data across all your Mac computers, as well as across Apple tablets, phones, and compatible iPods. It will ensure the same address book details are used across all devices, for example, and will synchronize your calendars and website bookmarks. Provided the apps concerned are compatible (that is, they’re either designed for OS X Lion or have been updated for OS X Lion), you can also synchronize office documents and photographs. Examples of compatible apps include the most recent updates to Apple’s iWork and iLife suites.

iCloud includes the Find my Mac service, which lets you track down the approximate location of a lost or stolen Mac and lock the screen or show messages to anybody using the computer. Also included as part of iCloud is the Back to My Mac service, which allows you to share your Mac’s screen across the Internet and access your Mac’s files from a remote location.

Setting up iCloud can be done by selecting the iCloud entry within System Preferences (Apple menu→System Preferences). You’ll need an Apple ID to so do.[8] Here, you can also choose which items are synced to iCloud by putting checks next to each entry in the list, and you can purchase more storage in addition to the 5 GB provided free of charge to all OS X Lion users.



https://appleid.apple.com














	Tip 82
	Know How Much Free Disk Space There Is




You can find out how much disk space is free by right-clicking the icon in the title bar of any Finder window (the one to the left of the name of the folder) and selecting the bottom entry in the list, which will probably be the name of your computer. 

Then right-click your Mac’s hard disk icon in the Finder window and select Get Info. Look at the Available heading in the dialog box that appears.

To always have this info available, open Finder and click View→Show Status Bar. Then look at the bottom of the Finder window to see the figure. You can also hit Command+/ to toggle the status bar on and off, if you don’t want to have it stick around all the time.







	Tip 83
	See Forgotten Passwords 




Often your Mac will ask if you want to let it remember your login details for websites and even applications like Yahoo! Messenger.

I make such heavy use of this feature that I often forget what the password was, or even the account name in some cases. However, Macs make it easy to recover such details.

All passwords are stored in a secure keychain file, and you can use the Keychain Access program to get to it. It’s found in the Utilities folder of the Applications list within Finder. When the program starts, ensure All Items is selected under the Category heading on the left, then simply type the name of the website or application into the search field at the top right of the program window. Then double-click the entry you’re interested in in the list of results.

In the dialog box that appears, put a check in the Show Password box. You’ll need to type your login password to authorize this, but once you’re done, it will appear in plain text (ensure there’s nobody who can see your screen at this point, of course). Your login name will be listed above in the Account text field.







	Tip 84
	Look Inside Print Jobs




You can see what files are queued to be printed by opening System Preferences (Apple menu→System Preferences), clicking the Print & Scan icon, selecting the printer in the list on the left, and clicking the Open Print Queue button. 

But what if there are several print jobs queued and you want to know what they are? Simply select any in the list and hit Space to Quick Look them, just like you Quick Look files within Finder. For an example, see Figure 17, ​Quick Looking an entry in the print queue​.
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Figure 17. Quick Looking an entry in the print queue











	Tip 85
	Force an Application to Open a Document




You can drag and drop files onto any Dock icon to open them, but only if that application believes it can understand that particular type of file (for example, doc files are understood by Microsoft Word).

Unfortunately, some applications don’t realize they can read certain types of files when they actually can.

Forcing an App to Open a File

To force an application in the Dock to at least attempt to open a file it doesn’t believe it can, hold down Option+Command before clicking and dragging the file to the Dock. If the application genuinely can’t understand the file, either nothing will happen or you’ll see an error message.

Increasing the Chance of Success

For a higher probability of success when dragging to the Dock icon as described above, you might also try removing the file extension from the file before opening it as described (that is, the part after the dot in a filename, such as .jpg). To do so, select the file and hit Command+I. In the Name & Extension field of the dialog box that appears, remove the extension. 

Note that removing the extension by simply renaming the file by any other method probably won’t work, depending on your system’s settings—the file will retain the extension but give the appearance of not doing so.

Don’t forget to restore the file extension after attempting to open it!







	Tip 86
	Save Spotlight Searches for Reuse




Spotlight lives at the top right of the desktop; you can access it by clicking the magnifying glass icon (or hitting Command+Space).

Saving Searches

To save a search for reuse later on, click the Show All in Finder entry at the top of the Spotlight search results. This will open a Finder search window. Directly beneath the search box at the top right, a Save button will appear, which when clicked will let you save the search as a Smart Folder—a pseudo-folder that contains links to files returned by the search term. It’ll be saved to the Saved Searches folder within the Library folder of your home directory, but if you check Add to Sidebar when saving the search, the Smart Folder will always be visible in the left pane of every Finder window. You can simply click on the saved search to run it again.

Viewing and Using Saved Searches

By navigating manually to the Saved Search folder (open a Finder window, hit Shift+Command+G and type ~/Library/Saved Searches/), you can double-click the searches to run them or create aliases on the desktop to be able to run them very quickly (to create an alias, hold Option and Command together and drag the saved search to where you’d like the alias to live).







	Tip 87
	See a Map of an Address You’ve Been Sent




If you type a contact address in any of your Mac’s built-in applications or come across one in a web page, simply highlight the whole thing and right-click the selection. Then click Show Address in Google Maps. As you might guess, this will perform an instant look-up of the address using Google Maps.[9]


If you see an address in a mail message, hovering the mouse over it should reveal an arrow icon that, when clicked, will show a menu offering a Show Address in Google Maps option.







	Tip 88
	Do Instant Math




The Spotlight search tool also includes a simple calculator. Simply activate Spotlight search by clicking the icon at the top right of the screen or by pressing Command+Space and typing the math expression (for example, 2+2 or 15-4). You’ll see the response immediately underneath in the form of a search result. For multiplication and division, use * and /, respectively.

Constants such as pi are understood (just type pi), and for square roots type sqrt followed by the number in parentheses, such as sqrt(9). cos, sin, and tan also work as you’d expect (for example, type cos(31)).

By hovering your mouse over the result so that it’s highlighted, you can copy the math into the clipboard using Command+C and then paste it into any application with Command+V (or by clicking Edit→Paste on the application’s menu).

Spotlight’s math function is actually an extension of the math abilities built into the command line of OS X. To learn more about what commands you can use, open a Terminal window (Finder→Applications→Utilities→Terminal) and type man math and then look under the List of Functions heading.







	Tip 89
	Get the Combined Size of Multiple Files




You probably already know about the File Info window, which you can open by selecting a file and hitting Command+I. This shows details about the file, such as its size, where it was downloaded from (if applicable), and so on. 

Highlighting several files at once and hitting Command+I doesn’t do what you might expect. Instead of showing a combined info window, it opens individual Info dialog boxes for every single file you’ve selected.

The solution is to highlight the files in question and hit Option+Command+I instead. This will open the less-well-known Multiple Item Info dialog, showing the combined size of the files (useful if you’re planning to burn them to CD or DVD, for example).

The Multiple Item Info dialog is dynamic, that is, you can highlight other files while it’s open and it will update to reflect their details, including single items you select.







	Tip 90
	Manage Project Files Using Color Labels




Files and folders can have color labels applied to them, which is to say that you can color them so that their filenames and icons in listings are outlined in red, blue, green, and so on. This is done by right-clicking the file or folder and selecting the color under the Label heading in the menu that appears. 

The intention is to help users organize files. You could label all files for a particular project in the same color, for example, so they’re easily identified.

Label colors can also be combined with saved searches as a method of instantly viewing all of a project’s files, no matter where they’ve been saved on your hard disk.

Setting Up

Here’s how to set it up:


	
Ensure files and folders you create for the project in question always have the same color label applied. Apply the color label to any existing files. Files can be bulk labeled by selecting them all and opening the Multiple Item Info dialog (see Tip 89, ​Get the Combined Size of Multiple Files​). Obviously, for this trick to work, you won’t be able to use that color label with any nonproject files!



	
Open Spotlight search (hit Command+Space) and then type label:, followed by the color. So if the project files are colored blue, I would type label:blue.



	
Listed beneath should be all the project files. At the top of the list of results in Spotlight will be an entry: Open All in Finder. Click this.



	
In the Finder window that appears, click the Save button near the top right, and—in the dialog box that appears—give the saved search a name, perhaps relating to the project. Be sure the Add to Sidebar button is checked and then click the Save Button.





Accessing the Saved Search

From then on, you’ll see the saved search on the left of the Finder window in the Favorites list. Clicking it will show all the project files, no matter where you’ve saved them or what type of file they are. To create an alias of the search somewhere else, such as the desktop, right-click the search and select Open Enclosing Folder. In the Finder window that appears, click and drag the saved search to wherever you want the alias to live, but before releasing the mouse button, hold down Option+Command. Later, double-clicking the alias will open the search. 







	Tip 91
	Record Movies, Screencasts, and Podcasts




Despite its name, QuickTime Player can help if you want to record a movie of yourself using your Mac’s built-in camera and if you want to create a screencast (that is, a movie of what you’re doing on screen). You can also create audio podcasts using QuickTime Player (although see also Tip 187, ​Podcast like a Pro from Your Mac​). 

Creating a Recording

Just start the application (Finder→Applications→QuickTime Player) and click File→New Movie Recording, New Audio Recording, or New Screen Recording, depending on what you want to do.

In the window that appears, hit the red record button to start recording; hit it again to stop. When recording screencasts, there’s an option to record the entire screen or to click and drag to record just a section of the screen area. Note that when recording the screen, the playback/record controls are visible while you’re recording but don’t appear in the actual movie).

All files are saved into the Movies folder of your home folder, even if they’re just audio files.

Altering Input Sources

To alter which camera or sound input is used, click the small down arrow to the right of the recording/playback controls before clicking the Record button. Note that when recording screencasts, no audio is recorded unless you specifically set your Mac’s built-in microphone as an input source—to do so, click the down arrow at the right of the QuickTime transport controls and choose an entry under the Microphone heading. See Figure 18, ​Selecting a sound source when recording a screencast​.

Exporting Your Creation

Once a screen or movie recording has been made, you can instantly shrink it down for use online or sending via email by clicking File→Export. If you click File→Export for Web, QuickTime will even save an HTML file (iFrame.html), which you can open by double-clicking for specific instructions on how to use video online.

You can also select an entry on the Share menu to automatically shrink and upload the file to social networking sites such as YouTube or Facebook.

To learn how to trim your home-recorded movies using QuickTime Player, see Tip 127, ​Edit Movies Within QuickTime Player​. 
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Figure 18. Selecting a sound source when recording a screencast











	Tip 92
	Print from Finder




This tip is blindly obvious but little known: selecting a file in Finder and then clicking File→Print on the menu will automatically open the file in the default editor (that is, a photo will open in Preview and so on) and automatically print it before closing the file (depending on the app in question—some apps leave the file open).

The only drawback is that the application doesn’t quit afterward. 







	Tip 93
	Add an Eject Button




Ejecting CDs or DVDs can be a little cumbersome, especially if you’re not using a Mac keyboard and therefore lack an eject key. Clicking the Eject icon next to the CD/DVD entry in Finder is perhaps the best method, but an even quicker way is to add an Eject button to the menu bar or Finder. Here’s how to set it up.

Adding an Eject Icon to the Menu Bar

Open Finder, hit Shift+Command+G, then type /System/Library/CoreServices/Menu Extras. Then double-click Eject.menu. The new button will instantly appear at the top right of the menu bar near the clock and will stay across reboots. Clicking it will show a menu that allows you to eject discs from the CD/DVD drive.

Holding down Option while clicking the icon will force the CD/DVD drive to eject, even if it doesn’t believe it has a disk in it—useful for when discs get “stuck” (see also Tip 128, ​Eject a Stuck CD/DVD Disc​).  

To get rid of the new icon at any time, hold down Command and click and drag it away from the menu. Upon releasing the mouse button, it will disappear instantly.

Adding an Eject Icon to Finder

Right-click the toolbar within Finder and select the Customize Toolbar option. Then, in the dialog box that appears, click and drag the Eject icon to a blank spot within the toolbar area (the Eject icon is in the top row of the dialog box icon listing).

To remove the new icon in future, hold down Command and drag it up from Finder. Release the mouse button and it’ll disappear in a puff of smoke.







	Tip 94
	Access Hidden Menu Options




Holding down Shift, Control, or Option while viewing virtually any application or system menu will display various alternatives to standard menu choices. For example, holding down Option while accessing Finder’s File menu changes the Open option to Open and Close Window, which will open the selected file and then close the Finder window immediately afterward. 

Try holding down Shift in addition to Option—other options might be revealed too.

The number of alternative options displayed varies depending on the support within the application, with the Mac’s built-in applications being particularly well supported.

On some menus you might notice that holding down Option removes the ellipsis after an entry (that is, the three dots). This means that clicking that menu option will activate it right away without any confirmation or questions. For example, clicking the Apple menu, holding down Option, and hitting Shut Down will cause the Mac to attempt to shut down instantly, without a confirmation dialog box appearing (although you’ll still be prompted to save files). 







	Tip 95
	Instantly Search Google 




Highlight some text in any application, and then drag and drop it onto the Safari icon in the Dock. This will instantly search Google using the text as a search query. 
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Figure 19. Applying visual effects to a login picture











	Tip 96
	Enhance Your Login Picture with Visual Effects




On Macs that have a built-in camera, there’s an option to take a quick snapshot of yourself. This photo then appears in the login window next to your username. But the pic can be easily enhanced, as follows:


	
Open Address Book (Finder→Applications→Address Book) and select your own entry in the list of contacts. If there’s more than one entry, look for the one that—when selected—has the word “me” beneath the thumbnail preview of the login pic. 



	
Double-click the thumbnail preview picture in the pop-out window and click the circular button to the right of the camera button.



	
This will open up an effects palette similar to the one seen in Photo Booth, and clicking on any of the previews will instantly apply the effect to your picture. See Figure 19, ​Applying visual effects to a login picture​.



	
By holding down Option and clicking and dragging the image after you’ve applied the effect, you can also rotate it (hold Shift to “snap” the image to points on the compass-like circle that appears). Simply clicking and dragging without Option will let you reposition the image within the frame. 



	
Once you’ve finished, click the Set button at the top right of the window. Note that you can repeat these steps at a later date and will be shown the original iSight/FaceTime HD snapshot once more without the effects you added, ready for a different set of effects to be applied. 





You can also click the camera icon in the pop-out effects window to take an entirely new photo for your login pic.







	Tip 97
	View a Cover Flow of iCal Events




Here’s a tip that might be useful to those who use iCal, the built-in calendar and organizer app. By making clever use of Finder’s Spotlight search feature, you can present all your appointments as a Cover Flow view and swipe your way through in the usual way, just as you would a list of files or a collection of photographs, as follows:


	
Open a Finder window, and in the search box at the top right, type kind:ical. Then check that This Mac is selected next to the Search heading.



	
Switch to Cover Flow mode if you haven’t already (a quick way of doing this is to hit Command+4).



	
Sadly there’s no way within Finder to sort the entries by their due date (Finder sees the iCal events as a series of files), but to make this tip a little more useful, right-click the Last Opened heading in the Finder file list and select Date Created from the pop-up list. Select it when it appears as a heading, which will sort the entries by the date they were created, which is slightly more logical than organizing them by their filenames, for example. 





If you only want to see meetings involving, say, John Smith, then simply add that to the search term: kind:ical John Smith.







	Tip 98
	Make the Mouse Cursor Bigger




Migrating Windows users might recall being able to change the type and size of the mouse pointer within Microsoft’s products. Apple doesn’t allow users to change the design of the mouse pointers, but you can make them bigger. This is intended to help those with limited eyesight, but it can be very useful for the rest of us too! You’ll find the setting within the Universal Access pane of System Preferences (Apple menu→System Preferences). Click the Mouse & Trackpad tab and then click and drag the Cursor Size slider. The changes will take effect immediately, so choose a size you’re happy with. Alas, it’s not perfect—the existing small mouse cursors are simply magnified to make them larger, leaving them looking a little ugly at larger sizes.

To revert back to default sizes, just click and drag the Cursor Size slider all the way to the left.







	Tip 99
	Be an Application Switcher Power User




Holding down Command and tapping Tab will let you switch between open applications (the equivalent of Alt+Tab in Windows). Here’s how to get the most from this useful tool.

Knowing the Basics

Holding down Command, tap Tab until the application you want to switch to is highlighted in the list of programs. Alternatively, you can tap the backtick key (left of the 1 key on US English keyboards, or left of the Z key on some other English keyboards) to move the section highlight left.

Keeping Command depressed, you can also use the left and right cursor keys to move the selection highlight between the application icons too. 

Once the application you want to switch to is highlighted, release the Command key and the application will switch to the foreground, ready for use. 

Previewing Program Windows

To see a preview of an application window (or windows, if more than one file is open in that application) while switching tasks, hold down Command and tap the up or down cursor keys (you can also hit 1). This will activate Mission Control in App Exposé mode, which shows only the open windows for the current program. At this point you can release the Command key and select a program window using the mouse. 

Be aware that if a program is active (that is, there’s a spotlight by its icon in the Dock) but it has no open windows, then all you’ll see when you switch to App Exposé is a blank screen. You can resume switching through apps by once again holding down Command and tapping Tab.

Restoring Minimized Programs 

It sounds complicated, but it’s actually quite useful once you’ve mastered it.

If you switch to a minimized app using the application switcher, it won’t maximize, which is somewhat counterintuitive! However, a simple trick gets around this limitation, although it’ll only maximize the most recently minimized window and not all the app’s windows.

Once the minimized application is highlighted in the switcher icon listing, press and hold Option and then release Command. The most recently minimized application window will now restore from the Dock. It’s odd, but it works!

If the program isn’t minimized but is simply open and not editing a document, holding down Option in this way will create a new document—the equivalent of opening the app and clicking File→New.

Quitting or Hiding Apps

To quit an application, just highlight the app in the list by tapping Tab and then tapping Q, keeping Command depressed. This is an excellent and quick way of pruning from memory apps that you’re no longer using. Hitting H instead will hide the app in question in the Dock. If the app is already hidden, tapping H will unhide it. 







	Tip 100
	Correct Your Mac’s Dictionary




Your Mac will spellcheck text when you type, but you might have accidentally told it to “learn” a word that’s spelled incorrectly. Usually this is done by right-clicking a word highlighted as incorrect and selecting the Learn Spelling option from the menu that appears. The result is that the word isn’t highlighted as misspelled and is ignored in spellchecking passes.

To undo the damage, open Finder and then hit Shift+Command+G. Then type ~/Library/Spelling into the dialog box, which will open the location where your personal dictionary is stored. 

Once there, open the LocalDictionary file. This will open in TextEdit, and you’ll see a list of words you’ve added to the dictionary. Just locate the misspelled word and delete it, removing the line break also (so there’s still a continuous list of words without any blank lines). Then save the file. The changes should take effect immediately, but if they don’t, try logging out and back in again.







	Tip 101
	Make the Volume Ultra-Quiet




If your Mac has built-in speakers, you’ll be familiar with altering the volume using keyboard shortcuts (usually via the F11 and F12 keys). What you probably don’t know is that there’s a secret ultra-low volume setting. 

To access it, press the volume decrease hotkey until the sound is muted (that is, the speaker icon onscreen is struck through). Now press the actual mute hotkey (usually F10). You’ll see that the volume level is set at no bars. However, the sound isn’t muted. In fact, it’s a notch quieter than the lowest setting usually allowed—enough to hear things in a very quiet room.







	Tip 102
	Quick Look Items in a Stack




As hinted in a few other tips here, Quick Look works just about anywhere and everywhere in OS X. It can be used to view items in a Dock stack, for example. Just hover the mouse over the item and hit Space to Quick Look. A pop-out window rather like that which appears next to entries in the Spotlight list of results will appear. You can also highlight the item using the up/down cursor keys once the stack has expanded before you hit Space to Quick Look. 

To learn how to make it slightly easier to know which item the mouse is hovering over before you use Quick Look, see Tip 57, ​Add a Cool Visual Effect to Dock Stacks​.







	Tip 103
	View Application Icons Close Up 




This isn’t the most useful tip in the world, but it’s worth a try if you’re a fan of your Mac’s look and feel and want to explore more. Here are a variety of ways to view most Mac application icons, which are often high-quality works of art.
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Figure 20. Viewing OS X icons at full resolution





Using Preview

Go to the Applications folder within Finder, click the application whose icon you’d like to examine, and hit Command+C to copy it to the clipboard. Start Preview (Finder→Applications→Preview) and hit Command+N to create a new file based on the clipboard contents. Hey, presto! You should now be able to view (and even save) the application icon in glorious high resolution. Several different sizes will be available, shown in the drawer at the side.

Looking Inside Packages

You can also look inside individual app packages to find the icon, along with any other icons the app uses. Open Finder and click the Applications link. Then right-click any app you’re interested in and select Show Package Contents. In the new Finder window, browse to Contents/Resources/ and then double-click any icns file to open the app’s icon(s) in Preview.

Be very careful not to modify or delete any files.

Viewing the Core Set of Icons

If you’d like to take a look at the basic set of OS X icons, open a Finder window, hit Shift+Command+G, and type /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources. Then double-click any icns file to view (for an example, see Figure 20, ​Viewing OS X icons at full resolution​). Be careful not to alter anything within the folder! Doing so could damage your system.







	Tip 104
	Lock Files to Avoid Changes or Deletion




You can manually lock any file on your Mac, which will prevent edits or deletion until the file is specifically unlocked. This can be useful if you have a master version of a file, for example, that you want to ensure remains sacrosanct. Folders can also be locked, which will prevent the folder or its contents being edited or deleted. 

If you try to edit a locked file, you’ll be warned and will have to specifically opt to unlock the file.

Locking Files via File Info

There are several ways to lock a file or folder. The easiest is simply to select the file or folder in Finder or on the desktop and hit Command+I to open the File Info dialog box. Then put a check in the Locked box under the General heading.

To unlock a file or folder later, simply repeat the steps and remove the check.

Locking Files via Applications

Certain applications, including those built into OS X such as TextEdit, support file locking from within the application. Click the filename in the window’s title bar and select Lock from the pop-up menu that appears. For an example, see Figure 21, ​Locking a file from within an application​. You can also select to unlock a locked file and browse previous versions (see ​Exploring OS X Lion: Auto Save and Versions​).

Automatic File Locking

Files are automatically locked if they aren’t edited within a two-week period. This delay can be changed by opening Time Machine preferences within System Preferences (Apple menu→System Preferences) and clicking the Options button. Then change the dropdown option alongside the Lock Documents heading.
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Figure 21. Locking a file from within an application











	Tip 105
	Replace Dashboard and Mission Control Wallpapers




This is a hack that modifies system files and therefore affects all users of the computer. It involves some risk and shouldn’t be undertaken unless you have an up-to-date Time Machine backup.

The wallpaper backgrounds that you see behind Dashboard and Mission Control can easily be replaced. They’re actually patterned wallpaper tiles rather than large images, and they’re repeated from left to right and from top to bottom along the screen. To replace them, you’ll need to source a similar small pattern image that’s designed to be repeated when used as desktop wallpaper or you can choose image files that are the exact same size as your monitor resolution (beware: if an image is too small, OS X will repeat it, creating an ugly effect). You’ll find many wallpaper pattern images by searching using Google.

Replacing the Main Wallpaper Images

Here are the steps to replacing the wallpapers:


	
Once you’ve found your designs, you’ll have to convert them to PNG images, if they aren’t already. To do so, open them in Preview by double-clicking them, then click File→Export. Choose PNG from the Format dropdown list. Then click Save.



	
Rename the file you intend to use to replace the Mission Control wallpaper as defaultdesktop.png. Rename the file you intend to use for the Dashboard wallpaper as pirelli.png.



	
Open Finder and hit Shift+Command+G, typing the following in the dialog box that appears: /System/Library/CoreServices/.



	
Look for the Dock file. Right-click it and select Show Package Contents from the menu that appears. 



	
In the new Finder window, browse to the Contents/Resources folder. Then locate the existing defaultdesktop.png and pirelli.png files in the folder, and drag them to a backup location on your hard disk (for example, your Documents folder). Keep these backups safe!



	
Now drag and drop your new
defaultdesktop.png and pirelli.png files on top of the Finder window that is browsing /System/Library/CoreServices.



	
Click the Authenticate button in the warning dialog box that appears, and then click the Replace button in the dialog box that warns about files already existing in the location. Type your password when prompted.  



	
That’s it! Log out and back in again for the changes to take effect.





Replacing the Dashboard Thumbnail Image

The only negative to this tip is that the thumbnail preview of Dashboard within Mission Control still uses the old Dashboard background. The image used for this miniatured background is called mini_pirelli.png and it’s located in the Dock package, like the images mentioned above.

The mini_pirelli.png thumbnail of the Dashboard is always 10 percent of your screen’s resolution—on my MacBook’s 1280 x 800 screen, the thumbnail is 128 x 80 pixels, for example, while on my 1920 x 1080 external monitor, the thumbnail is 192 x 108. This makes creating a replacement background for the Dashboard thumbnail easy—simply create a copy of the defaultdesktop.png image you used above and reduce it to 10 percent. To do this in Preview, open the image, click Tools→Adjust Size, and change the Pixels dropdown in the dialog box to read Percent. Then enter 10 in the Width and Height fields and click OK. Then click File→Export and save the image as mini_pirelli.png. Replace the default version of the file within the Dock package, as described previously, backing up the original first.

Restoring the Default Wallpapers

To restore the default wallpapers at a later date, open a Finder window, hit Shift+Command+G, and type /System/Library/CoreServices/. Once again right-click the Dock file and select Show Package Contents, browsing to the Resources folder. Then locate the backups you made of the original two (or three) files and drag and drop them onto this Finder window. Again, you’ll need to click the Authenticate button and the Replace button in the dialog boxes that appear. Type your password when prompted, then log out and back in again for the changes to take effect.







	Tip 106
	Use a Screen Saver as a Desktop Background




This is a fun hack that lets you use any screen saver as a desktop backdrop in place of the regular wallpaper. You could use one of your Mac’s colorful animated screen savers if you’re a big fan of eyestrain as you work, but it’s perhaps more sensible to use any of the entries under the Pictures heading, which will gently cycle through images.

Setting Up

To give it a try, follow these steps:


	
Using Finder, hit Shift+Command+G, and type /System/Library/Screen Savers in the dialog box that appears. This is where your Mac’s screen saver files are stored. Look at the filenames of the screen savers (that is, files that end in the qtz or slideSaver extensions.



	
Choose one that you’d like to use, and make a note of its filename, including capitalization (if used), but ignore the qtz or slideSaver extension. You can use the Desktop & Screen Saver section of System Preferences (Apple menu→System Preferences) as a guide for what each screen saver does.



	
Open a Terminal window (Finder→Applications→Utilities→Terminal) and carefully type the following line of code, replacing XX with the name of the screen saver you noted earlier:



	 
	
​nohup /System/Library/Frameworks/ScreenSaver.framework/Resources/​




	 
	
​        ScreenSaverEngine.app/Contents/MacOS/ScreenSaverEngine -module XX​




	 
	
​        -background​





You’ll see the screen saver start to play in the background.



	
You can now close the Terminal window, and the screen saver will continue to play in the background. Ignore the warning that appears about terminating an application.



	
If you get tired of the screen saver, open a Terminal window and type the following:



	 
	
​killall ScreenSaverEngine​









Note that this tip isn’t ideal for long-term use on portable Macs because it places a small additional drain on the battery. However, desktop Macs or portable Macs connected to power sources shouldn’t see any downside.

Making It Permanent

The screen saver wallpaper will not survive across reboots. You must invoke it each time you boot.

If you decide you would like the screen saver wallpaper to start each time you boot your computer, follow these steps:


	
Open AppleScript Editor (Finder→Applications→Utilities→AppleScript Editor), click File→New, and type the following into the main editing area:



	 
	
​do shell script "nohup /System/Library/Frameworks/ScreenSaver.framework/​




	 
	
​        Resources/ScreenSaverEngine.app/Contents/MacOS/ScreenSaverEngine​




	 
	
​        -module XX -background"​





Again, replace XX with the name of the screen saver, as above.



	
Click File→Save As, and in the dialog box that appears, change the File Format dropdown to read Application. Then save your new script in a safe location, such as within your Documents folder. Call it something like Run Screen Saver at Login.



	
Quit AppleScript Editor and open System Preferences (Apple menu→System Preferences). Click the Users & Groups icon, then click the padlock icon at the bottom left of the System Preferences window. Enter your password when prompted.



	
Click the Login Items tab, then use Finder to locate your new script. Drag and drop it on top of the list of startup items within the System Preferences window. This will add it to the list. Put a check in the box under the Hide column.





And that’s it! You can log out and back in again to see the screen saver automatically start. There’s only one drawback, which is that the AppleScript you created spawns a Dock icon that you’ll have to manually remove each time you boot—right-click it and select Force Quit.

To stop your screen saver wallpaper starting at boot-up, repeat the steps above, opening System Preferences, but this time select the entry in the startup program list for your AppleScript and click the minus button below. 

A better way of starting a screen saver wallpaper at login is to use a personal launchctl service. Those experienced with launchctl can download a plist file from http://mackungfubook.com/screensaver.plist. Open the file in a text editor, replace any uppercase words with your own details, then place it in ~/Library/LaunchAgents.







	Tip 107
	View Tech Info at the Mac Login Screen




Most Mac users are familiar with the login screen, which appears whenever you boot or reboot your Mac. At the top right of the screen is a brief display showing the time, along with things like details about the Wi-Fi connection and battery power, in the case of a portable Mac. Note that those using FileVault won’t see this info because a different login screen technology is used.

Altering a secret setting allows you to add a little extra functionality so that when the time display is clicked, the info display will switch to showing the computer’s IP address, then the name of the computer, and then the build version number of the operating system.

Setting Up

To make the change, which affects all users of the system, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following (note there is a space between AdminHostInfo and 1). You’ll be prompted to enter your login password afterward, so do so:



	 
	
​sudo defaults write /Library/Preferences/com.apple.loginwindow AdminHostInfo​




	 
	
​        1​





Then log out to test it. Click the time display to cycle through the information displays.

Reverting to the Default

To revert to the default display showing only the time, open a Terminal window and type the following:



	 
	
​sudo defaults delete /Library/Preferences/com.apple.loginwindow AdminHostInfo​











	Tip 108
	View the Boot Menu Using an Apple Remote




If you use your Mac’s bootcamp feature to install Windows alongside OS X, you might already be aware of the menu that lets you choose between operating systems at boot time or accessing the repair system. Holding Option before the Apple logo appears during booting should make the menu appear.

However, another way of seeing it is to press and hold the Menu button on an Apple Remote as the computer boots up.


Exploring OS X Lion: FileVault


FileVault lets you encrypt the startup disk of your Mac in a way that’ll have no impact on the way your use your computer. You won’t even know the disk is encrypted, and the only difference will be that you’ll have to provide your login password immediately after powering up or rebooting rather than at the login screen a minute or two after the computer has started.

The protection offered by FileVault in OS X Lion—technically known as FileVault 2—is industrial strength: XTS-AES 128 encryption. Anybody who steals your Mac will be simply unable to either boot the computer without your password or access any of the contents on the hard disk by removing the disk from the computer and attaching it to a different computer (so-called forensic analysis).

FileVault can be activated by opening System Preferences, then clicking Security & Privacy, and then selecting the FileVault tab. The disk will have to be initially encrypted, which will take several hours, but that happens in the background. Check back on the Security & Privacy pane of System Preferences periodically to see its progress. 











	Tip 109
	Stop Programs Automatically Opening Files on Restart




When you start a program, OS X Lion will attempt to open any files that were open the last time you quit the app. This is either very useful or extremely annoying, depending on your personal preference, but here’s how to take control of this feature.

Permanently Deactivating App Restore System-Wide

You can permanently deactivate this feature in System Preferences (Apple menu→System Preferences). Click the General icon and then remove the check next to Restore Windows When Quitting and Reopening Apps.

Temporarily Deactivating for an Individual App

However, if you wish to temporarily deactivate automatic file restore for a particular application when you’re quitting it (so that it’ll open “clean”), simply quit the app using the Option+Command+Q keystroke rather than the usual Command+Q key combination. Alternatively, hold down Option before clicking the Quit option on the program’s menu—you’ll see the menu option change to Quit and Discard Windows.  

Permanent Disabling for an Individual App

It’s also possible to permanently deactivate the feature on a app-by-app basis. You could turn it off for TextEdit, for example, while leaving it active for all other apps. Here are the steps required:


	
You’ll need to find the name of the preferences domain for the app in question, that is, the name of the file that holds its configuration settings. Open Finder, hit Shift+Command+G and type ~/Library/Preferences.



	
In the list of preference files, look for the one that matches the app you’re interested in. All will start with com., followed by the name of the developer (that is, adobe or apple, for example) and the name of the app will then follow. Built-in OS X tools will always start com.apple.—TextEdit’s preference file is com.apple.TextEdit.plist, for example.



	
You can ignore the plist extension, and you should end up making a mental note of something like com.apple.TextEdit.



	
Quit the app in question if it’s running, then open a Terminal window (Finder→Applications→Utilities→Terminal) and type defaults write, then follow it with the preference domain you discovered and follow it with NSQuitAlwaysKeepsWindows -bool FALSE. The line for TextEdit would read as follows, as an example:



	 
	
​defaults write com.apple.TextEdit NSQuitAlwaysKeepsWindows -bool FALSE​







	
Restart the app. The changes will take effect immediately. Note that with some apps, the first time you run the app it might restore its old windows. However, quitting and restarting once more will put a stop to it. 





Should you wish to reactivate window restore for the app, quit the app and open a Terminal window. Then type the following, again substituting the correct preference domain (the following will reinstate window restore for TextEdit):



	 
	
​defaults delete com.apple.TextEdit NSQuitAlwaysKeepsWindows -bool TRUE​





Quit and restart the app for the changes to take effect. Again, you might have to quit and open the app once more for the changes to actually take effect. You might also try logging out and back in again.







	Tip 110
	Create Encrypted Archives for All Computers





    Elsewhere I explained how to create encrypted archives for use under OS X (see Tip 33, ​Create a Totally Secure Store for Personal Files​). But if you also own a Windows or Linux
    computer, you might want to create cross-platform encrypted archives
    that you can copy to, say, a USB stick and carry around with you.
  

Luckily, a piece of open source (and therefore free)
  software called TrueCrypt provides this functionality. TrueCrypt works by creating an encrypted
  file store. This single file is then mounted by the
  operating system and accessed as a virtual disk drive in a similar way to when you attach a
  USB memory stick.


When you’ve finished, you unmount it, thus “locking”
the store so that nobody can access it without typing the
password.

Setting Up and Installing

 
		Start by downloading TrueCrypt from http://www.truecrypt.com. Select the Mac OS X ".dmg package" release. You might also choose to download the versions for any other operating systems you’d like to use your new file store under.

Once the download has finished, install the software by double-clicking the dmg file and then double-clicking the mpkg installation file. 

If you find TrueCrypt doesn’t work in any of the steps described below, you might also need to download and install an updated version of the MacFuse subsystem TrueCrypt relies upon. This program can be downloaded from http://mackungfubook.com/MacFUSE-Tuxera-2.2.dmg.

Creating an Encrypted Archive


		Run the program (you can find it in Applications). The following instructions explain how to create an initial encrypted file store:
	


	

			Encrypted file stores are known as volumes. So, click the Create Volume button. A wizard will appear. Ensure that Create an encrypted file container is selected, and click Next. (Note that the second option, Create a volume within a partition/drive, might seem to suit your needs better, but creating a container file allows the encrypted file store to be transferred easily from one USB key stick to another, if need be; thus, it’s the best choice here.)
		



	

			Next, select the type of volume you want to create. The default choice of Standard TrueCrypt volume is fine. You might want to investigate the Hidden TrueCrypt volume option at some point, but it has a specific purpose and adds some complications. When done, click Next.
		



	
			
			On the Volume Location screen, click Select File to type a filename and select a location for the new archive. By default TrueCrypt archives don’t need a file extension, but it’s a good idea to give it one, so add the extension .tc. This will enable you to double-click the file store to open it in Windows. Once you’re done, click the Next button to move to the next step. 
		



	

			You’ll be invited to choose the encryption algorithm you want to use. You can select each in the list to read a description underneath the list showing the pros and cons of each choice. AES is a good choice for most uses. You can also change the hash algorithm if you want, but there shouldn’t be any need to do this. Once you are done, click Next.
		



	
			
			Now you’ll be prompted to enter the size of the file store. If you’ve chosen to create the file store on a USB stick, you’ll be told how much free space is available. You can’t enter fractions of a GB/MB, so to enter 1.9 GB, for example, you would need to select MB from the dropdown list and type 1946 into the Volume Size text box (bearing in mind that there are 1024 MB in 1 GB, so 1.9 x 1024 = 1945.6). Once you’re done, click Next.
		



	

			Now you’ll be invited to choose a password for the archive. As always, a good password involves both lowercase and uppercase characters and should be as long as you can make it while still being possible to remember. Avoid clichés or anything else that might be easily guessed. Click Next when done. 
		



	

			You’ll now be asked to choose the file system for the file store. FAT is the best choice because it’s understood by Windows, Mac OS X, and Linux. Click Next when you’ve made your choice. 
		



	

			Next you’ll go to the volume format screen. However, first you must create some random data for the encryption process. As strange as it might seem, this is done by waving the mouse pointer around within the TrueCrypt program window. So, wave the pointer around for a few seconds and then click the Format button. After this, the file store will be created. This might take some time for larger archives. Once it’s done, click Exit. 
		





Accessing the File Store

After creating the file store, you must mount it so it’s accessible. Follow these steps to do so—the instructions are essentially the same for versions of TrueCrypt running on all operating systems:
	


	

			Start TrueCrypt if it isn’t already running, as described earlier, and in the main TrueCrypt dialog box, select 1 under the Slot heading. 
	



	
		
			Click the Select File button. Navigate to your new file store using the file-browsing dialog box, and click the Open button. Back in the TrueCrypt window, click the Mount button. You’ll immediately be prompted for its password, so type it. After this, a new drive icon should appear in the Devices list in the Finder sidebar offering access to the encrypted file store, as if a new drive had been connected to the system. It’ll probably be called  NO NAME. You can drag and drop files to it, just like any removable storage device. 
	



	

	  Note that you’ll  need to keep the TrueCrypt program running while using the archive file. However, you can close the program window, which will leave TrueCrypt running in the Dock. It’s also possible to configure TrueCrypt to quit without unmounting the archive: on the menu, click TrueCrypt→Preferences, ensure the Security tab is selected, and remove the check from the box that reads TrueCrypt Quits. 
	



	
	
		Once you’ve finished using the file store, you can simply unmount it in the usual way: open Finder, and click the Eject icon next to the file store’s entry in the devices list. Alternatively, start TrueCrypt again, select the archive’s entry in the list, and click the Dismount button.
	






		 When the file store is mounted, a useful tip is to click Favorites→Add Selected Volume to Favorites. From then on, you can quickly mount the file store by selecting its entry on the Favorites menu when you start TrueCrypt. You should also be able to right-click the TrueCrypt icon in the Dock when the program is running, and click the entry there to automatically mount it. 







	Tip 111
	Look Up Words Instantly




One of my favorite features of my Mac is the Dictionary application, which, just like its dusty, shelf-bound companions, allows you to look up the definitions of words.

However, there’s no need to go to the trouble of actually starting the app to look up definitions. It can be called from within other applications in various ways.

Using Spotlight

Typing a word or short phrase into Spotlight will return a definition, for example, although it will appear beneath all the files and folders that match the search term. You can then click the dictionary entry within the search results to open Dictionary or just hover the mouse over the search result to see the full definition in a pop-out Quick Look window.

Right-Clicking for Definitions

In some apps, you can also highlight a word and click the application menu, then Services→Look Up in Dictionary.

Using Keyboard Shortcuts

In some apps, you can hover the mouse cursor over a word and then hit Control+Command+D to see a pop-out window showing the definition of the word (see Figure 22, ​Looking up a word instantly​). This works largely in built-in apps like Safari.

Gesturing for Word Look-up

If you use a multitouch trackpad, you can also hover the mouse cursor over a word and double-tap with three fingers bunched together. This will cause a pop-out window to appear, showing the definition. To get rid of it, just click anywhere outside of the pop-up. Looking up words this way takes some practice to do right but can be extremely useful!
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Figure 22. Looking up a word instantly











	Tip 112
	Repair Your Mac—Even If the Disk Appears Trashed




OS X Lion installs a small set of tools on your hard disk that you can boot to should things go wrong. Just hold down the Option key when you start your computer, before you hear the chime sound and before the Apple logo appears. Then use the left/right cursor keys to select the recovery option from the choices that appear and hit Return to boot one. 

Once the recovery system is running, you can access Disk Utility to scan the disk for errors, restore from a Time Machine backup, and get access to a Terminal window to carry out other repairs. You can even reinstall OS X from scratch.

You can also write the recovery toolkit to a USB memory stick, from which you can boot the computer to get things back on the road should you find yourself not even able to boot the hard disk. To do so you’ll need a USB memory stick of at least 1 GB that you can dedicate to the purpose. 

Apple has released a utility that can be used to automatically create a recovery USB memory stick, and it can be downloaded from http://support.apple.com/kb/DL1433. Just insert the memory stick, run the program, and follow the step-by-step instructions. You’ll need to enter your login password when prompted. 







	Tip 113
	Turn Off File Download “Quarantining”




Whenever you download a file using a web browser, your Mac will warn you when you first open it that it could be dangerous. It’ll tell you when you downloaded it and from where. This is known as quarantining and can get annoying after a while, especially if you only download files from sources you know are safe.

To permanently turn off this warning message, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.LaunchServices LSQuarantine -bool FALSE​





Then log out and back in again to have the changes take effect. If in future you wish to restore the warning system, type the following:



	 
	
​defaults delete com.apple.LaunchServices LSQuarantine​





You’ll need to log out and back in again for the changes to take effect.







	Tip 114
	See Where Files You’re Editing Are Stored




Sometimes I open a file for editing, perhaps one attached to an email, and I have no idea where it’s stored on my computer. One option is to click File→Save to see this information in the Save As dialog box, but a much easier solution is to right-click on the filename in the title bar of the program window. This will show a hierarchical display of folders. The top one nearest the file’s icon will be where the file is stored. The second one from the top will be where the parent of that folder is, and so on, going right back to the name of the hard disk, then the name of your computer, which should be the last in the list. 

Selecting any entry in the list will open that folder (or disk) in Finder for browsing.

See also Tip 56, ​Instantly Create Desktop Shortcuts to Files​.







	Tip 115
	Cut Rather Than Copy Files Using Keyboard Shortcuts




This is a subtle but useful tip. If you use keyboard shortcuts to copy and paste files from one place to another, you’ll know that it’s not possible to move files. Hitting Command+X—the keyboard shortcut for cut—simply doesn’t work, and the Cut option on the Edit menu when Finder is selected is grayed out.

You can in fact move a file using keyboard shortcuts but in a slightly obscure way. Hit Command+C to copy the file, but hit Command+Option+V when it comes to pasting it into a new folder, rather than Command+V. This will move the file from the old destination to the new one. 

If you like to use the Edit menu to move files around, hold down the Option key while accessing it (after first copying the file in the usual way) and you’ll see a Move Item Here option appear, which has exactly the same effect as using Command+Option+V. 







	Tip 116
	Avoid the Wait for Spring-Loaded Folders




If you drag and hover a file over the icon for a folder for long enough (in both Finder windows and on the desktop), a new Finder window will pop out, wherein you can see the contents and deposit the file. This feature is known as spring-loaded folders, and you can alter the delay before the new Finder window appears by changing the setting in Finder’s preferences (application menu→Preferences, and ensure the General pane is selected). 

However, if you’re in a rush, simply drag and hover the file as described, then hit Space to cause the new Finder window to spring out immediately.







	Tip 117
	Move the Cursor When Using Page Up/Page Down




Here’s an annoying “gotcha” that you might find catches you out when editing text.

If you’ve got a desktop Mac (or use a full-sized keyboard with your portable Mac), you might use the Page Up/Page Down keys to quickly navigate in documents. However, you might also be aware of an issue: although the text moves up and down, the cursor stays where it was last used. When you start typing, the document immediately scrolls back to its previous position. Grrr! 

Luckily, there’s a way around it. Hold Option while hitting the Page Up/Page Down keys. This will cause the text to scroll up or down a page and cause the cursor to jump to the middle of each page. You can then move it to where you’d like to start editing.

Incidentally, Mac notebook users (and those using Apple wireless keyboards) can hold down the Fn key while hitting the Up/Down cursor keys to emulate Page Up/Page Down. 







	Tip 118
	Jump to Locations Quickly in Open/Save Dialog Boxes




When saving new files, you are usually taken to the app’s default Save location or to the last location where you saved a file. If you want to save the file elsewhere, it can be cumbersome navigating there.

However, if you already have a Finder window open browsing where you want to save, just click and drag the proxy icon on top of the Save As dialog box. The proxy icon is the little icon in the title bar of the Finder window, to the left of the name of the folder you’re currently browsing. You’ll need to click and hold for a second before it detaches and you can drag it away. 

You’ll instantly be switched to that location. If you instead drop the icon in the filename field, you’ll see a Go To dialog box asking you to confirm you want to switch directories. Just click the Go button. 

This trick works in File Open dialog boxes, too.







	Tip 119
	Regain Control of a Crashed Mac




Very occasionally an application might crash so badly that it appears to lock up your Mac. You might see the “beachball of death,” that spinning color wheel that indicates your Mac is too busy to respond to you. 

Forcing a Quit

If the app has crashed, right-clicking its Dock icon will probably show a Force Quit menu entry. Click this to force the app to quit. If there’s no Force Quit entry, hold down Option and it will appear. 

You can also hold down Option+Command and tap Esc to bring up the Force Quit dialog box. From there you can select the app and click the Force Quit button.

Using a Keyboard Shortcut

The following might work if the app simply won’t quit, but beware that it terminates the app without offering the chance to save data: click the Dock icon for the app, then hold down Shift+Option+Command+Esc for three seconds. You’ll know instantly whether it’s worked because the app will vanish. 

Forcibly Rebooting the Computer

If that doesn’t work and the computer is simply unresponsive, the only solution might be to restart the computer. Holding down Control and Command and hitting the power button will forcibly shut down your computer, but be aware that you won’t get a chance to save files, although OS X will otherwise shut down correctly, avoiding the possibility of system files becoming corrupted. Press the power button once after shutdown to restart.

If that doesn’t work, hold down the power button for five seconds. This simply powers down the computer instantly, so, again, you won’t get a chance to save any open files. Because of the slight risk of system files getting damaged, this method should be considered a last resort if nothing else works.







	Tip 120
	Turn a Clipboard Image into a File




If you’ve copied an image from a web page or a document and want to turn it into a file, just open Preview (Finder→Applications→Preview) and then hit File→New from Clipboard. This will create a new file containing the image. Click File→Save to save the file in whatever format you want: select the format from the Format dropdown list in the Save As dialog box.







	Tip 121
	Leap Around the Desktop Using the Keyboard




Moving your hand to grab the mouse while you’re working can be a concentration killer. Luckily, it’s mostly possible to move around your Mac’s desktop using the keyboard. 

Activating the Main Menu

To activate the menu, hit Control+F2 (on portable Macs, or Macs with an aluminum keyboard, you’ll have to hit Fn+Control+F2). You can then navigate from menu to menu using the left/right cursor keys, and you can open a menu using the down cursor key. Hitting Return will select an option. 

Activating the Dock

Hitting Control+F3 (or Fn+Control+F3) will do the same for the Dock. Use the left/right cursor keys to move the selection highlight, Return to start or switch to an app, and hit the up cursor key to activate the application menu (the same one you see if you right-click the Dock icon).







	Tip 122
	Create Email Shortcuts




Here’s a nice trick for anybody who emails the same person frequently and would like to create a desktop shortcut that, when double-clicked, will instantly create a new message addressed to that individual.

The shortcut doesn’t have to live on the desktop. You could create a folder full of these email shortcuts and access them via Finder, or you could click and drag them to the top or the sidebar of a Finder window to create a one-click shortcut.

Creating a Shortcut Using Address Book

If you’re able to locate the address in the Address Book app (Finder→Applications→Address Book) or a web/text document, just highlight it and drag it to the desktop. This action will create a Mail To file. Unfortunately, it isn’t possible to drag addresses like this from the headers of emails within Mail, although you can click and drag any address mentioned within the body of the email, and this method will work. 

Creating a Shortcut using TextEdit

If you’re unable to locate the email address in Address Book or online, just start a blank document in TextEdit (Finder→Applications→TextEdit), type the address on a new line, then highlight it and drag it to the desktop. It should then work in the way described for other shortcut methods.







	Tip 123
	Check Your Mac’s Warranty




You can check the service and support coverage of your Mac easily on Apple’s website, as well as that for any other Apple hardware you own.

Using the Built-in Warranty Checker

To check warranty details for your Mac, click the Apple menu, then choose About This Mac. In the dialog that appears, click the More Info button, and in the program window that appears, click the Service button on the menu. Then click the Check My Service and Support Coverage Status link.

Checking Details for Other Apple Hardware

You can also check the warranty details of other Apple hardware like iPhones, iPads, and iPods. First you’ll need to find the serial number of the hardware; how this is done varies, but the following web page comprehensively explains the process: http://support.apple.com/kb/HT1349.

Then open a web browser and visit https://selfsolve.apple.com/GetWarranty.do. In the Hardware Serial Number text field, type in your serial number. Make sure the Country dropdown list displays your place of residence, and then click the Continue button. 

On the page that appears, click the See Your Service and Support Coverage link.







	Tip 124
	Lock the Screen for Security




You can set your Mac to show a blank screen or start the screen saver on demand. If you also set a password prompt to appear when the mouse is moved or a key pressed, you’re effectively making the computer impossible to use until you return. Additionally, nobody will be able to see your screen contents as they pass.

Enabling Password Protected Sleep

For screen locking to be effective, you’ll need to first activate password protection: open System Preferences (Apple menu→System Preferences) and click the Security & Privacy icon. Ensure the General tab is selected and then put a check alongside Require Password Immediately after Sleep or Screen Saver Begins.

Locking via a Keyboard Shortcut

To lock the screen quickly from the keyboard, hit Shift and Control together, and hit the Eject key (top right of the keyboard, or top right of the main keyboard area on aluminum keyboards). 

Locking via a Menu Icon

A little-known way to lock the screen is to use a feature of your Mac’s Keychain Access application, which ordinarily handles password and certificate security for your Mac. Start the application (Finder→Applications→Utilities→Keychain Access) and select Preferences from the application menu. After ensuring the General tab is selected, put a check next to Show Keychain Status in Menu Bar.

You’ll now see a padlock icon appear at the top right of the screen near the time display (you can now quit Keychain Access because we’re finished with it). Clicking the padlock will show a menu with a Lock Screen menu option. 

To remove the padlock icon at a later date, hold down Command and simply drag the icon onto the desktop. Upon releasing the mouse button, it will disappear.

Locking via Touching a Screen Corner

You can also set up your Mac so that pushing the mouse cursor into a particular corner of the screen either activates sleep mode, which will have the effect of locking the screen, or starts the screen saver. Start System Preferences (Apple menu→System Preferences), click the Mission Control button, and then click the Hot Corners button. Click the dropdown list next to whichever corner(s) you’d like to use and select either Put Display to Sleep or Start Screen Saver. Then click the OK button.


Mac for Linux/Unix Users


Mac OS X is a version of Unix and a POSIX-compliant operating system. The heart of Mac OS X, including the kernel, is called Darwin, which evolved from the Berkeley Software Distribution (BSD).

Within the Utilities folder in Applications, you’ll find a Terminal program that will provide a BASH command prompt, although various other shells are available, such as csh, ksh, zsh, and so on. Each can be called in the usual way by typing its name. Users can change their default shell by opening System Preferences, clicking Users & Groups, unlocking System Preferences, right-clicking their username in the list on the left, and then selecting Advanced Options. A choice can then be made from the Login Shell dropdown list. 

Many contemporary Linux/Unix open source technologies are included in a standard Mac OS X installation. For example, the Python, Ruby, and Perl programming languages are present, as is the Apache web server software. The X Window System required for the majority of Unix/Linux GUI applications is built into OS X and can be started in the standard way by issuing the startx command or by double-clicking its entry in the Utilities folder within the Applications view of Finder.

A standard Mac OS X desktop installation can be expanded into a fuller Unix implementation using MacPorts or Fink.[10] The chflags command can be used to reveal within Finder the usually hidden Unix filesystem hierarchy: open a Terminal window and type sudo chflags -h nohidden /*.) 



http://www.macports.org and http://www.finkproject.org, respectively.













	Tip 125
	Open a File You’re Working On in Another App




Let’s say you’re tweaking a photo in Preview and decide you need the full power of Adobe Photoshop. 

Look at Preview’s title bar. You’ll see the name of the file currently being worked upon. To the left of this will be a small icon representing the file. This is known as the proxy icon. Click and hold it for a few seconds, then drag and drop the icon to the Photoshop icon on your Dock or to the Photoshop icon in Applications. The most recent version of the file will open in Photoshop (to learn about versions, see ​Exploring OS X Lion: Auto Save and Versions​).

It’s a good idea to close Preview. Otherwise, attempting to save the file in Photoshop will show an error message saying the file is in use. 

Instead of dropping the proxy icon onto the Dock icon, you can tap Command+Tab to bring up the application switcher and drop the proxy icon on top of the program’s icon in the switcher display.

Note that with some older apps created before the release of OS X Lion (that is, mid-20), you’ll first need to save the file before dragging or it won’t work. 







	Tip 126
	Take Control of PDFs




Preview is the Mac’s highly capable image viewer, and it also displays PDFs. You’ll find it within the Applications list of Finder. But that’s just the start of its abilities when it comes to these document files.
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Figure 23. Merging one PDF with another





Annotating PDFs

Preview has reasonably sophisticated annotation facilities built in that you can use to add notes or markings to a PDF. Look under the Tools→Annotate menu. Once you’ve made a selection, click and drag anywhere on the page to add the annotation. 

You can add the annotations toolbar by clicking the pen icon on the standard toolbar. The annotations toolbar provides quicker access to annotations functions, as well as access to some that aren’t listed on the menu—see Tip 262, ​Add Your Signature to Docs Using Preview​.

Combining PDFs

To combine two or more PDFs, open the first of them in Preview and then ensure the thumbnails sidebar is visible (View→Thumbnails). Locate in Finder the second PDF you want to combine with the first, and drag it on top of the thumbnail sidebar of the first PDF in Preview’s sidebar. For an example, see Figure 23, ​Merging one PDF with another​. You can insert the new document anywhere within the page order of the original file—the existing pages will slide out of the way to make a gap for you to drop in the new file. 

Once the two documents are merged, you can reorder any of the pages—old or new—by clicking and dragging them in the sidebar. If you have a multitouch trackpad, pages can be rotated using the standard picture rotate gesture—be sure to first place the mouse cursor over the body of the page in question, or over the thumbnail for the page.

Note that you can keep adding more PDFs by dragging and dropping them onto the thumbnail preview drawer—you aren’t limited to merging two files.

When done, click File→Export and give the merged document a new name. Beware that simply saving the file will overwrite the original PDF you selected for merging!

Adding Images to PDFs

You can also add images to a document; again just drag and drop them onto the thumbnail preview drawer (View→Thumbnails) in the same way as described above. Each image is given a new page. It’s not possible to insert images onto an existing page using Preview, although the signatures feature can be unofficially utilized to insert hand-drawn sketches—see Tip 202, ​Add Hand-Drawn Sketches to PDFs​.  

To learn how to create a new PDF from images, see Tip 219, ​Convert a Series of Images into a PDF​.

Password Protecting a PDF

You can encrypt a PDF file so that a password is required to open it. To do so, open the PDF in Preview, then click File→Export. In the Format dropdown list of the dialog box that appears, make sure PDF is selected. Then put a check in the Encrypt box and type a password beneath this (type it again in the Verify field to confirm). 

Note that the protection is primitive compared to what you might be used to with programs like Adobe Acrobat[11]—there’s no way to protect PDFs so that copying text or images is prohibited, for example. The password protection merely protects the document from being opened. Once opened, the user is free to do whatever he or she likes in the file, including saving out an unencrypted copy. 







	Tip 127
	Edit Movies Within QuickTime Player




QuickTime Player is the Mac’s built-in movie player—you can find it on the Applications menu within Finder. 
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Figure 24. Trimming a movie file





Trimming Movies

QuickTime Player is actually a  trimmed down version of the (not free) QuickTime Pro, but it’s pretty powerful in its own right. For example, you can edit movies within QuickTime Player, at least in a primitive way, as follows:


	
Open the movie in QuickTime Player and click Edit→Trim. The timeline will now change to a frame display of the movie, surrounded by a yellow boundary box—see Figure 24, ​Trimming a movie file​.



	
Click and drag the boundary box on the left and right sides to cut out any material at the beginning and end you wish to lose (unfortunately, it’s not possible to cut sections out of the middle of the file—for that you’ll need a more sophisticated editor like iMovie,[12] although movie clips can be merged together—see the following section).



	
If you want to view the audio track of the file, click View→Show Audio Track. This switches the frame display to one showing the audio waveform, so you can edit perhaps based on quiet or loud episodes.



	
Once you’re done, click the Trim button.





Merging Two or More Movies

You can combine two or more movies into one file. To do so, open the first of the movies in QuickTime Player, then locate the next in Finder and drag and drop it onto the QuickTime Player window. It will appear in the timeline view at the bottom as a separate clip, and you can drag and drop it to the beginning or end of the existing movie file. You can add more clips in the same way and reposition them by clicking and dragging. When you’ve finished, click the Done button, then close the file to bring up a Save dialog box.

Saving an Edited Movie

When you’ve finished trimming or merging movie files, click File→Close. This will bring up a prompt asking if you want to save the file. Unfortunately it’s not usually possible to simply save the file in its original format. Instead it must be exported in an Apple-compatible format. The safest bet is to select the 720p option from the Format dropdown list in the dialog box, unless you know the movie has a smaller frame size. The 720p option will retain the existing resolution of the movie provided the frame size isn’t larger than 1280 × 720, although it will downsample a 1080p movie (to edit a 1080p movie, you’ll need a higher-end solution such as iMovie, as mentioned earlier).







	Tip 128
	Eject a Stuck CD/DVD Disc




Most Macs don’t have a physical Eject button for the DVD drive. Instead, users must hit the Eject button on the keyboard, usually located in the top right.

For various reasons, Macs sometimes forget they have a disc in the drive, in which case the Eject button won’t work. One solution is to reboot the Mac and, before the Apple logo appears or the chime sounds, press and hold the mouse or trackpad button. Within seconds the disc will be spewed out, and you can release the mouse button. Booting will then continue normally. 

You can also try to force an ejection when OS X is running, using the Eject menu item—see Tip 93, ​Add an Eject Button​.







	Tip 129
	Get Troublesome Second Displays to Work




Your Mac can automatically detect and configure any displays you attach to it. However, sometimes you might find that your Mac doesn’t register the second display. The symptom will be that the newly attached screen remains blank. 

To force the Mac to detect any attached screens, open System Preferences (Apple menu→System Preferences) and click the Displays icon. Then click the Detect Displays button at the bottom right.

If this doesn’t work, try resetting your Mac’s hardware settings—see Tip 81, ​Reset Your Mac’s Hardware Settings​.







	Tip 130
	Cue Through Movies Using a Trackpad




Does your Mac have a multitouch trackpad? Want to cue backward or forward in movies? Just “scroll” left or right with the cursor placed over the movie window to cue back and forth (that is, bunch two fingers together and slide them left or right on the trackpad). You’ll see an icon appear at the top left showing the playback speed. To return to normal playback speed, just lift your fingers from the trackpad.







	Tip 131
	Take a Picture of the Screen




 Your Mac has a powerful screen-grabbing facility built in, with a variety of ways of accessing it.

Using Keystrokes

The simplest way to take a shot of the screen is to tap Shift+Command+3. This will output an image to the desktop, although beware if you’re playing a DVD movie—the DVD movie window will be blank because movies are copyrighted. 

If you want to grab a specific area of the screen, hit Shift+Command+4 instead. The cursor will change to a crosshair, and you can click and drag to define an area that will be turned into a screenshot and output to the desktop. Hold Space while dragging, without releasing the mouse button, and you can reposition the screenshot frame. Hit Esc to cancel. 

To capture one program window in particular, tap the spacebar once after this series of keystrokes, as in  Shift+Command+4, then tap Space. Then click the window you want to capture. It doesn’t matter if it’s behind another window—it’ll still be captured in its unobscured entirety.

See also Tip 23, ​Screengrab to the Clipboard Rather Than to a File​, and Tip 65, ​Control Hidden Screenshot Settings​.

Using the Grab App

If key combinations are a little confusing, you can use the Mac’s Grab utility, which is found in the Utilities folder of Applications within Finder. Once the program starts, select the entry you want from the Capture menu. Grab also gives you the opportunity to take a screen grab only after ten seconds have passed—just select the Timed Screen option on the Capture menu. 

Additionally, if you click the program menu and then Preferences, you can select to include various cursor images within the screenshot (usually cursor images are hidden). Just select a cursor type you’re interested in, close the preferences dialog box, then capture a screen using one of the menu options as described previously. During the capture process the cursor will change to the one you selected. 

Grab can only capture images in the TIFF format. 

Using Preview

The Mac’s general purpose image viewer, Preview, also has screen capture abilities built in. The advantage of using Preview is that you can crop, edit, or annotate the image once captured. You can also save out images in a variety of image formats. 

Just start Preview (Finder→Applications→Preview), then click File→Take Screen Shot and choose from the options. The captured image will appear within Preview as if it’s an image file you’ve just double-clicked. You can annotate it by clicking Tools→Annotate. To save it, click File→Save. Select the image format you want to use from the Format dropdown list in the dialog box that appears.  







	Tip 132
	Permanently Ignore a Software Update




In my experience there’s a new update for my Mac every few months or so. Often this is an iTunes update, and on one of my computers, I simply never use this software. Therefore, wasting time downloading an update is pointless. 

To avoid being nagged about the update, I simply select it in the list of software updates and hit Delete. This will remove it from the list. 

Should you change your mind at some point, simply click the application menu and select Reset Ignored Updates.

Note that you should never hide security or major operating system updates. These should always been installed, no matter how long it takes. To learn how to capture update files for manual installation on more than one computer, which can save time if you have more than one Mac, see Tip 166, ​Download and Keep Software Updates​.







	Tip 133
	Generate a Font Sample Document




If you’ve got a lot of fonts installed on the system, you may find it helpful to create a sample document displaying them all. Lots of professional designers rely on binders full of such printed examples. 

A series of AppleScripts will do the job. Start by opening the Font Book application, which is the Mac font manager (Finder→Applications→Font Book). Highlight any or all the fonts you want to include in the sample document. Then open Finder, hit Shift+Command+G, and type /Library/Scripts/Font Book. Then double-click Create Font Sample.scpt. This will open the script in AppleScript Editor, but don’t worry; all you need do is click the green Run button on the program’s toolbar. This will open a TextEdit document, and, slowly but surely, it will be filled with samples of each font you selected. Once it’s finished, quit AppleScript Editor and then save and/or print the new TextEdit document as required.







	Tip 134
	Instantly View a Command’s Man Page




To view the man page for any command at the prompt, right-click it and select Open Man Page on the menu that appears.







	Tip 135
	Autocomplete Words




Ever had one of those days where you can’t quite spell? Well, all you need do is start typing the first few letters of the word and then hit Esc. A pop-out menu will appear showing lots of suggestions—see Figure 25, ​Using OS X’s word autocomplete feature​. Then use the cursor keys to select the correct word and hit Return to insert it. Hit Esc again to close the list if you don’t want to choose one of the options.

This tip works in most built-in OS X apps, such as TextEdit or Safari, but not in Microsoft Office. 

Note that in some applications where Esc is already assigned to a function, such as in the search field of Safari, you’ll need to hit either F5 (Fn+F5 on MacBooks and those with aluminum keyboards) or Option+Esc to make the word list appear.
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Figure 25. Using OS X’s word autocomplete feature











	Tip 136
	Make the Dock Display Only Running Programs




The Dock is designed as a launcher for programs, but it can also be switched to a different mode that shows only the programs that are currently running. This can massively simplify the Mac experience for those who struggle with computing concepts. 

Switching to Simple Mode

To switch the Dock to simple mode, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following line:



	 
	
​defaults write com.apple.dock static-only -bool TRUE;killall Dock​





The changes will take effect immediately. Note that the Finder will always be on display in the Dock. Finder is always running in the background, and ordinarily it is impossible to quit it. 

Creating Desktop Program Launchers

Once this is set up, you’ll need to find a different way of launching programs, of course, unless you want to open Finder and view your Applications list each time. One way of doing this is to create desktop aliases for your favorite programs, which is commonly how Windows users work—just click and drag any icon from the Applications list to the desktop and, before releasing the mouse button, hold down Option+Command.

You can also add application shortcuts to Finder—see Tip 74, ​Make Finder Your Productivity Hub​.

Reverting to the Default Dock

To switch back to the standard Dock, open a Terminal window and type the following line:



	 
	
​defaults delete com.apple.dock static-only;killall Dock​





You should find that your Mac hasn’t forgotten what icons were in the Dock previously.







	Tip 137
	Add a Recent Items Stack to the Dock




Macs remember what applications and documents were recently open (click the Apple menu, then Recent Items). You can also add these lists to the Dock as a stack alongside the other stacks on the right of the Dock near the Trash. This allows ultra-quick access.

Setting Up

To do so, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following single line, being sure to type it exactly as written:  



	 
	
​defaults write com.apple.dock persistent-others -array-add '{ "tile-data" =​




	 
	
​        { "list-type" = 1; }; "tile-type" = "recents-tile";}';killall Dock​





The new stack will appear next to the Trash. By default it shows recently accessed applications, but you can switch to recent documents or servers by right-clicking and selecting from the list.

Adding More Stacks and Tweaking

If you’d like a separate stack for each—one for recent applications, one for recent documents, and one for recent servers, for example—just repeat the command above two more times and set the choice of what’s displayed by right-clicking and selecting from the menu.

To increase/decrease the number of items shown in the recent item stack(s), change the settings under Number of Recent Items in the General component of System Preferences (Apple menu→System Preferences). 

Removing the New Stacks

To remove any of the new stacks, just click and drag them away from the Dock, and they’ll disappear in a puff of smoke.







	Tip 138
	Personalize the Highlight Color for Mission Control 




This is a hard hack that alters system files and therefore affects all users of the system. If the instructions are followed correctly there should be no problems, but you should perform a Time Machine backup before commencing.

By default your Mac adds a blue border around any window preview you mouse over in Mission Control mode. Changing the color to something brighter, such as yellow, can make for an easier-to-spot effect, which can be especially useful if the screen brightness is set low. To switch the Mission Control highlight color, follow these instructions:


	
Open Finder, hit Shift+Command+G and type the following before hitting the Go button: /System/Library/CoreServices.



	
Scroll down and you’ll see an application called Dock. Right-click it and select Show Package Contents. This will open a new Finder window showing the files within the Dock application. 



	
In the new Finder window, open the Contents folder and then the Resources folder. Look for two files: expose-window-selection-small.png and expose-window-selection-big.png. Click and drag the two files to a safe location, such as your Documents folder, to create copies. These will serve as backups of the original files that you can restore, should you want to.



	
Back in the Finder window showing the contents of the Dock package, drag the two files to the desktop. Then open them in the image editor of your choice. If you haven’t got a suitable image editor, the following steps explain how to edit the images in Preview. Read through them even if you’re not using Preview to recolor the images.



	
Double-click the expose-window-selection-big.png file, which will open it in Preview. In the Preview program window, click Tools→Adjust Color. In the window that appears, click and drag the Exposure, Contrast, Saturation, Temperature, Tint, and Sepia sliders until you achieve a color you’re happy with. There’s not an exact science to this—just experiment to see what you can achieve. Don’t drag any of the other sliders! 



	
When making a change, you might see a warning that the file needs to be unlocked. This is fine, so click the Unlock button when prompted. When you’ve finished your edits, click File→Save a Version to save the file. Don’t alter the filename or the type of file. 



	
Repeat the steps above with the expose-window-selection-small.png file, altering its color to suit your tastes before saving it. Open the other file to match the colors if that helps.



	
Once you’ve finished editing the images, find the files you edited on the desktop, and click and drag them onto the Finder window showing the contents of the Dock program. You’ll initially be told via a dialog box that the items can’t be moved, but clicking the Authenticate button will override this. However, you’ll need to enter your password when prompted. You’ll also be told that you’re going to overwrite the existing files, but this is fine, so click the Replace button. 



	
Log out and back in again for the changes to take effect.





To restore things to the way they were (that is, to go back to the original blue highlights in Mission Control), repeat the instructions in steps 1--3 to browse the contents of the Resources folder within the Dock application package, and drag and drop the backups of the original files you created in Step 3 to the Finder window showing the contents of the Dock application. Again, you’ll need to authenticate by entering your password. Log out and back in again for the changes to take effect.  







	Tip 139
	Get Quick Access to System Preferences Tools




Here’s a way to get quick access to system configuration tools.

Right-Clicking the Dock Icon

If you keep System Preferences in the Dock, simply right-click it and select the preference you want from the list that appears. This will start System Preferences with that particular option open. 

If the System Preferences window is open, you can also click and hold the Show All button to see this list and select an entry from it. 

Using Spotlight

If you can remember the name of the various System Preference panes (Desktop & Screen Saver, Energy Saver, Network etc.), then you can access them ultra-quickly using Spotlight. Just hit Command+Space to open Spotlight’s text field, then type the name of what you want. Before you’ve finished typing you should see it appear near the top of the list of results, if not at the top. Simply select it to start System Preferences with that particular pane viewable.

Using Hotkeys

If your Mac’s keyboard has hotkeys at the top for changing the volume or brightness or for activating Mission Control, you can quickly access the associated pane of System Preferences by holding Option before hitting the shortcut key.

For example, holding down Option and hitting the volume increase button will open the Sound pane of System Preferences. Holding down Option and hitting the Mission Control hotkey will open the Mission Control pane of System Preferences. Hitting Option and the keyboard brightness hotkeys opens the Keyboard pane of System Preferences.

Adding Specific System Preferences Icons to the Dock

If you find yourself using a particular System Preference option a lot, you can add it to the side of the Dock that contains the Trash; you’re not allowed to add them to the other side of the Dock, where app icons live.

To do this, open Finder, hit Shift+Command+G, and type /System/Library/PreferencePanes. Then click Go. In the file listing that appears, click and drag the prefPane file you’re interested in straight to the right side of the Dock.

Clicking it within the Dock will now activate System Preferences, which will then jump straight to that pane when it starts. 

To remove the Dock icon, just click and drag it off the Dock, where it will vanish.







	Tip 140
	Turn Off the Desktop




If you’re using your Mac to give a presentation, you might not want everybody to see your messy desktop! If so, you can run a quick command that will hide your desktop icons.

Hiding the Desktop

To temporarily turn off the desktop, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following line:



	 
	
​defaults write com.apple.finder CreateDesktop -bool FALSE;killall Finder​





Note that this will mean you can no longer right-click on the desktop or drag files there. The files there will still be accessible by using Finder to browse to your Desktop folder.

To restore things back to normal after your presentation, again open a Terminal window, but this time type the following:



	 
	
​defaults delete com.apple.finder CreateDesktop;killall Finder​





Hey, presto! Everything should be back to normal. If not, log out and back in again.

Creating a Desktop Hiding App

With the use of a quick AppleScript, this Terminal command can even be turned into an standalone application that you can run before each presentation, saving the hassle of the command line.

Open AppleScript editor (Finder→Applications→Utilities→AppleScript Editor), and type (or cut and paste if you’re reading the eBook version of this book, being careful to remove the line breaks) the following code:



	 
	
​display dialog "Desktop icons visible or hidden?" buttons {"Visible",​




	 
	
​        "Hidden"} with icon 2 with title "Switch to presentation mode"​




	 
	
​        default button 1​




	 
	
​set switch to button returned of result​




	 
	
​if switch is "Hidden" then​




	 
	
​tell application "Terminal"​




	 
	
​do shell script "defaults write com.apple.finder CreateDesktop -bool FALSE;​




	 
	
​        killall Finder"​




	 
	
​end tell​




	 
	
​else​




	 
	
​tell application "Terminal"​




	 
	
​do shell script "defaults delete com.apple.finder CreateDesktop;killall​




	 
	
​        Finder"​




	 
	
​end tell​




	 
	
​end if​





Click the Run button on the toolbar to test your script. You should see a dialog box appear with two buttons: Visible and Hidden. To make sure the app works OK, click Hidden to hide the icons, then run the app again and click Visible to reveal them again.

To save the AppleScript as an application, click File→Save As. Type a filename and, in the File Format dropdown list, select Application. Save the file, althoughnot on your desktop—when the icons get hidden, you won’t be able to access it again to unhide them unless you use Finder.







	Tip 141
	Fix Broken Passwords




You Mac will offer to remember login details for applications and websites (see Tip 83, ​See Forgotten Passwords ​). However, you might find that passwords no longer automatically appear when you’re logging into websites or that the passwords somehow become corrupted so they’re no longer accepted. Here’s how to try to fix that.

Repairing the Keychain

Start the Keychain Access utility (Finder→Applications→Utilities→Keychain Access) and click Keychain First Aid on the application menu.

In the dialog box that appears, select the Verify radio button, enter your login password in the relevant field, and click Start. The scan should take a few seconds to complete. If it reports an error, click the Repair radio button and again click Start. Once complete, close the Keychain Access program, log out and then back in again, and visit the errant websites to see if the issue has been fixed.

Deleting the Entry

If the problem persists, try once again to open Keychain Access, and this time delete the entry for the website or application from the list within the Keychain Access program. These will be listed to the right of the program window, although you can type the app or website name in the search field at the top right of the window.

Deleting the entry will then prompt you to enter the details anew next time you access the website or application, where they’ll also be recorded fresh for future reference.







	Tip 142
	Minimize Windows to Dock Icons




In the old days of OS X, minimized programs shrank into their Dock icon. In more recent versions of OS X, minimized programs shrink to icons on the right of the Dock near the Trash.

This change can cause the Dock to expand significantly and become a little unmanageable. To return to the older way of working, open System Preferences (Apple menu→System Preferences) and click the Dock icon. Then put a check next to Minimize Windows into Application Icon. The changes take effect instantly.

To return to the default OS X Lion minimizing method, should you want to, just repeat the steps and remove the check from the box.







	Tip 143
	Temporarily Switch On (or Off) Dock Magnification




If you have Dock magnification switched on (that is, the Dock icons expand when your mouse passes over them), holding down Shift+Control will cause them to remain small. On the other hand, if you don’t have Dock magnification turned on, the same key combination will cause them to be magnified! This can be useful for impressing passersby with your Mac’s cool visual effects if you’re otherwise not a fan of Dock magnification.







	Tip 144
	Remove System Preferences Icons




Here’s how to tidy up and trim the list of options within System Preferences.

Removing Third-Party Icons

Some applications like to add their own icons to the bottom of the System Preferences window under the Other heading. 

The trouble is that the same programs leave behind these icons when they’re uninstalled. To manually remove any icon, right-click it and select Remove Preference Pane.

Note that if the app is still installed, simply removing the icon probably won’t uninstall the rest of the app. To do that you’ll need to click and drag the program’s icon from within Applications to the Trash. If the program doesn’t add an entry to the Applications list within Finder, you’ll need to consult the website of the software developer to learn how to manually remove the program.

Pruning Standard System Icons from the List

To remove any of the standard system icons from System Preferences, click and hold the Show All button (top left of the program window) until the list of apps appears, then—keeping your finger on the mouse button—scroll to the bottom and select Customize. Then remove the checks next to any icons you want to remove (see Figure 26, ​Removing built-in System Preferences icons​). Click the Done button at the top left when you’ve finished. 

Note that although the icon might have been removed, you can still access the function by clicking and holding the Show All button and selecting the entry in the list.

To restore icons, repeat the above and add a check next to the icon(s) you removed.
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Figure 26. Removing built-in System Preferences icons











	Tip 145
	Speed Up PDF files




Sometimes you might find that someone sends you a PDF that is very slow when you view it in Preview—scrolling takes a long time, for example, and pages draw slowly too. It’s not always clear why this happens, but it might have to do with the number of layers in the document.

A quick and easy solution is to use Preview to save a copy of the file (File→Export, then assign a different file name). Open the copy, and you should find it’s now much quicker to browse.







	Tip 146
	Insert a Picture into a Doc via an Image Editor




If you’re editing an image for use in a document, here’s how to save a few seconds. Open the word processor or layout program in which you want to insert the image, and load the relevant document file. Back in the image editor, save the file if you haven’t already, then look at program’s title bar. You’ll see the name of the file currently being worked on. To the left of this will be a small icon representing the file. This is known as the proxy icon. Click and hold it for a few seconds without moving the mouse, and then drag the icon on top of the word processor or layout program’s window. The image will be inserted instantly.







	Tip 147
	Take Control of File Compression




Macs can read and write zip compressed archives, the most popular type of compressed file format used under Windows. As you’d expect, everything is automated, but here are some tricks you can employ.

Unpacking and Creating Archives

To unpack an archive, simply double-click it. The contents will automatically be extracted to the same folder as the archive file. To create an archive, right-click a file or folder and select the Compress option.

Setting Archive Preferences

You can change the location where all zip files are extracted to and also make your Mac delete the original zip files after extraction by setting the preferences of the program called Archive Utility, which your Mac uses in the background to perform zipping actions. You’ll find it in /System/Library/CoreServices: open a Finder window, press Shift+Command+G, and type the path before hitting Go. Double-click the program, although note that it doesn’t have a program window. Instead, on its application menu, click the Preferences entry. Then make your choices from the dropdown menus of the dialog box that appears. 

You can also choose what happens when creating an archive (that is, when you right-click a file or folder and select the Compress option)—just make your selection from the Save Archive, Use Archive Format, and After Archiving dropdown menus. Close the application when you’ve finished with it. 

Adding a System Preference Option for Compressed Files

If you’d like these options at hand so they can be changed easily, right-click the Archive Utility icon in /System/Library/CoreServices, as mentioned previously, and select Show Package Contents. Then navigate to Contents/Resources/ and double-click the Archives.prefPane file. Then click the Install button. This will permanently add an option to set the file archive preferences to System Preferences.

Extracting to Destinations You Choose

You can add an entry to the right-click menu that will cause the unzipped output to be placed on the desktop, regardless of preference changes you made earlier. Another entry you can add will cause a file browsing window to appear, prompting for a destination where you’d like to unarchive the files.  

To make either a reality, open System Preferences (Apple menu→System Preferences) and then click the Keyboard icon. Click the Keyboard Shortcuts tab, select Services in the list on the left, and scroll to the very bottom of the list on the right, where you’ll find two options that read Unarchive to Desktop and Unarchive To. Put checks in the boxes alongside both. 

The change will take effect immediately. Whenever you right-click an archive file, no matter where it is, clicking the Unarchive to Desktop option will unzip the contents to your desktop. Clicking Unarchive To will open a file browsing dialog box, in which you can select a destination. 

To remove the menu options at a later date, repeat the steps above and simply uncheck the entries in the list within System Preferences.







	Tip 148
	Get Better Control When Taking Pictures




Here’s a few quick tips to better control Photo Booth, the Mac application that uses the iSight or FaceTime HD camera to take pictures of users.

Stopping the Flash

When using Photo Booth, the Mac’s screen flashes white to illuminate the subject an instant before the picture is taken.

Sometimes, however, you might simply want to make use of ambient light. To avoid the firing the flash, just hold down Shift when clicking the camera button. There’s no need to keep holding it down while the photo is taken.

Turning Off the Countdown

To avoid a countdown before the photo is taken (that is, to take a snapshot as soon as you click), hold down Option before clicking the snapshot button. You can combine this with Shift to prevent the flash from firing.







	Tip 149
	Select Text like a Pro




In some built-in Mac apps like TextEdit, as well as in Microsoft Office and Mozilla Firefox, it’s possible to select text in a variety of useful ways above and beyond simply clicking and dragging.

Selecting Noncontiguous Regions

Holding down Command while clicking and dragging lets you select disparate sections of text. You could highlight one sentence at the beginning of a paragraph, for example, and while holding down Command, select another sentence at the end of a paragraph. Hitting Command+C will copy both to the clipboard. If you hit Command+V to paste, the two sentence components will be pasted on two separate lines. 

Selecting Square or Rectangular Blocks of Text

Holding down Option will let you select rectangular blocks of text within a paragraph. This is hard to describe, so give it a try by holding down Option and clicking and dragging within a paragraph of text (hold Option+Command in Microsoft Word). Again, hitting Command+C will copy it and Command+V will paste it. It’s hard to imagine how this would ever be useful, but you might find a use for it! 

Selecting Without Dragging

By clicking at the beginning of the region you want to select, then holding Shift and clicking at the end of the region, you’ll select everything in between.

If you’ve already made a text selection, you can hold down Shift and click on either side of it to add text to the selection. Clicking within the selection while holding down Shift will let you subtract letters and words from the selection. 


Exploring OS X Lion: Auto Save and Versions


Since the computer was invented, users have been familiar with saving files. OS X Lion makes a brave step away from this strict requirement. In apps that are compatible with the new Auto Save and Versioning features, files are automatically recorded to disk as soon as you start editing—even if you haven’t chosen to save them or given them a name. Create a file in TextEdit, for example, and you can quit the app right away. When you next open TextEdit, the unsaved file will be there waiting for you. 

In those same apps (that is, they were either designed or specifically updated for Lion’s new features), OS X also periodically saves versions of files so you can step back in the file’s history to restore an older rendition. Every time you close a file a new version is recorded, and a new version is also recorded after every hour that passes while the document is open. You can also hit Command+S to save a version whenever you want, such as before making a big edit, although this will also update the saved file in the standard way.

To restore a previous version, just click File→Revert to Saved on the menu. This will open a timeline view of the document rather like that offered by the Time Machine backup function, but, crucially, Versions can work independently of Time Machine. In fact, there’s no requirement for Time Machine to be set up.

Even if you restore to an older version of the file, the version of the file you’re abandoning will also be added to the version list, making it essentially impossible to lose any data.











	Tip 150
	Search Better in TextEdit




If you search for a word or phrase in TextEdit, you’ll see that the document view is dimmed and any instances of the search term are picked out in stark white. Additionally, you can click the left and right arrow buttons in the Find toolbar to move a yellow “blob” highlight through the document that shows instances of the search term.

The problem is that the yellow “blob” expands beyond the boundaries of the word or phrase and covers letters to the left and right, which can make it difficult to see whether this particular instance of the found search term is the one you’re looking for.

The solution is to click anywhere within the document. This will deactivate the screen dimming. The search toolbar won’t disappear, and if you keep using the left and right arrows to find the search term, the yellow blob will contract to a simple yellow highlighting of the word or phrase within a second or two of finding it. It’s a subtle but useful difference.







	Tip 151
	Quick Look Attachments and Websites in Mail




Like most elements of OS X Lion, Mail integrates Quick Look. You can use it to preview attachments in emails or to preview websites that are linked to within emails. Simply right-click any attachment and select Quick Look Attachment or Quick Look URL from the menu that appears.

Another method of Quick Looking email attachments is to click and hold the attachment’s icon before hitting Space. Then release the mouse button.

With web links you can also hover the mouse cursor over the link until a small down arrow appears. Clicking this will open a Quick Look window that shows the website. Right-clicking and selecting Quick Look URL also works. Note that this method also works for links sent to you via iChat.







	Tip 152
	Turn Finder Shortcuts into Dock Stacks




Almost everything that appears under the Favorites and Devices heading in the sidepane of Finder can be turned into a Dock stack for quick access. Simply drag and drop its icon from the Finder window to the stacks area of the Dock (that is, the side containing the Trash). You can drag and drop Applications, the desktop, pictures, and so on, including removable storage devices such as USB memory sticks. Turning Applications into a stack offers a quick way to start apps akin to Launchpad—see Figure 27, ​Turning the Applications list into a stack​.

There are two items that can’t be converted into a stack: AirDrop and All My Files. The latter can be added to the Dock, but clicking it simply opens a Finder window with All My Files selected.  

Note that in the case of removable storage devices added as a stack, when the device isn’t attached to the computer, the Dock icon will turn into a question mark on top of a hard disk. This is only temporary, and the stack will function correctly once the memory stick is reattached.



	
[image: images/applicationsstack.png]




	


Figure 27. Turning the Applications list into a stack











	Tip 153
	Use the Numeric Keypad for Hotkey Shortcuts




If you never use the numeric keypad of your full-sized keyboard for its proper purpose (that is, quickly typing numbers), you can turn it into a range of hotkeys that activate various OS X functions.

This is possible because OS X sees the numeric keypad as a separate range of keys. As far as it is concerned, hitting 3 on the numeric keypad is not the same as hitting 3 on the main keyboard. The same is true for the other numbers and also for the symbols on the numeric keypad.

Creating a Hotkey Shortcut

You can define new keyboard shortcuts and redefine existing ones by starting System Preferences (Apple menu→System Preferences), selecting the Keyboard icon, then ensuring the Keyboard Shortcuts tab is selected. 

Just select an entry in the list on the right, and then double-click the right-hand side of the entry. Then press the keyboard shortcut or combination you’d like to use. Switch between categories using the list on the left. 

To use one of the numeric keypad keys as a hotkey, double-click the entry for the function you want to define or redefine, as mentioned above, and press the numeric keypad key. For example, because my keyboard lacks a hotkey to make Launchpad appear, I selected the Launchpad & Dock entry on the left, then I double-clicked the Show Launchpad entry in the list within System Preferences and hit the 0 (zero) key on the numeric keypad.

Removing Shortcuts

As strange as it might seem, there’s no way to remove individual keyboard shortcut combinations once you’ve created them. All you can do is restore the default keyboard shortcuts for all entries within that particular keyboard shortcut listing. For example, to remove the shortcut I created above—Show Launchpad—I would again select its entry under the Keyboard Shortcuts tab within System Preferences and click the Restore Defaults button. Unfortunately, this restores the default keyboard combinations for all other entries in the Launchpad & Dock list, but there’s no way to avoid this. This is one area of OS X where there are strictly limited options, although a semiofficial add-on is available for download from one of the Mac OS X developers employed by Apple. Services Manager allows full control over the right-click menus and keyboard shortcuts. For more information, visit http://macosxautomation.com/services/servicesmanager.







	Tip 154
	Clean Caches for Smooth Running




To speed things up, most OS X applications and system tools cache data on the hard disk that they access frequently. While this works fine most of the time, sometimes the caches can become corrupted and this can slow down either the application or the entire system. Therefore if you run into a mysterious problem of an app working slowly or perhaps not working at all, deleting the caches might be worth trying. Don’t worry—the caches will be recreated as soon as the app next opens.

Clearing Local Caches

Start by quitting any apps that are open. Then open a Finder window, hit Shift+Command+G, and type the following: ~/Library/Caches. Then drag all the files and folders you see to the Trash. Enter your login password when prompted. Reboot for the changes to take effect.

Note that the first time you reboot the system might seem slower. This is because the caches are being rebuilt.

Clearing Application Caches

As above, ensure all applications are closed, then open a Finder window. Hit Shift+Command+G and type the following: /Library/Caches. Then drag all the folders and files you see in the Finder window to the Trash, and reboot the computer.







	Tip 155
	Change the Login Screen Wallpaper




This tip is similar to Tip 105, ​Replace Dashboard and Mission Control Wallpapers​. The aim is to change the wallpaper that lies behind the standard login screen (not the background you see if you have FileVault enabled, which cannot be altered). As such, this tweak is not for the fainthearted because it involves editing system files and will therefore affect all users of the system.
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Figure 28. Changing the login screen background





Personalizing the Wallpaper

The file we need to replace is called NSTexturedFullScreenBackgroundColor.png and is located at /System/Library/Frameworks/AppKit.framework/Versions/C/Resources/. As with the Mission Control and Dashboard wallpapers, the login screen wallpaper is actually a pattern that’s repeated from left to right, top to bottom. You can replace it with a similar pattern of the same size (256 x 256 pixels) or use a full-size image the exact same resolution as your monitor. 

Note that because the white text and graphics of the login screen are overlaid on the wallpaper, darker wallpapers tend to work better than light ones.

Here’s how to replace the login screen wallpaper:


	
Open the image you’d like to use for the wallpaper in Preview and convert it to PNG format by clicking File→Export. In the dialog box that appears, select PNG from the Format dropdown list and change the filename so it reads NSTexturedFullScreenBackgroundColor.png.



	
Back up the original wallpaper image by opening a Finder window, hitting Shift+Command+G and typing /System/Library/Frameworks/AppKit.framework/Versions/C/Resources/. Then copy the NSTexturedFullScreenBackgroundColor.png file to a safe backup location.



	
Then click and drag your new image onto the Finder window so it overwrites the original. You’ll be asked to authenticate, so click the button in the dialog box that appears and type your login password when prompted. Choose to replace the original file when prompted.  





That’s all that’s required, but you’ll have to reboot your computer for the change to take effect. For an example from my computer, see Figure 28, ​Changing the login screen background​.

If you find the wallpaper pattern shrunk and repeated across the login screen rather than filling it, try using an image editor to create a new image of the same resolution as your screen (that is, 1280 x 800, for example), and then open your wallpaper image before copying and pasting it into the new image. Then save out the new image to the location mentioned earlier using the filename that’s mentioned.

Restoring the Default Wallpaper

To revert to the default login wallpaper, repeat the steps above to browse /System/Library/Frameworks/AppKit.framework/Versions/C/Resources/ and drop your backup back in place.







	Tip 156
	Reveal the Desktop via a Hotkey




Although it’s a very useful feature, the Show Desktop feature isn’t given its own hotkey on Mac keyboards—unlike Mission Control and Dashboard. While you can hit F11 to activate it (Fn+F11 on a portable Mac or a Mac with an aluminum keyboard), you might like to know that the Exposé/Mission Control hotkey doubles up as a Show Desktop hotkey. Just hold Command before you tap it. 







	Tip 157
	Quick Look Files at the Command Prompt




You can use Quick Look at the command line to preview any file. What you’ll see is the same as what you would see if you select a file in Finder and hit Space or right-click it and select Quick Look. 

Just use the qlmanage -p command, followed by the filename. For example, to Quick Look the file disneyland.jpg from the command line, I’d type the following:



	 
	
​qlmanage -p disneyland.jpg​





You can Quick Look any type of file: images, documents, PDFs, and so on.







	Tip 158
	Open a Terminal Window Where You’re Browsing




Command-line junkies will like this one: you can make it possible to open a Terminal window automatically switched to the location you’re viewing in a Finder window. Open System Preferences (Apple menu→System Preferences) and click the Keyboard icon. Then click the Keyboard Shortcuts tab and, in the list on the left, select Services. In the list on the right, scroll down until you find New Terminal at Folder under the Files and Folders heading. Then put a check next to the entry in the list—this will cause the entry to appear on the menu that appears whenever you right-click a folder. Close System Preferences and give your new tweak a try-out in a Finder window or on the desktop.

Note that although it’s theoretically possible to also assign a keyboard shortcut to open a Finder window with System Preferences, this does not work in practice because of limitations placed on how Finder works with keyboard combinations.  







	Tip 159
	Turn Off the Trackpad When a Mouse Is Attached




In my experience, Apple designs its portable Macs well and positions the trackpad to avoid accidental touching while typing. But if you’re using an external mouse, you might still find that you occasionally brush against it, causing the mouse pointer to skitter. 

Fixing this is easy, but Apple has buried the setting you must alter. Open System Preferences (Apple menu→System Preferences) and click the Universal Access icon. Click the Mouse & Trackpad tab and then the Trackpad Options button at the bottom of the program window. You’ll find the option you need in the dialog box that pops up—put a check alongside Ignore Built-in Trackpad When Mouse or Wireless Trackpad Is Present.







	Tip 160
	Install Only Printer Drivers and Not Their Add-ins




If you download and install printer drivers from a manufacturer’s site, you might find that they come with bundled software that you don’t need, such as programs that warn you about low ink levels. There’s no need for this on a Mac because it’s already built-in—just open System Preferences, then click Print & Scan, then click the Options & Supplies button for the printer you’re interested in. Click the Supply Levels tab in the dialog box that opens. 

Sometimes it’s possible to delve into the installation package you download to install only the actual printer drivers, which may well be in a package of their own. It’s something of a black art because different manufacturers name files differently, but it’s worth a try. The actual printer driver packages are often identified by the name of the technology they use—CUPS, or Common Unix Printing System, so look for this in the filename.

Assuming that what you download from the manufacturer’s website arrives as a disk image, double-click it in the usual way so it opens in Finder. Then right-click the mpkg or pkg file representing the installation package and select Show Package Contents. In the Finder window that opens, browse to the Packages folder. If there isn’t a Packages folder, then look in the other folders in the package, but the chances are you’re out of luck and will just have to install the entire thing in the usual way.

If there is a Packages folder, look for anything that looks like it might just contain the actual drivers. In the package for my Brother multifunction printer, for example, I found two packages named with variations of Brother_Inkjet. Double-clicking to install both gave me the printer drivers I needed but not the irritating software that starts at boot-up and is intended to help with scanning.







	Tip 161
	Send Somebody a Link to an App




Spotted something in the App Store that you think would be perfect for a friend? Just right-click the product image above the price/install button and select Copy Link from the menu that appears. Then switch to Mail or iChat and paste the link into a message to your friend. When clicked, it will open the product page at Apple’s website. Your friend can then click the View in Mac App Store button to actually install the app via App Store. 







	Tip 162
	Get a Bigger Search Area in Safari




By clicking and dragging the small area between the URL bar and the Google search field within Safari, you can resize both so that there’s more space in the search area for typing queries. 







	Tip 163
	Copy Calculator Results




Any result displayed on the Calculator app’s LCD screen can be instantly copied into the clipboard for pasting into any other application. 

Copying and Pasting

After hitting the equals key, hit the usual copy keyboard shortcut—Command+C to copy the result in the clipboard. Then paste it into other applications in the usual way—either by clicking Edit→Paste or by hitting Command+V.

It works the other way around too—if you have a figure from another app that you want to use in Calculator, just copy it to the clipboard and then, making sure the Calculator window is on top, hit Command+V to paste it into Calculator (note that any existing numbers within the LCD display will be cleared).

Using the Paper Tape

If you’re doing a series of complex calculations that you’d like to copy and paste into other apps, open the Paper Tape window, which can be found on the Window menu. All calculations and results are recorded on it, even if you clear the calculator, and you can click and drag to select anything “printed” on it, then copy and paste as usual.







	Tip 164
	Bookmark Images and PDFs for Fast Access




If there are images or PDFs that you view frequently, you can bookmark them within Preview, OS X’s image viewer. This works just like bookmarking websites within a web browser like Safari and uses the same keyboard shortcut—just load the image or PDF and hit Command+D. From then on, click the image or PDF’s entry on Preview’s Bookmarks menu to open it instantly.

If you bookmark a multipage PDF file, you’ll also bookmark the page you were reading at the time, so that clicking the bookmark in future will return you to that page.

Rather cleverly, even if you move the original file from one folder to another, Preview’s bookmark will still link to the file—even if it’s moved into the Trash!







	Tip 165
	Shrink Safari Windows When in Full-Screen Mode




If you use Safari in full-screen mode, you might get irritated that websites look ugly and sparse when stretched to the full width of the screen. In fact, many websites assume screen widths of around 800 to 1024 pixels.

There’s a simple solution: move the mouse cursor to the very left (or right) of the screen when in the Safari space and it’ll turn into a resizing cursor. Click and drag, and you’ll narrow the space websites occupy. It’s hard to describe, so give it a try! 







	Tip 166
	Download and Keep Software Updates




Approximately every few months, Apple updates OS X with a point release. This is usually several hundred megabytes in size, and if you have more than one Mac in the house, downloading the updates for each computer can put significant strain on your Internet connection. 

The command-line softwareupdate tool can help. This gives much more control over the updating procedure compared to its GUI cousin, and it allows you to download the update packages before manually installing them. This way you can download the updates and transfer them to other computers using a USB memory stick.

Viewing and Installing Updates

Open a Terminal window and begin by listing what downloads are available, as follows (typing your login password when prompted):



	 
	
​sudo softwareupdate -l​





It’ll take a few minutes for the list of results to appear.

At this stage, installing any entry mentioned in the results list is simply a matter of specifying its name after the softwareupdate -i command (specify the name alongside the asterisk in the list—with some updates, this might simply be a series of numbers, such as 041-0846-2.7). For example, if the list includes an entry by the name of MacOSXUpd10.7.1-10.7.1, the following will both download and install it:



	 
	
​sudo softwareupdate -i MacOSXUpd10.7.1-10.7.1​





Downloading Updates

To simply download the update without installing it, use softwareupdate -d. Using the same example, this will download but not install the MacOSXUpd10.7.1-10.7.1 update package:



	 
	
​sudo softwareupdate -d MacOSXUpd10.7.1-10.7.1​





To download but not install all available updates, type the following:



	 
	
​sudo softwareupdate -d -a​





In each case, the downloaded update packages are stored in the /Library/Updates folder, and each will probably be in a numbered folder (from your Terminal window, you can type open /Library/Updates to browse this location more easily in a Finder window). Each update package can be installed simply by double-clicking it, or, if you want to remain at the command line, you can type open and specify the package name (that is, something like open MacOSXUpd10.7.1Patch.pkg).







	Tip 167
	Connect to Non-Mac Screen-Sharing Computers




OS X Lion computers can both share their screens with users of other computers and connect to screens shared in this way.

Sharing Your Screen

To share your screen, open System Preferences (Apple menu→System Preferences), click the Sharing icon, and put a check in Screen Sharing. Other Mac users will see your computer listed under the Shared heading of Finder. When they select it, they can click the Share Screen button to connect (they’ll need to enter a login and password for the screen-sharing computer in order to connect).

Users of Windows or Linux will need to download an up-to-date VNC client like RealVNC,[13] for example, and specify the network address that was listed in System Preferences when Screen Sharing was activated.

Connecting to a Windows or Linux PC

Virtual Network Computing (VNC) screen sharing is the technology that powers OS X’s screen sharing feature. To connect your Mac to a Windows or Linux computer running a VNC server, open a Finder window and click Go→Server. Then in the dialog box that appears, type vnc:// followed by the address. To connect to a computer located at 192.168.1.5, for example, I’d type vnc://192.168.1.5. You can also type this into the Safari URL bar.

Whichever method is chosen, all that happens is that OS X’s hidden Screen Sharing app is activated. This can be found in the /System/Library/CoreServices folder (open Finder, hit Shift+Command+G, then type the address to browse to the folder). You can drag and drop this to the Dock for easy access to the utility—upon running, it will prompt for a network address and then for login details. 

Adding Windows Screen-Sharing Support to Your Mac

Microsoft also offers for download a free client that allows Macs to connect to Windows computers running Remote Desktop Protocol (RDP), which is the Windows technology responsible for screen sharing. For more details, see http://www.microsoft.com/mac/remote-desktop-client.







	Tip 168
	Add Blank Spaces to the Dock




All the Dock icons sit next to each other and are equally spaced, but it’s possible to add spacers to the Dock so you can separate out some of the icons. You may find this helps you to avoid misclicking, for example. 

Adding a Spacer Between App Icons

To add any number of spacers to the side of the Dock containing the application icons, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following two lines:



	 
	
​defaults write com.apple.dock persistent-apps -array-add '{tile-data={};​




	 
	
​        tile-type="spacer-tile";}';killall Dock​





The new spacer will appear alongside the app icons. Repeat for more spacers. You can click and drag each spacer to where you want it to go. To get rid of it, just click and drag it off the Dock. It will disappear upon releasing the mouse button.

Adding a Spacer Near the Stacks/Trash

To add a similar spacer to the side of the Dock containing the Trash and stacks (or any number of spacers), open a Terminal window and type the following two lines:



	 
	
​defaults write com.apple.dock persistent-others -array-add '{tile-data={};​




	 
	
​        tile-type="spacer-tile";}';killall Dock​





The new spacer will appear beside the Trash, and again you can click and drag it to where you’d like it to go. Click and drag it off the Dock to dispose of it. 







	Tip 169
	Work with Background Windows




Often you might find yourself transferring information from one program window to another—from a browser window to a text editor, for example. Here are some tips to make that easier.

Repositioning Windows

Repositioning program windows in such a situation can be annoying, because each must be selected and then repositioned before you return to the window you’re working in—that’s a lot of clicking around!

However, holding down Command and clicking any nonactive window’s title bar lets you move that window without losing focus in the window you’re working in. 

Copying Text and Images from a Background Window

Holding down Command before clicking and dragging in the editing area of a background window will let you select text. You can then right-click the selected area to copy to the clipboard for inserting into another app (select the Copy entry from the menu that appears; unfortunately the Command+C keyboard shortcut won’t work). 

Just right-click the image in a background window and select Copy from the menu that appears to copy it to the clipboard for insertion in another app.

Scrolling

Position the mouse over the background window and you’ll be able to scroll it in the usual way—by using a multitouch trackpad gesture or by rolling the mouse ball. 

Clicking Links in a Background Window

Holding down Command and clicking a link in a background window will open the link in the default web browser (or if you’re clicking a link in a web browser, simply navigate to that link). 







	Tip 170
	See Only Files Created Today or Yesterday (and More)




Wouldn’t it be useful to click a link in Finder that showed only files accessed or created today, yesterday, or within the last week? That would make it significantly easier to find files you’ve saved but forgotten the location of. 

To make this a reality, open a Finder window and hit Shift+Command+G, then in the dialog box that appears type /System/Library/CoreServices/Finder.app/Contents/Resources/CannedSearches. Then click and drag the Today, Yesterday, and/or Past Week files to the sidebar within Finder. Clicking any in future will show just the files as discussed previously.

Log out and back in again, and File Open/Save As dialog boxes will also show the shortcuts.
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Figure 29. Downloading files using Safari’s Activity window











	Tip 171
	Download Just About Anything




If there’s something you’d like to grab from a web page for which a download link isn’t provided, such as a movie file, Safari offers a handful of ways to download it. 

Using the Activity Window

This doesn’t always work but is certainly worth a try. While browsing the site using Safari, click Window→Activity and, in the window that appears, expand the entry alongside the web page you’re viewing. Then look for the filename that matches what you’re looking for (some guesswork is often necessary—pay particular attention to the size column on the right; items like movie files are usually multiple megabytes). For an example, see Figure 29, ​Downloading files using Safari’s Activity window​.

Once you’ve found what you’re looking for, hold down Option and double-click its entry in the list. This will either open it in a separate tab of Safari, from where you can click and drag it to the desktop in the case of an image, or the file will begin downloading in the usual way, as if you’d just clicked a download link. 

Using the Download Window

Downloading any file for which you have the full URL (that is, something like http://example.com/filename.txt) is also easy using Safari. Highlight the link text and copy it to the clipboard (Command+C).

Then expand the pop-out Downloads window in Safari by clicking the button to the right of the Google search box. This will open the download progress window, and you can just hit Command+V to invisibly paste in the download address. The file will start downloading right away.

If you can’t see the download pop-out window, hold Option and click any web link on the site you’re browsing. This will download the HTML file for the page, which you can instantly delete, but the download window will now be activated and ready for use as described earlier. 

This URL pasting technique works on pictures you might want to download from a website—just right-click them, select Copy Image Address, and then select the Downloads window and hit Command+V.  

However, whether or not a file can be downloaded depends on how the website in question is configured, and this is something you can’t alter. You’ll know if this is the case because pasting some links into the Download box might simply open Safari so the file can be viewed. Some websites use this method to stop files from being downloaded directly.







	Tip 172
	View Two Weeks of Appointments in iCal




iCal has four view modes by which you can view forthcoming appointments: Day, Week, Month, and Year. You can switch between them by clicking the tabs in the middle of the iCal program window.

Here’s a quick hack to switch the Week view to showing two weeks (or more), which is useful if your working life is arranged around two-week periods or if you’d just like to see a little further into the future.


	
Quit iCal if it’s open, then open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.iCal IncludeDebugMenu -int 1​







	
Restart iCal and you’ll see you have a new menu: Debug. This is designed to allowing testing of the app by developers, so be very careful not to click any entry on the menu other than the one outlined below! 



	
Click Debug→Top Sekret [sic]→Days in Week View, and make your choice. To view two weeks in Week view, click 14. You can also choose 21 (three weeks) and 28 (four weeks), although be aware that the latter two options will make the iCal program window very wide, and it might no longer fit on your computer screen.



	
Close iCal, then return to the Terminal window and type the following to remove the Debug menu, which you no longer need:



	 
	
​defaults delete com.apple.iCal IncludeDebugMenu​





Reopen iCal and you should find that Week view now shows two weeks of appointments, and the Debug menu will have vanished.





If you find that more than two weeks are visible, it’s probably because you’ve switched iCal to show only five days per week (that is, it isn’t showing the weekends). This can be altered under the General tab of iCal’s preferences. You need to switch away from Week view (by clicking the Month view tab, for example), and then switch back to it for the changes to take effect. 

To revert to showing only one week in Week view, repeat the steps above to activate the Debug menu, but select Default (7) from the Days in Week View menu option. Then repeat the steps to deactivate the Debug menu. 







	Tip 173
	Get Rid of the Mac Startup Chime




Macs are distinctive among the computing fraternity in the melodious chime they make while booting. While PCs that do nothing more than beep might look on enviously, the fact is that the chime isn’t always welcome—boot your MacBook in a library, for example, and several annoyed faces will willingly hand out censure.

Creating a Silent Boot

Here’s how to deactivate the chime. Because there’s no official way of doing this (via a hardware switch, for example), the solution below is a hack that works by muting your computer’s volume when you shut down and then unmuting it when you log in again upon rebooting. Unfortunately, this only works if you don’t have FileVault turned on, because that uses a different login procedure.  


	
Open Terminal (Finder→Applications→Utilities→Terminal) and type nano, to open the nano command-line text editor. Then type the following within nano:



	 
	
​#!/bin/bash​




	 
	
​osascript -e 'set volume with output muted'​







	
When you’ve finished typing, hit Control+O, then type the following for the filename: ~/Documents/mute.sh. Hit Return to save the file. 



	
Don’t close the Terminal window, but alter the second line within nano to read as follows (that is, change with to read without):



	 
	
​#!/bin/bash​




	 
	
​osascript -e 'set volume without output muted'​







	
When you’ve finished typing, hit Control+X, hit Y, then type the following for the filename: ~/Documents/unmute.sh. Hit Return to save the file. nano will quit.



	
In the Terminal window type the following series of commands, typing your login password when prompted: 



	 
	
​sudo chmod u+x ~/Documents/mute.sh​




	 
	
​sudo chmod u+x ~/Documents/unmute.sh​




	 
	
​sudo mv ~/Documents/mute.sh /Library/Scripts/​




	 
	
​sudo mv ~/Documents/unmute.sh /Library/Scripts/​




	 
	
​sudo defaults write com.apple.loginwindow LogoutHook /Library/Scripts/​




	 
	
​        mute.sh​




	 
	
​sudo defaults write com.apple.loginwindow LoginHook /Library/Scripts/​




	 
	
​        unmute.sh​









If you reboot, you should find the chime volume is now muted. 

Reactivating the Chime

To restore the chime at a future date, open a Terminal window and type the following series of commands, again typing your login password when prompted:



	 
	
​sudo defaults delete com.apple.loginwindow LogoutHook​




	 
	
​sudo defaults delete com.apple.loginwindow LoginHook​











	Tip 174
	Zoom Into the Desktop




Ever wanted to examine something on a web page in more detail? OS X includes a screen zoom tool that’s deactivated by default but can be extremely useful. 

Setting Up

To activate the screen zoom tool, start System Preferences (Apple menu→System Preferences) and click the Universal Access icon. Make sure the Seeing tab is selected, then click the Options button alongside the Zoom heading. In the dialog box that appears, put a check in the box next to Use Scroll Wheel with Modifier Keys to Zoom. Then click Done and close System Preferences.

Zooming In

From then on, if you hold down Control and vertically scroll the mouse wheel/​ball (or drag two fingers up/down a multitouch trackpad) you can zoom into the screen at the cursor position. This feature is designed for people who are partially sighted, but it’s also a quick, albeit low-fi way of zooming into pictures if you don’t want to use the application’s own zoom tools. Note that you won’t actually increase the amount of detail in the picture using this method. Instead you simply make the pixels larger. 

Using a More Accurate Zoom

By default the zoomed image is antialiased, that is, the rough edges of pixels are smoothed over, giving a slightly blurry effect. To quickly switch off antialiasing while zooming, which can give you a less blurred zoomed image, hit Option+Command+\. Hit the same key combination again to reactivate antialiasing.







	Tip 175
	Make Time Machine Back Up Less Frequently




By default Time Machine makes a backup of the system every hour or thereabouts. This can put strain on your computer that might lead to slowdowns and reduced battery life on a portable Mac. Bearing in mind that each backup takes space on your hard disk, you also run the risk of running out of space.

You can tweak a secret setting to cause backups to be made every two hours or more. 

Note that this tip changes a system-wide setting, so it will affect all users.

Changing the Backup Interval

Open a Terminal window and type the following code. The number at the end of the command is the number of seconds between backups. By default this is set to 3600 (60 minutes x 60 seconds), but if you wanted to back up every two hours, for example, you could use a value of 7200 (120 minutes x 60 seconds), as follows (type your login password when prompted):



	 
	
​sudo defaults write /System/Library/LaunchDaemons/com.apple.backupd-auto​




	 
	
​        StartInterval -int 7200​





You’ll need to restart the computer for the changes to take effect. Note that you can see when the next backup is due by opening System Preferences (Apple menu→System Preferences), clicking the Time Machine icon, and looking under the Next Backup heading.

Restoring the Default Interval

To restore the time interval to the default 60 minutes, type the following:



	 
	
​sudo defaults delete /System/Library/LaunchDaemons/com.apple.backupd-auto​




	 
	
​        StartInterval​











	Tip 176
	Switch Between Document Windows




The Command+Tab key combination lets you switch between open applications, but what if you want to switch between open documents within the same application?

Simply hit Command+`. That last one is the backtick key, which is located to the left of the number row on most English keyboards, but you might find it to the left of the Z key on some keyboards.

You won’t see a fancy list showing which windows are open, as with the main task switcher. Instead you’ll simply cycle through the open windows of the app on each tap of the key, bringing each window to the fore. 

You’ll cycle through all program windows using this trick. For example, if you have a Find dialog box open in a text editor, you can switch between that and the main editing window using Command+`. 







	Tip 177
	Quickly Rename Files




To quickly rename a file or folder, select it in Finder or on the desktop and then hit Return. Unlike with Windows computers, this won’t open the file but will highlight the filename so you can type over it with something else.

If you change your mind and want to leave the name as it is, just hit Esc. 

An additional tip is that if you want to rename the entire file including its file extension, simply hit Command+A to select the entire filename after hitting Return.


Exploring OS X Lion: Time Machine


Time Machine will invisibly back up the entire system plus your personal data to an external hard drive that’s physically attached to your computer or across a Wi-Fi network via Time Capsule.[14]


Time Machine makes incremental backups, which means you can restore not only the last version of a file but versions going back to when the file was first created. Time Machine stores hourly backups for the past twenty-four hours, then switches to saving a single backup representing every day for the past month. Eventually it switches to saving one backup representing each week.

Reverting to an earlier version of a file is simply a matter of clicking the Time Machine icon at the top right of the screen, then selecting Enter Time Machine. You’ll then see a display of Finder windows stretching back in time. Against the right edge of the screen will be a vertical listing of the times and dates when backups were taken. Clicking any backup will magically return the Finder to that time and show how the files and folders appeared back then.

It’s possible to restore an entire system via Time Machine should a disaster occur—see Tip 226, ​Make Use of Boot-Time Options​.



http://www.apple.com/timecapsule/














	Tip 178
	Force a File to be Indexed in Spotlight




Sometimes you might find a particular file simply won’t appear in Spotlight’s search results, even though you know it should. For example, you’re searching for files containing the text quarterly report, but you later find that the file Quarterly report 2012.xls in your Documents folder simply didn’t show up.

Forcing Files to Be Indexed

The solution is as follows. Open a Terminal window (Finder→Applications→Utilities→Terminal) and type mdimport, then specify the filename and location (or just drag and drop the file onto the Terminal window to autocomplete these details).

For example, to import the file mentioned above, contained in my Documents folder, I’d type the following:



	 
	
​mdimport ~/Documents/"Quarterly report 2012.xls"​





Note that I’ve enclosed the entire filename in quotation marks above because it contains a space.

Forcing Folders to Be Indexed

Folders can also be specified, in which case all files within will be indexed. The following will index all of a folder called accounts in your Documents folder, for example:



	 
	
​mdimport ~/Documents/accounts​











	Tip 179
	Turn Off Requests to Use New Disks for Time Machine




If you don’t use Time Machine, you might notice that every time you attach a blank hard disk to the computer, you get asked if you want to use it for backups. 

You can stop this request dialog box from appearing by opening a Terminal window (Finder→Applications→Utilities→Terminal) and typing the following:



	 
	
​defaults write com.apple.TimeMachine DoNotOfferNewDisksForBackup -bool TRUE​





Then log out and back in again for the changes to take effect.

If you’d like to restore the request dialog at a later date, type the following (log out and back in again after for the changes to take effect):



	 
	
​defaults delete com.apple.TimeMachine DoNotOfferNewDisksForBackup​











	Tip 180
	Put Hard Disks to Sleep Sooner on Portable Macs




Portable Macs include a feature in the Energy Saver pane of System Preferences that will put the hard disk to sleep when it isn’t being used (for example, if you’re simply browsing the Internet while out and about and not editing files). This can save battery life, but it only kicks in after ten minutes of inactivity, that is, ten minutes after the disk has not been written to or read from.

Going to Sleep Faster

You can reduce this time delay at the command line, causing the hard disk to go to sleep faster. You might find this helps save battery life, although there might be a very brief system freeze each time as the hard disk spins up again. 

The following command will make the delay five minutes, but only when the battery is in use and not when the power cable is connected (note this is a system-wide change and therefore affects all users):



	 
	
​sudo pmset -b disksleep 5​





Restoring Default Sleep Times

To restore things to default, repeat the command, replacing the 5 with a 10 so that the default delay of ten minutes is reinstated:



	 
	
​sudo pmset -b disksleep 10​











	Tip 181
	Add Your Own System Sounds




With a little hacking you can use your own sound files for system alerts. You can find a variety of sound effect files online—just try Google. However, the files must be in AIFF format. Most sound files you might download from websites are in other formats (usually wav). However, you can convert them to AIFF format using iTunes, as described below.

Remember that alert noises need to be short. There’s no point in using a three-minute pop song as an alert because it’ll continue playing long after you’ve forgotten what the alert was for.

Right-click the sound you want to download and select Downloaded Linked File. Simply clicking the link will play the sound within the browser window.
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Figure 30. Adjusting iTunes settings to output AIFF files





Converting Sounds to AIFF Format


	
Open iTunes in the usual way—click Finder→Applications→iTunes, click the application menu, and then click Preferences.



	
In the dialog box that appears, make sure the General icon is selected and then click the Import Settings button. 



	
In the new dialog box that appears, click the Import Using dropdown list and select AIFF Encoder (see Figure 30, ​Adjusting iTunes settings to output AIFF files​). Then close all the dialog boxes and return to the main iTunes interface.



	
Click and drag your sound file to the iTunes window so that it’s imported into your playlist. Locate it in the list (hint: type its name into the Search box at the top right of iTunes), and then right-click it and select Create AIFF Version. 



	
Conversion is instant and you’ll find you have two versions of the file. Select the second of the two and click and drag it to the desktop. You should now have an AIFF file (the file will have an .aif file extension). 



	
Now you need to return iTunes to its original settings, so click the application menu again and select Preferences. Click the Import Settings button, and this time select AAC Encoder from the Import Settings dropdown list. You can now close all dialog boxes and quit iTunes.





Importing Sounds for Use by the System

Once the sound file has been converted to AIFF format, it must be imported for use and activated. 


	
Open a Finder window, hit Shift+Command+G and type ~/Library/Sounds.



	
Click and drag the AIFF file you created earlier to the directory, and then close Finder.



	
Now open System Preferences (Apple menu→System Preferences) and click the Sound icon. In the pane that appears, click the Sound Effects tab and select your sound effect from the list—the sounds will be listed alphabetically.



	
The changes will take effect immediately, but to test the new sound effect, click it once or twice. 





To go back to using built-in system alert sounds, simply open System Preferences, then open the Sound pane as described previously, and—ensuring the Sound Effects tab is selected—select one from the list. You can then delete your sound files from the ~/Library/Sounds folder.







	Tip 182
	Know When You’re Accessing a Read-Only Folder




Want to know when you’re browsing a read-only folder? Click View→Show Status Bar. This will add a small info display bar to the bottom of Finder windows that mainly indicates how many items are shown within the Finder window and how much free space there is. However, if you access a folder to which you can’t save files or edit existing documents, you’ll see a struck-through pencil icon on the bottom left of the bar.







	Tip 183
	Quickly Email Text or Pictures




Click and drag a text selection, picture, or file to the Mail icon in the Dock to instantly compose a new email with the text or picture in the body or the file attached to the new mail.  







	Tip 184
	Bulk Shrink, Rotate, or Flip Pictures in Preview




Your Mac’s built-in image viewer, Preview, includes the ability to adjust the size of a picture and to rotate it.

If you open several pictures at once, you can adjust all of them simultaneously. You may find this useful for preparing photos for use online, for example, or for correctly orienting several photos that were taken in portrait mode. 

Manipulating Individual Pictures

To shrink, rotate, or flip an individual picture, just open it in Preview and click Tools→Adjust Size, Tools→Rotate Left/Rotate Right, or Tools→Flip Horizontal/Vertical on the menu.

Manipulating Many Pictures

To bulk-tweak photos, open a Finder window and select all of the picture files in the usual way, by rubber-band selecting them or by using Shift and/or Command. Then click and drag them all to the Preview button on the Dock. You can also drag a folder full of photos to the Preview Dock icon. 

This will open Preview with all the picture thumbnails in the slide-out drawer to the right of the program window. Click any one of the thumbnails and hit Command+A to select all the pictures in the drawer. Then select Tools→Adjust Size (or any of the other options for manipulating photos on the menu). Then set a new setting in any dialog box that appears. 

Once you’re done, click OK in the dialog box. The process might take some time and there’s no progress display, so you might have to wait a few seconds for the changes to take effect. You might get a prompt asking if you want to Unlock the photos to save changes, so click Yes to do so.

Professional photographers might be interested to know that you can also assign new color profiles to the images (after selecting all the images in the Preview drawer, click Tools→Assign Profile and select from the dropdown list), although it isn’t possible to tweak the color or brightness of a group of images—any attempt to do so will only affect the first image in the selection.







	Tip 185
	Quickly Create a New Sticky Note




The Stickies application is one of the hidden gems of your Mac’s built-in software list. You can find it in the Applications list within Finder. The app borrows from the real-life sticky notes, and you can stick virtual notes anywhere on the desktop. Whatever you type on them is automatically saved across reboots. 

Sometimes I want to make a note of text on a web page, but this can be a cumbersome experience—I have to highlight the text, copy it, switch to Stickies, and create a new note before I can paste in the text.

Here are two potential solutions to this issue.

Creating New Notes Using Keyboard Shortcuts

The first solution is to highlight the text in the usual way and hit Shift+Command+Y. This will automatically create a new sticky note containing the text. 

If photos are included within the block of selected text, they’ll be included in the note, but any layout is usually lost (that is, the pictures might not appear where they did on the web page, for example).

Dragging and Dropping

An alternative is to create a Dock icon for Stickies (just drag the Stickies program icon from Applications to the Dock), and then simply drag and drop selected text onto it to create a new note containing the text. So in Safari I would highlight text and then click and drag it down to the Stickies icon before releasing the mouse button to create a new note.  

If images and links are included in the block of selected text, they too will become part of the note, although—as above—the formatting of the web page will probably be lost and everything will look a little skewed.

Additionally, dragging and dropping image files from Finder or the desktop straight onto an existing note will insert them at the cursor position. You can also drag text clippings into the Dock icon to create a note from the clippings content (see Tip 62, ​Save Text Snippets for Reuse​).







	Tip 186
	Open a Finder Window When Saving or Opening Files




Hitting Command+R while using the File→Open or File→Save As dialog boxes will open a Finder window displaying the contents of the folder you’re currently in. You may find this useful when trying to locate files.

Remember that you can drag and drop a folder from a Finder window onto a File Open/Save As dialog box to jump straight to that location. 







	Tip 187
	Podcast like a Pro from Your Mac




OS X includes Podcast Publisher, a versatile and user-friendly podcasting app that helps you create both video and audio podcasts (see Figure 31, ​Using Podcast Producer​). You’ll find it in the Utilities folder within the Applications view of Finder, and using it is very simple.
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Figure 31. Using Podcast Producer





Creating a Podcast

Once the app starts, click the down arrow alongside the New Movie Episode button at the bottom left to choose between creating a video or audio podcast, then:


	
If creating an audio podcast, hit the Record button at the bottom of the window and, after the countdown has completed, speak your podcast! When done, click the Record button again to end the recording. 



	
If creating a video podcast, click the Add a New Episode sticky on the virtual corkboard to start the creative process. Once you’re happy with the video framing and audio levels (watch the audio meter at the bottom of the window), click the Record button to create. Once you’re done, click the Record button again to stop the recording.





After making an audio or video podcast, you’ll be invited to trim the recording (in the same way as described in Tip 127, ​Edit Movies Within QuickTime Player​). Trimming can be useful for deleting those few seconds at the beginning and end of the podcast when you’re clicking the Record button. Type a name for the podcast at the top of the program window, typing over the default name. 

Sharing Your Work

Click the Share button to automatically add the podcast to iTunes, save it to your desktop for manual uploading to your server, or attach it to an email. You can also upload the podcast to an OS X Server computer running Podcast Producer or Remote Workflow servers,[15] although this will first need to be set up using the Podcast Capture app (also within the Utilities folder of the Applications list in Finder).







	Tip 188
	Know If a PDF is Multipage at a Glance 




The file icon for a PDF containing more than one page has a black binder at the left (just as a real multiple-page document would be bound). Single-page PDFs are shown as just one page, sans binding. 







	Tip 189
	Control Slideshow Screen Savers




Spotted a picture you like while your computer is running one of the various photo slideshow screen savers? Just hit Space to pause. You can then use the left and right cursor keys to manually advance back and forth in the slideshow. 

While the screen saver is running, you can tap the left and right cursor keys to step quickly back and forth through the images—useful if you want to go back to an image you’ve just seen!







	Tip 190
	Get Photos and Movies Off Your iPhone and iPad




When you attach your iPhone or iPad to your Mac via USB, open Preview and click the File menu. At the bottom of the list you’ll see option to import from the device. Selecting this will show a new window full of pictures and movies on the phone. You can click and drag individual files (or groups of files selected by holding down Command or Shift) to a Finder window or the desktop, or you can click the Import buttons at the bottom of the screen. In both cases a new Preview window will appear showing the pictures as they’re imported. 







	Tip 191
	Save Web Pages to Disk




There are a variety of ways to save web pages to disk within Safari so you can view them later. 

Using the Reading List

Perhaps the quickest is to use the Reading List, which is built into Safari and is designed to let you read pages even if your computer is offline. Browse to the page in question and hit Shift+Command+D, or select the Add to Reading List entry on the Bookmarks menu. You can access your stored Reading List pages by clicking the eyeglasses icon at the left of the shortcuts toolbar. 

Saving Web Archives

The biggest issue with the Reading List is that only you can read any pages it stores—there’s no way to export a Reading List page. To save a web page to disk so it can be opened on any other Mac or on a Windows PC that has Safari installed, click File→Save As; then in the Format dropdown list of the dialog box that appears, select the Web Archive option. This will create a single file that you can email to others or pass to them via a USB memory stick.

Saving as a PDF

To save the web page so it can be viewed on any computer, save it as a PDF file. Click File→Print and then, in the dialog box that appears, click the PDF button at the bottom left. Select Save As PDF in the pop-up menu that appears.

Beware that saving the page as a PDF will strip out most of its formatting, although it should leave the content readable (that is, text and images should be in roughly the correct order). 







	Tip 192
	Recycle Your Old Apple Hardware and Get Paid




If you’ve got an old Mac or other Apple hardware such as an iPhone, you can recycle it via Apple’s official partner, PowerON. If the item has any worth, you’ll be given an Apple gift card.

Deciding if an item has any worth depends on whether the item is functional and also on its age. However, PowerON will also accept broken or very old devices and will even pay for shipping, although it’s unlikely you will receive any money for it.  

For more information, visit http://store.apple.com/us/browse/reuse_and_recycle. Note that this scheme only runs in the US. However, Apple stores in some other countries run a recycling scheme whereby they will responsibly dispose of old hardware free of charge. Inquire with an Apple store in your area for details.  







	Tip 193
	Make iCal Appointment Times Shorter




iCal has a clever feature whereby you can create new calendar events by typing a sentence describing them. Just click the plus icon at the top left of the window and start typing. For example, typing “Lunch with parents at 12pm weds” will create an appointment on Wednesday starting at 12 p.m. and called “Lunch with parents.” 

However, unless you add in how long the event will last, iCal will always create hour-long appointments. If you’re using iCal to schedule appointments for a business, it might be more convenient if iCal defaulted to thirty- or even fifteen-minute appointments.

Shortening Default Appointment Times

A secret setting can be tweaked to make this happen. Quit iCal, then open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following, which will shorten the default time to thirty minutes:



	 
	
​defaults write com.apple.iCal "Default duration in minutes for new event"​




	 
	
​        -int 30​





Change the number at the end to the number of minutes you want events to last for. For example, the following will shorten the time to fifteen minutes:



	 
	
​defaults write com.apple.iCal "Default duration in minutes for new event"​




	 
	
​        -int 15​





Reverting Back to Default Appointment Times

To revert back to an hour, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.iCal "Default duration in minutes for new event"​











	Tip 194
	Make Your Mac Speak




Your Mac includes a high-quality speech synthesizer that sounds almost like a natural voice. 

Speaking Within Applications

In some applications, especially the built-in apps like Safari or TextEdit, you can make your Mac read by selecting text, right-clicking the selection, and selecting Speech→Start Speaking from the menu that appears. Some people find this useful for proofreading, because hearing the words allows them to pick up on errors their eyes might glide over. 

Recording Speech Synthesis

You can also record your Mac’s speech synthesis and turn it into an iTunes track for downloading to an iPod/iPhone. Just select the text, then right-click the selection and click Add to iTunes as a Spoken Track from the pop-up menu. A pop-up window will appear, asking you to define a filename for the new file. Once you’re done, click the Continue button. iTunes will automatically start, and clicking the Spoken Text heading on the left of the program window will reveal your new creation.

Changing the Voice

You can change the synthesis voice by selecting the Text to Speech tab in the Speech pane within System Preferences (Apple menu→System Preferences). Click the dropdown list next to System Voice. The built-in voices aren’t very good, but by clicking Customize in the System Voice dropdown list, you can download several high-quality voices. Be aware that these come as very large (multigigabyte) files, however, so they are perhaps best downloaded at home rather than across public Wi-Fi in a coffee shop.

Speaking at the Terminal

Using the Terminal (Finder→Applications→Utilities→Terminal), you can make your Mac read entire text (txt) files. Just type the following, replacing FILENAME.txt with the name of your file: 



	 
	
​say -f FILENAME.txt​





You can also use the say command to make your Mac say anything. For example, you could type the following:



	 
	
​say The Mac is the best computer the world has ever known​











	Tip 195
	Get the Most from the Mac Dictionary App




Your Mac includes a fantastic Dictionary application that you can find in in the Applications folder of Finder. 

Reading the Front and Back Matter

The Dictionary app relies on the prestigious Oxford Dictionary for its word definitions, but the app also contains all of the dictionary’s pages, including introductory chapters and reading guides. To access these, open the application and click Front/Back Matter at the bottom of the Go menu. Then click the hyperlinks to individual sections within the Dictionary program window.

Adding New Languages and Variations

You can also search a British version of the English dictionary and thesaurus, as well as a Japanese dictionary and a Japanese/English dictionary. To activate these, click Preferences on the Application menu and select them in the list within the dialog box that appears. You can click and drag entries in the list to define which results are shown first when you search for words.  







	Tip 196
	Scroll Finder Windows Better




If you drag a file to the top or bottom of a Finder window and hold it there, the window will eventually begin to scroll up or down. This can be useful, but it’s a rather difficult trick to master—often the window will scroll jerkily or scroll a little, then stop. 

Activating Better Scrolling

A secret setting can help enhance this feature and make it a useful part of your workflow. To activate it, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.finder NSDraggingAutoscrollDelay -int 0;killall Finder​





The changes take effect immediately, so give it a try by dragging a folder to the top or bottom of a Folder window full of files. You’ll see how the Finder window becomes far more responsive to scrolling suggestions.


Reverting to Default Settings

If you decide the change isn’t for you, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.finder NSDraggingAutoscrollDelay;killall Finder​











	Tip 197
	See Numbers in Huge Type for Easy Jotting Down




Have you ever wanted to jot down a phone number from the screen, but found it difficult because you had to keep looking back and forth from screen to page, constantly losing your place on the screen?

In TextEdit you can simply highlight the telephone number, right-click it, and select Large Type. In Mail, hover the mouse over the phone number until an arrow icon appears and click it, selecting Large Type from the menu that appears. Note that this only works for messages you’ve received in Mail and not for ones you’re composing.

This also works when using Calculator, letting you view the result of calculations—right-click the numbers on the LCD screen and then select Large Type.

In each case the text will then be displayed in large floating text that fills the width of the screen. To get rid of it, just click anywhere. 







	Tip 198
	Always See Expanded Save Dialogs




Your Mac offers two dialog box modes when it comes to saving files: compact and expanded (see Figure 32, ​Dialog boxes can be set to expanded (above) or compact (below) views​). Compact size keeps things simple, deliberately offering few choices other than typing the filename, while the expanded size usually displays a file listing and various other options. You can switch between the two using the small down arrow next to the filename, but small size is the default unless the user changes it.

Your Mac will remember your choice for any particular application once the change is made, but it’s possible to force all Save As dialog boxes in all applications to always appear in expanded format, even for applications you haven’t used before. 
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Figure 32. Dialog boxes can be set to expanded (above) or compact (below) views





Activating Large Dialog Boxes

To force save dialog boxes to always use large format, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following: 



	 
	
​defaults write -g NSNavPanelExpandedStateForSaveMode -bool TRUE​





Log out and then back in for the changes to take effect. Note that should you contract the dialog box again (by clicking the down arrow), the app will remember and show a small dialog box until you manually change it again.

Reverting to Default

To revert to compact dialog boxes by default at a later date, open a Terminal window and type the following:



	 
	
​defaults delete -g NSNavPanelExpandedStateForSaveMode​





Again, log out and back in again for the changes to take effect.







	Tip 199
	Quick Look Using Full-Screen Mode




Selecting a file in Finder or on the desktop and hitting Space will open the file in Quick Look mode, showing a preview. Quick Look also has a full-screen mode, which shows more detail. Just hit Option+Space instead of just Space.

A drawback of activating Quick Look in this mode is that hitting Option+Space again won’t close the Quick Look window. Instead you must hit Esc or click the close button on the Quick Look floating toolbar.	

You can switch in and out of full-screen mode in any Quick Look window by clicking the icon at the top right of the window or by using the pinch-and-expand gesture. 







	Tip 200
	Have Your Grammar Checked as You Type




Your Mac will check your spelling as you type in many applications, underlining mistakes in red, but did you know that it can also check your grammar? 

Activating Grammar Checking

To activate the feature in any application where you want to use it (such as Safari, TextEdit, or Mail), open the application and click Edit→Spelling and Grammar→Check Grammar with Spelling. It will remain active when you quit and restart the application until you deactivate it in the same way. 

Correcting Bad Grammar

What OS X considers bad grammar will be underlined in green, but beware that grammar checking is nowhere near as accurate as spell checking, and—quite simply—OS X will probably get it wrong a lot of the time.

Right-clicking any words or phrases highlighted as bad grammar probably won’t provide a suggested correction of the suspected error, as with spelling mistakes, or even a description (although suggested corrections might appear for simple mistakes, such as mistaking “it’s” for “its”).

However, to see the nature of the error, you can hover the mouse cursor over the underlined phrase until a tooltip appears, which will explain the problem, or you can perform a complete spell and grammar check using the Spelling and Grammar dialog box. To begin a full check, click Edit→Spelling and Grammar→Show Spelling and Grammar. Clicking the Find Next button will cycle through any highlighted errors (both spelling and grammar), with a description of what your Mac thinks the error is for grammar mistakes. 







	Tip 201
	Tweak the Dock’s Look and Feel




Here’s how to adjust how the Dock looks and where it’s positioned onscreen.

Switching to a Flat, 2D Dock

The Dock is a masterpiece of engineering. In its default configuration and position, it emulates a glass platform with reflections of any nearby windows showing in it.

If that all sounds too fancy, you can switch to a flat, two-dimensional Dock quite easily. Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock no-glass -bool TRUE;killall Dock​





The changes will take effect immediately—for an example, see Figure 33, ​Switching the Dock to a flat, 2D representation​. The flat Dock will work in the same way as before.

To revert to a 3D Dock again, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock no-glass;killall Dock​
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Figure 33. Switching the Dock to a flat, 2D representation





Shifting the Dock to a Side of the Screen

 You can move the Dock from its original position at the bottom of the screen to the left or right via the Dock pane within System Preferences (Apple menu→System Preferences). However, a quicker way is to hold down Shift and click and drag the “Abbey Road” bars that separate the application icons from the stacks and the Trash (that is, the bars that look like the road crossing on the Beatles’ Abbey Road album cover).

Just click and drag to the left or right of the screen and then release when the Dock takes its new position. To return the Dock to the bottom of the screen, just click and drag it there in the same way. When the Dock is positioned at the left or right of the screen, it switches automatically to the 2D appearance. 

It’s possible to shift the Dock to the corner of the screen rather than having it centered. To do this, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following to shift it to the left if it’s at the bottom, or to a top corner if it’s positioned on the left or right of the screen:



	 
	
​defaults write com.apple.Dock pinning start;killall Dock​





Or you can type the following to shift it to the right if the Dock is at the bottom of the screen, or to a bottom corner if the Dock is positioned on the side of the screen:



	 
	
​defaults write com.apple.Dock pinning end;killall Dock​





To return it to the middle of the screen, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.Dock pinning;killall Dock​











	Tip 202
	Add Hand-Drawn Sketches to PDFs




We discuss in another tip how to insert your signature into PDFs (Tip 262, ​Add Your Signature to Docs Using Preview​). However, the system can also be used to insert hand-drawn sketches like maps or diagrams into documents. Just hold the drawing up to the camera instead of your signature, and then resize it appropriately once it’s inserted into the document—the drawing will be captured in surprisingly high resolution that makes it suitable for inclusion, even in documents intended for printing.

It’s not possible to append such sketches to existing image files, although you can add text boxes and various other annotations to images—just click Tools→Annotate and select an option. 







	Tip 203
	Prune Entries from the Right-Click Menu




Is your right-click menu getting a little full, making it hard to see the options you’re interested in at a glance? This can be a real issue in Finder because many apps like to add their own entries to the right-click menu that appears for files, but other right-click menus can get filled up too, such as the one that appears when you right-click text.

To control what entries appear in right-click menus, open System Preferences (Apple menu→System Preferences) and click the Keyboard icon. Then click the Keyboard Shortcuts tab and select Services on the left. Then, to prune the file browsing right-click menu, look under the Files and Folders heading in the list on the right of the window. Clearing the checkbox next to any entry will immediately remove it from the menu.

To prune the menu that appears when you right-click text, look for entries in the rest of the list under the various other headings in the list on the right of the System Preferences window, with particular reference to the entries under the Text heading.







	Tip 204
	Quit Finder




You can quit all applications except one: Finder. Finder is designed to always be running, and with good reason—it’s responsible for displaying files on the desktop. Quit Finder and these will disappear. However, there are certain instances when it’s useful to quit Finder. Some of the tips in this book require it, for example, although we use the killall Finder command, which is a quick and dirty way of doing so within a Terminal window.

Adding a Quit Option

To add a Quit option to the file menu of Finder’s application menu, all you need to do is enter the following line within a Terminal window (Finder→​Applications→Utilities→Terminal):



	 
	
​defaults write com.apple.finder QuitMenuItem -bool TRUE;killall Finder​





Starting Finder again once you’ve quit is easy—just click its icon in the Dock.

Removing the Quit Option

To remove the Quit menu option, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.finder QuitMenuItem;killall Finder​











	Tip 205
	Undo File Operations




Just copied or moved a file and changed your mind? The standard undo keyboard shortcut—Command+Z—also works on the desktop and within Finder windows to undo the most recent actions. 







	Tip 206
	Create a New Folder from a Selection of Files




Want to ultra-quickly create a new folder that contains a handful of files? Just select the files in the usual way by clicking and dragging a rubber band around them (or by selecting them individually by holding down the Command key), and then right-click any one of them. The topmost entry in the menu will be Make Folder with Selection. Clicking it will do exactly as the description says—you’ll find yourself with a new folder containing the files! Rename it in the usual way (see Tip 177, ​Quickly Rename Files​). 







	Tip 207
	Quickly Remove Dashboard Widgets




Removing widgets from your Dashboard can be a pain—you have to bring up the Manage Widgets panel by clicking the plus icon at the bottom left, which will then add a close button at the corner of each widget.  

A quicker way to remove a widget is to simply hold down Option while hovering your mouse over it. The same close button will appear, allowing you to click to delete that particular widget.







	Tip 208
	Align Desktop Icons When Dragging




Holding down Command while dragging a desktop icon will cause it to align to an invisible grid when you release the mouse button (the equivalent of clicking the Clean Up Selection option on the right-click menu). This also works with multiple files—click and drag to highlight them, then hold down Command while moving them to align them all to a grid. This is a quick way of tidying up either the desktop or files in a Finder window if you’re using Icon view—select all files (Command+A), hold down Command, then drag them all a little to the left or right. All the icons will magically slide into place according to the invisible grid.







	Tip 209
	See OS X Animations in Slow Motion




Holding down Shift while clicking just about anything in OS X that uses an animated transition will reveal the animation in slow motion. For example, holding down Shift while minimizing a window to the Dock will slow the minimizing process in pleasing slow motion. Holding down Shift while activating Mission Control using the keyboard hotkey will do the same. 

This feature was added to OS X to allow former Apple CEO Steve Jobs to demonstrate the beauty of window animations while giving the first keynote speech introducing Mac OS X. It’s hung around in the decade since!







	Tip 210
	Know Which Apps Are Hidden in the Dock




There are two ways to send a program window to the Dock on your Mac: minimizing and hiding. The only real difference between the two is that minimized app program windows are visibly shrunk to an icon on the right-hand side of the Dock, while hidden program windows simply disappear from the screen and can be brought back to view by clicking their Dock icon (that is to say, they don’t shrink to an icon on the right side of the Dock). 

To minimize a program, click the button on the program’s title bar or hit Command+M. To hide a program, click the Hide option on the program’s application menu or hit Command+H.

Revealing Hidden Apps

If you choose to hide a program, there’ll be no obvious sign that the program is hidden, but you can fix this with a quick Terminal command that will cause the hidden program’s icon to be dimmed out (that is, it’ll become translucent). 

Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.Dock showhidden -bool TRUE;killall Dock​





The changes will take effect immediately.

Reverting to Default

To revert to the default mode of hiding apps, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.Dock showhidden;killall Dock​











	Tip 211
	Cancel Drag and Drop Mid-move




Ever found yourself changing your mind about dragging and dropping a file? The problem is that if you let go of the file, it’ll be moved or copied to wherever your mouse is hovering over. 

To cancel drag and drop, either hit Esc or drag the file to the menu bar at the top of the screen and release. 







	Tip 212
	Make Time Machine Forget a File




Time Machine periodically backs up every single file on your computer, including personal data. That might include data you want to permanently eradicate from your computer so it simply no longer exists—not as a file and not within a backup.
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Figure 34. Making Time Machine delete a file from its backup





This is surprisingly easy to do. Click the Time Machine icon at the top right of the screen and, if a backup is currently taking place, click Stop Backing Up. Then click Enter Time Machine. Use the Time Machine Finder window to navigate to the file’s location. Locate it and right-click. Select Delete All Backups Of from the menu and enter your login password, if prompted. See Figure 34, ​Making Time Machine delete a file from its backup​.

Click Cancel at the bottom left of the Time Machine window. When you’ve returned to the desktop, immediately delete the file in the usual way by dragging it to the Trash (don’t forget to securely empty the Trash for maximum security—see Tip 18, ​Empty the Trash—Securely​).







	Tip 213
	Connect to Shared Folders or Servers




Your Mac can speak the same networking language as Windows computers, meaning you can share files and printers.

Using Finder’s Sidepane

Connecting to a shared folder or other resource should be as easy as looking under the Shared heading in the sidepane of Finder, clicking the entry for the computer in question, and typing the other computer’s login credentials when prompted.

Unfortunately, things sometimes don’t run as smoothly as this, and it can be hard to diagnose why. The computer simply might not appear in the list.

Specifying a Network Address

Luckily, there’s an alternative method of attempting to make a connection, but to use it you’ll need to know the IP address (that is, the numeric network address) of the computer in question. You can ask your local administrator for this information or, on the Windows computer in question, click Start and in the search field type cmd. In the command-prompt window that appears, type ipconfig and look for the details that appear alongside the IPv4 Address heading.

Back on your Mac, open a Finder window and click Go→Connect to Server. In the Server Address field, type smb:// and then the IP address. For example, a Windows PC on my network has the address 192.168.1.102, so I would type smb://192.168.1.102. Once you are done, hit the Connect button. Hopefully you should now be able to connect. 

Connecting to a WebDav Server

To connect to a WebDav server, open a Finder window and click Go→Connect to Server. In the Server Address field, type the server’s address, complete with the https:// prefix. Then hit Connect. Type the login username and password when prompted. 







	Tip 214
	Browse Another Country’s App Store




Are you on vacation but still want to purchase items from the App Store? You might find that the App Store you see is the one for the country you’re in rather than for your home country. The solution is to click the small circular flag icon at the bottom right of the App Store home page. On the following screen you can select which country’s store you’d like to visit. 

Beware: you can only purchase apps for the country where your Apple ID is registered. Therefore it’s not possible for European Mac users to beat the exchange rate and purchase apps for less in the US app store (or vice versa, depending on currency fluctuations!). However, this technique means it’s possible for European Mac users to take a look at the US App Store to get information about certain apps that are released in the US first, before being made available elsewhere.







	Tip 215
	Avoid Cluttering Network Shares with .DS_store Files




If you access a network share with Windows computers, you might have heard your fellow users complain about small DS_store files that appear like breadcrumbs wherever you browse. These are Mac system files that contain data about the directory and are hidden when a Mac browses the folder. However, they’re not essential.

Deactivating the Writing of .DS_store Files on Networks

To configure your Mac so these files are not written to network shared folders, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.desktopservices DSDontWriteNetworkStores -bool TRUE​





Once you’re done, log out and back in again for the changes to take effect.

Reverting to Default

If you should ever want to reverse the fix in future (perhaps if you work in an office full of Macs, where it won’t be an issue), open a Terminal window and type the following:



	 
	
​defaults delete com.apple.desktopservices DSDontWriteNetworkStores​





Then log out and back in again.







	Tip 216
	Record Your Work at the Terminal




Ever wanted to save your work at the command line, perhaps for showing others? Just hit Command+S (or Shell→Export Text As) to save all the commands plus output as a text file (that is, everything you see by scrolling up and down to the top and bottom of the window, including any work from the previous session that usually appears grayed out).


Exploring OS X Lion: AppleScript


AppleScript is the Mac’s own programming language. Like everything else Mac, it’s designed to be intuitive and very easy to use. Making a dialog box appear is simply a matter of using the built-in AppleScript Editor (within the Utilities folder of Applications) to create an ApppleScript that reads display dialog. If you’d like to create an AppleScript that, when run, causes TextEdit to quit, you could type tell application "TextEdit" to quit. AppleScripts can be saved out as actual applications that will run just like any other. 

Although AppleScript quickly gets more complex than simple noun and verb combinations, the intention is that people without any programming experience can at least read an AppleScript and understand what’s happening, if not construct their own.

AppleScript is designed to pass information to and from applications, particularly those that are built into OS X, such as Finder (some third-party applications include AppleScript extensions, but not many). As such, AppleScript has strictly limited potential when it comes to creating apps from scratch and isn’t comparable to other user-friendly languages such as BASIC.  

The AppleScript Editor can be found in the Utilities folder of Applications within Finder. Apple hosts a beginner’s guide to AppleScript at http://developer.apple.com/library/mac/documentation/AppleScript/Conceptual/AppleScriptX/AppleScriptX.html, and several books have been written on the subject.











	Tip 217
	Access a Secret Minimize Visual Effect




You probably know that you can change the visual effect you see when you minimize a window by opening System Preferences (Apple menu→System Preferences), clicking the Dock icon, and selecting from the dropdown list next to Minimize Windows Using.

Activating the Suck

However, there’s a third effect not on the list: Suck. As its name suggests, this is rather like the window is being sucked into the Dock by a powerful vacuum cleaner!

To activate the effect, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock mineffect -string suck;killall Dock​





The changes will take effect immediately, so give it a try by minimizing a window. 

Reverting to Default Visual Effects

To restore things to normal, choose one of the two default minimize effects within System Preferences or open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock mineffect;killall Dock​











	Tip 218
	Right-Click with Two Fingers Better




Most Mac trackpads allow you to right-click by placing two fingers on the trackpad and clicking. However, it takes a little practice to get it right, and it can be very frustrating to right-click a web link to try and bring up the context menu, only to find it didn’t work and you’ve actually clicked the link!

After a lot of experimentation, I have discovered that two-finger clicking at the bottom of the trackpad rarely works well. Two-finger clicking in the middle or top tends to work better. Now that I’ve trained myself to do this, I rarely have any issues.

Or try this instead: bunch two fingers together, then use your thumb to click the trackpad at the bottom.







	Tip 219
	Convert a Series of Images into a PDF




Converting an image into a PDF file is as simple as opening it in Preview and clicking Print from the File menu. Then, in the dialog box that appears, click the PDF dropdown at the bottom left and select Save As PDF. 

To do the same for a whole series of images, open them in Preview by multiple-selecting them in Finder (that is, holding down Command or Shift and selecting more than one file), then drag them onto the Preview Dock icon. This will open the images in a drawer to the left of the window. Select all of them (click one of the thumbnail previews, then hit Command+A) and click File→Print. In the dialog box, click the PDF button before clicking the Save As PDF option.

 To avoid pictures being rotated, uncheck the Auto Rotate box in the Print dialog box.







	Tip 220
	Make Only One Program Window Visible at a Time




This is a tip for those who don’t find it easy to use computers (see also Tip 136, ​Make the Dock Display Only Running Programs​). This tip makes only the currently active application window(s) visible at any given moment. Any other program windows are automatically hidden. You can switch between open applications as usual using the Dock. 

Autohiding App Windows

To make this happen, open Terminal (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock single-app -bool TRUE;killall Dock​





The changes will take effect the next time you click the Dock icon. Click any Dock icon to hide all other program windows.  

Restoring Default Settings

To deactivate the effect at a later date, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock single-app;killall Dock​





You’ll need to click on the Dock icons of your apps to unhide them one by one.







	Tip 221
	Add the Trash to Finder’s Sidepane




You can click and drag just about anything to Finder’s sidebar (under the Favorites heading) to create a convenient shortcut with one exception: the Trash. It seems Apple doesn’t want a shortcut to the Trash to be created. However, the following steps, which involve creating a short and simple AppleScript, should do the trick: 


	
Start by opening the AppleScript Editor (Finder→Applications→Utilities→AppleScript Editor), then enter the following code into the main editing area of the program window:



	 
	
​on open​




	 
	
​tell application "Finder"​




	 
	
​move selection to trash​




	 
	
​end tell​




	 
	
​end open​







	
Check that the code is correct by clicking the Compile button on the AppleScript Editor’s toolbar. If you see an error, check that you’ve typed the code correctly. You’ll know if it’s correct because the AppleScript Editor will color your code and indent it for easier reading. 



	
Click File→Save As and, in the save dialog box, enter the filename Trash. In the File Format dropdown list, select Application. Opt to save it to your Documents folder or to another location where your new AppleScript can remain without the risk of being accidentally deleted. Then click the Save button. Quit AppleScript Editor. 



	
Navigate to where you saved the AppleScript using Finder. Click and drag the file to the sidebar of the Finder window anywhere under the Favorites heading. Hey, presto! You should now have a Trash icon in the Finder sidepane that will move files to the Trash when files are dragged on top of it.





Unfortunately, your homemade Trash shortcut isn’t a 100 percent clone of the Trash icon in the Dock. As you might have noticed, the icon is incorrect. Additionally, if you right-click it, you won’t be offered the option to empty the Trash. Emptying must be done via the Trash Dock icon. But other than these quibbles, the new icon should work in the way you’d expect. 

You can also (or alternatively) add the AppleScript to the Finder toolbar by dragging and dropping it there.

To delete the icon at a future date, hold down Command and drag it away from the Finder. Additionally, you should delete the AppleScript you created earlier.







	Tip 222
	Use Quick Look Inside Open/Save Dialog Boxes




If you’re opening or saving something and want to see what another file is, just select it within the Open/Save As dialog box and then hit Space to activate Quick Look, which works within dialog boxes in the same way it does in Finder windows or on the desktop.







	Tip 223
	Strip Out the Audio from a Movie File




Want the separate the audio from a movie clip so you can listen to it on your iPod or iPhone? Just open the clip in QuickTime Player, which is in the Applications list in Finder, then click File→Export and select Audio Only from the Format dropdown list (see Figure 35, ​Extracting the audio from a movie file​). This will create an m4a file compatible with all Apple devices and computers. Just import it into iTunes in the usual way, by double-clicking the new file.
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Figure 35. Extracting the audio from a movie file











	Tip 224
	Create PDFs and Save Automatically to a Folder




Macs are extremely PDF friendly, to the extent that you can output just about any document as a PDF: click File→Print in any application that outputs images or documents, and select the PDF dropdown button at the bottom left of the dialog box. 

If you regularly output PDFs to a particular folder, you might be annoyed that you have to navigate to the folder each time you want to save a PDF there. 

Luckily, there’s a simple solution that will add the folder as an option in the PDF dropdown list within Print dialog boxes. Selecting it will automatically create the PDF there.

Adding a PDF Store Folder

The steps are as follows:


	
Open a Finder window, hit Shift+Command+G, and type /Library/PDF Services.



	
Open a new Finder window (right-click the Finder icon in the Dock and select New Finder Window) and navigate to the folder where you normally save PDFs. Switch to Finder’s column view in the new window (Command+3).



	
Click and drag the folder where you save PDFs over to the Finder window that’s browsing /Library/PDF Services. However, hold down Option+Command before releasing the mouse button. This will create an alias rather than copying the folder. You’ll be prompted to type your password.



	
You can now close both windows.





From now on, you’ll find the folder as an option in the PDF dropdown list in Print dialog boxes, listed beneath the Add PDF to iTunes entry in the list. Just select it to automatically save a PDF file to the folder.

These steps can be repeated to add as many folder destinations as you’d like to the PDF dropdown menu.

Removing the Folder Link

To remove the folder at a later date, just repeat the steps above to browse to /Library/PDF Services and drag the alias of the folder to the Trash. Again, you’ll need to type your password when prompted.







	Tip 225
	Copy and Paste Without the Formatting




Like most modern operating systems, Mac OS X will retain text formatting when you copy and paste text from one place to another. For example, copying a paragraph of text from a website and then pasting it into a TextEdit document will mean it keeps the same font and point size.

There are several ways to avoid this, as follows:


	
In some apps, you can click the Paste→Paste and Match Style entry on the Edit menu.



	
In some apps, holding down Shift+Option+Command+V will paste without formatting—I usually hold down Option+Command with my thumb and hold down Shift with my pinkie before reaching across with my index finger to hit V.



	
In Microsoft Office applications, you can click Edit→Paste Special, and select Unformatted Text in the dialog box that appears. (in Word 20, click Edit→Paste and Match Formatting).



	
If nothing else works, try this: hit Command+Space to open Spotlight, then hit Command+V to paste the text. Quickly after this, hit Command+A to select all the text you’ve just pasted, and hit Command+X to copy it again. Then hit Command+Space to close the Spotlight window (or hit Esc twice). Finally, paste the text into your document, where you should find it’s been stripped of formatting.











	Tip 226
	Make Use of Boot-Time Options




By holding down various key combinations before the Apple logo first appears when booting, you can do things such as boot from a CD/DVD or switch to your Microsoft Windows Boot Camp installation. Here’s a table of key combinations—you can release the key once booting is underway and you see the boot progress indicator (the spinning circle beneath the Apple logo). Note that most of these shortcuts won’t work if you have FileVault enabled.




	
Keyboard shortcut


	
Description







	

Option



	
Switch between operating systems installed on your computer (that is, Mac or Windows) or access the rescue system. Also lets you choose to boot from an attached storage device, like a USB memory stick.





	

Shift



	
Boot into safe mode, in which your Mac starts with only strictly necessary kernel modules loaded and no startup programs. Ideal for repairing a damaged system that won’t boot any other way. 





	

C



	
Boot from CD or DVD.





	

N



	
Network boot (usually only useful in corporate environments).





	

T



	
Boot in Target Disk Mode,[16] in which case the operating system doesn’t load but the computer’s hard disk can be accessed from another computer via a FireWire connection.





	

X



	
Force Mac OS X to boot, even if the system can’t identify a Mac OS X hard disk (useful when things break).





	

Command+R



	
Boot to recovery mode—allows you to check the disk, restore from a Time Machine backup, and reinstall OS X.





	

Command+S



	
Boot to single-user mode of OS X (a command-line prompt, useful for making repairs).





	

Command+V



	
Boot in verbose mode, showing boot time messages rather than the Apple logo. Useful for diagnosing boot problems.





	
Eject button


	
Eject any inserted CD/DVD (holding the mouse button does the same thing).













	Tip 227
	Create Secure Notes




Your Mac provides no fewer than three independent and distinct methods of creating notes:


	
Using the Stickies app, found within the Applications view of Finder. This lets you “stick” notes to the desktop.



	
Using Mail—just click the New Note toolbar button. The benefits of using Mail’s Notes feature is that any notes created are automatically synced with iPhones and iPads. 



	
Using the Keychain Access utility. Here you can create notes that are encrypted and inaccessible unless your login password is entered.





Here’s how to use Keychain Access to create secure notes.

Creating Secure Notes

Start Keychain Access (Finder→Applications→Utilities→Keychain Access). To create a new secure note, click the entry on the File menu within Keychain Acccess or hit Command+Shift+N. A dropdown dialog box will appear. Type the name of the note in the Keychain Item Name field and the contents of the note beneath. Once the details have been filled in, click the Add button.

And that’s it. Your secure note has been created and resides encrypted on your hard disk. 

Accessing Secure Notes

To access your notes, start Keychain Access and click the Secure Notes entry under the Category filter list on the left of the Keychain Access program window, and then double-click your new note. In the dialog box that appears, put a check in the Show Note box and type your password when prompted, clicking the Allow button once you’re done. The text within the note will then be visible. 

Deleting Secure Notes

To delete the note at a future date, right-click it in the list and select the Delete entry on the menu that appears. 







	Tip 228
	Create a Quit All App




Ever wanted to quit every single open application? Perhaps you want to free up memory for the launch of another app.

You can create an app using AppleScript Editor that you can place in the Dock and that will quit all open apps when clicked. Here are the steps:


	
Start AppleScript Editor by double-clicking its entry in the Utilities folder of Applications in Finder. 



	
In the main code area, type the following:



	 
	
​tell application "System Events" to set quitapps to name of every​




	 
	
​        application process whose visible is true and name is not "Finder"​




	 
	
​repeat with closeall in quitapps​




	 
	
​quit application closeall​




	 
	
​end repeat​







	
Click the Compile button on the toolbar to check the code to ensure it’s correct. If it’s OK, the code will be colored and indented properly. If it’s incorrect, you’ll see an error message. Try typing the code again.



	
Click File→Save and choose to save the new app in your Applications folder. Call it something memorable—I chose “Quit Everything!” In the File Format dropdown list, choose Application.



	
Close AppleScript Editor and navigate to your Applications list within Finder. Then drag and drop your new app onto the Dock, ready for use.











	Tip 229
	Upgrade Your Computer’s RAM




Most Macs are designed so their memory can be easily upgraded by users, and OS X includes a utility that tells you what’s currently filling the RAM slots, as well as if any are free. It also provides a link to the manual on the Apple website that gives step-by-step instructions on how to upgrade.

To access this utility, click the Apple menu and click About This Mac. Then click the More Info button in the dialog box that appears, and in the new program window you see, click the Memory menu button. For an example, see Figure 36, ​Viewing free memory slots​.
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Figure 36. Viewing free memory slots











	Tip 230
	Start GUI Apps from the Command Line




Sometimes it’s necessary to start GUI apps from within a Terminal window. Here’s how that can be done.

Opening Finder

To start a Finder window displaying the location you’re currently browsing at the command prompt, just type the following:



	 
	
​open .​





That’s open followed by a period. Any path will work here, along with relative paths: open ../ opens the parent of the folder currently being browsed, for example, while open / will open a Finder window displaying the root of the filesystem.

Note that the Terminal window can now be closed without affecting the Finder window.

Opening Files

The open command could also be described as the command-line equivalent of double-clicking a file. Any file specified after the command will be opened in the application that saved it or in the default application for that type of file if the file has been downloaded (in other words, images will open in Preview and so on). 

You can also use the asterisk wildcard. Typing open *.jpg will open all the images within the current folder in Preview, for example. 

As previously, note that the Terminal window can be closed and the opened app will not be affected.

Starting Any App

You can also start applications as if you’d double-clicked their entry within the Applications list of Finder. Just use the open -a command, specifying the name of the application afterward. For example, to start TextEdit, type the following:



	 
	
​open -a TextEdit​





Applications that involve two words (like Google Chrome) need to be enclosed in quotation marks:



	 
	
​open -a "Google Chrome"​





You need to enter the name of the application as it appears in the Applications view of Finder.

To open a file with a specific application, just list it afterward. For example, to open textfile.txt in TextEdit, type the following:



	 
	
​open -a TextEdit testfile.txt​





Opening a Web Address in a Browser Window

To open a web address, specify it after open, but make sure you include the http:// prefix or you’ll see an error message:



	 
	
​open http://www.apple.com​





Creating a New Mail with a File Attached

Just type open -a Mail and then type the filename. For example, to create a new mail with the file Disneyland.jpg attached, I would type the following: 



	 
	
​open -a Mail Disneyland.jpg​











	Tip 231
	Quickly Create a Text Copy of Emails




If you use Mail,
you can simply click to highlight any message within the Inbox, hit Command+C, and then hit Command+V to paste the message contents into an editor such as TextEdit (pasting into Microsoft Word doesn’t work). 

By selecting multiple emails in the Inbox, then hitting Command+C, you can paste all of them into a new single document within TextEdit, and they will appear one after the other. 







	Tip 232
	Search Spotlight from a Terminal Window




This is a tip for those who like to use the command-line prompt. To perform a Spotlight search at the command line, use the mdfind command. For example, to search for any documents that contain the term macintosh, you could type the following:



	 
	
​mdfind macintosh​





The -onlyin command option will limit the search to a certain folder, which is useful if you want to find files that are within your Documents folder, for example. The following would search for files containing the term macintosh within your Downloads folder:



	 
	
​mdfind -onlyin ~/Downloads macintosh​





An interesting additional command option is -count, which will display how many files there are that contain your search term, for example: 
	



	 
	
​mdfind -count -onlyin ~/Downloads macintosh​











	Tip 233
	Enable the Root User




Those who have used Unix or Linux in the past might be used to the idea of a root user. This is a user with special powers who can do just about anything to the system without being challenged. It’s disabled on OS X for reasons of security, but if you just can’t do without it, you can enable it as follows.

Activating the Root Account

Open Finder, hit Shift+Command+G, and enter the following: /System/Library/CoreServices. In the file listing that appears, open the Directory Utility program. Click the lock icon at the bottom left to enable changes, if it isn’t already unlocked, and enter your password when prompted. 

Following this, click Edit→Enable Root User (see Figure 37, ​Enabling the root user login​). You’ll immediately be asked to enter a new password for the root user, which you’ll need to type again in the Verify field to confirm. 

The new account is created instantly.

Following this you’ll be able to switch to root user in the usual way at the command prompt by typing su -. It appeared to be impossible to log into a GUI desktop as root in my tests, which is just as well, bearing in mind that it would be extremely dangerous to do so.

Deactivating the Root Account

To deactivate the root user account at a future date, start Directory Utility again and click Edit→Disable Root User.
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Figure 37. Enabling the root user login











	Tip 234
	Wake Your Portable Mac When the Power’s Attached




This is a small time-saving tip of the type that makes your Mac a little easier to live with. Note that it changes a system setting, so it affects all users of the computer.

The following command, issued at the command-prompt (Finder→Applications→Utilities→Terminal), will cause your portable Mac to wake as soon as the MagSafe power cable is attached:



	 
	
​sudo pmset -a acwake 1​





Because this makes a system-wide hardware change, you’ll be prompted to enter your password.

Note that even though the system wakes on attaching the MagSafe, the screen might remain blank until you hit a key.

To revert back to the old way of working, where attaching the MagSafe does nothing other than quietly charge your Mac’s battery, type the following in a Terminal window:



	 
	
​sudo pmset -a acwake 0​











	Tip 235
	Pass Command-Line Output to GUI Apps




This is a tip for hardcore command-line fans who like a little graphical user-interface goodness in their lives.

Piping Output into Default GUI Apps

As mentioned elsewhere, you can use the open command at the command line to open files in GUI applications (Tip 230, ​Start GUI Apps from the Command Line​). The command open filename.txt will open filename.txt in TextEdit, for example.

However, the -f command-line switch will cause open to accept output piped from a command. For example, the following will pipe a detailed directory listing in a new document within TextEdit:



	 
	
​ls -la | open -f​





Piping Output into a Specific App

To choose an application other than the default, specify it using the -a switch. I have an alternative text editor called TextMate installed on my system,[17] for example, and the following pipes the directory listing to it:



	 
	
​ls -la | open -f -a TextMate​





Piping Output into the Clipboard

Instead of specifying the open command, you can pass the output of a command to the clipboard, ready for pasting into another app. Simply use the pbcopy command: 



	 
	
​ls -la | pbcopy​





Typing Directly into the Clipboard

Should you want to, you can type text directly into the clipboard by specifying the pbcopy command on its own and hitting Return. Type what you want to enter into the clipboard (you can include carriage returns), and hit Control+D when you’ve finished.

Typing Directly into the “Find” Clipboard

OS X uses a separate clipboard for what appears in find and replace boxes. So if you want to type something directly at the command line that you’d like to then search for within an app like TextEdit, you can use the following command—just replace “search phrase” with what you’d like to put in the clipboard:



	 
	
​echo search phrase | pbcopy -pboard find​





Then switch to an app like TextEdit and hit Command+F and you’ll find the text you typed waiting for you in the Find field.

This command could be used very effectively with the yank feature of BASH.

Inserting Clipboard Contents at the Command Line

It’s also possible to reverse the process described above and paste the contents of the clipboard onto the command line or into a file using the pbpaste command. For example, the following will redirect the clipboard contents—which can come from anywhere, such as Microsoft Word—into a new file:



	 
	
​pbpaste > textfile.txt​





Obviously, any formatting applied to the text is stripped out.

Again, you can add -pboard to output the find clipboard contents instead:



	 
	
​pbpaste -pboard find > textfile.txt​











	Tip 236
	Disable Some OS X Features




Across various releases of the Mac OS X operating system, the people behind it have added many new features. You might not use all of them. Some of them can be annoying, especially if you’re prone to accidentally hitting the wrong key (for example, activating Mission Control when you didn’t mean to).

Here’s a guide to switching off various features of OS X, along with instructions on how to turn them back on again should you change your mind at a later date.

Note that in terms of memory or computer performance, there’s nothing really to be gained from turning off operating system features on modern Macs. You should only turn off a feature simply to remove something that you don’t need and that obstructs your day-to-day use of the computer.

Turning Off Mission Control

It’s possible to deactivate Mission Control, but this will also make it impossible to switch desktop spaces (Dashboard excepted). Therefore, be sure to delete any desktop spaces before typing the command below (to delete a desktop space, switch to Mission Control, hold Option, and click the X at the corner of each desktop space).

Additionally, be aware that turning off Mission Control also deactivates the Show Desktop feature.

To turn off Mission Control, open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock mcx-expose-disabled -bool TRUE;killall Dock​





Note that this technique only disables the main “all windows” mode of Mission Control. App Exposé mode will still work, which arranges the open windows of the active program, although the only way of accessing it will be via task switching (see Tip 99, ​Be an Application Switcher Power User​). 

To enable Mission Control again at a later date, type the following:



	 
	
​defaults delete com.apple.dock mcx-expose-disabled;killall Dock​





Turning Off Dashboard

The Dashboard is the desktop space that features gadgets. My experience is that people either love this feature and use it all the time or they entirely ignore it. 

To kill the Dashboard, open a Terminal window and type the following:



	 
	
​defaults write com.apple.dashboard mcx-disabled -bool TRUE;killall Dock​





The changes will take place immediately.

To enable the Dashboard again at a later date, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dashboard mcx-disabled;killall Dock​





Disabling Spotlight

You can turn off Spotlight’s indexing, which can avoid disk churning and occasional system slowdowns, but it’s not possible to get rid of its desktop icon—this can be done only through very risky editing of system files, which I can’t condone. However, to turn off Spotlight indexing, open a Terminal window and type the following, entering your password when prompted: 



	 
	
​sudo mdutil -a -i off​





To enable it again at a future date, open Terminal and type the following, entering your password when prompted:



	 
	
​sudo mdutil -a -i on​





Clicking the icon when Spotlight is deactivated will still perform dictionary lookups and start applications, as described in Tip 111, ​Look Up Words Instantly​, and Tip 3, ​Start Apps Without the Mouse​. 


Exploring OS X Lion: Automator


Automator allows you to automate tasks that you do frequently or that involve repetitive actions. For example, you could create an workflow to automatically email a frequently-updated file to a particular group of people or to rename hundreds of images you’ve just downloaded from your digital camera.

Automator offers two ways of working, and both are based around workflows, chains of small, individual operations. Automator can either record what you do and turn these actions into a workflow, or you can manually construct a workflow from predefined actions. Note: At no point do you need any programming ability—Automator workflows are built around intuitive building blocks. 

A predefined action can be used on its own, or, more commonly, the user can feed output from one action into another for further processing. For example, to create a workflow that grabbed a series of images from a web page, several actions would be needed. The first grabs the web page address, the second uses that data to work out the image links, the third uses the image link data to prepare for download, while the fourth actually grabs the image based on this data.  

Recording a workflow is very different from manually creating a workflow from predefined actions and is akin to the Macro Recording feature you might have used in applications like Microsoft Office. A workflow recorded in this way might consist of items such as “Click Safari in the Dock,” followed by “Click the File Menu,” “Save Image As,” and “Click the Save Button.”  

Crucially, Automator workflows can be saved as applications that run when double-clicked or when a file is dropped onto their icon just like other apps. You can also save workflows as services and as folder actions.

You’ll find Automator in the Applications list within Finder.











	Tip 237
	Redefine Shortcuts to Use Option or Command




If you’re altering a keyboard shortcut and choosing from options in a dropdown list, pressing Shift, Control, Option, or Command while the dropdown list is open will show additional keyboard combinations involving those keys.

Using Key Combinations in Practice

For example, let’s say you want Mission Control to activate when you hit Command+F9 rather than when you simply hit F9. Open System Preferences (Apple menu→System Preferences) and click the Mission Control pane. Click the dropdown list next to Mission Control to redefine its keyboard shortcut. While the list is open, try pressing Shift, Control, Option, or Command—you’ll see that the shortcut changes accordingly. Selecting an entry in the list with one of the modifier keys pressed will switch it to that combination.

Using Multiple Key Combinations

You can combine keys as well—you can make Mission Control appear when Shift+Command+F9 is pressed, for example; just activate the dropdown list and press Shift+Command at the same time.







	Tip 238
	Copy the Font Style of Some Text




Let’s say you’re working on a complicated document in TextEdit and want to add a paragraph. However, you also want to copy the same font and style as a paragraph earlier in the document. Simply place your cursor within the older paragraph and hit Option+Command+C. Then place the cursor where you’d like to type and hit Option+Command+V. If you start typing, you should find it matches the font and style.







	Tip 239
	Use Gestures for App Exposé




Those with a multitouch trackpad might already have realized that it’s possible to activate an additional gesture that will start App Exposé mode for the current app. The setting can be found under the More Gestures tab within the Trackpad pane of System Preferences (Apple menu→System Preferences)—put a check next to App Exposé. 

Test the new setting by switching to an app and swiping down with three fingers. Swipe up again to return to the desktop.

However, there’s a hidden second way of starting App Exposé for any app using a gesture. If you position the mouse cursor over an icon in the dock and swipe down with three fingers, you’ll activate App Exposé for that particular app. Again, swipe back up to return to the desktop.







	Tip 240
	Change Alias Destinations




Most Mac users know an alias can be created for any file, folder, or application by clicking and dragging it to the new location and holding Option+Command before the mouse button is released. Aliases are akin to shortcuts under Windows.

Few people know that you can edit an alias to make it point to a different file. To do so, select the alias, hit Command+I, and in the info window that appears, click the Select New Original button. Note that the name of the alias won’t change to match the new file, but its icon preview will change if the alias now points to a different kind of file.







	Tip 241
	Jump Between Categories in Spotlight




When searching via Spotlight, you’ll usually see results categorized according to  what they are: files, dictionary definitions, website results, and so on. You can move up and down the list of results using the up/down cursor keys, but to quickly jump between the categories, hold down Command and hit the down or up arrow keys.







	Tip 242
	Re-create the Dock from Scratch




The following has never happened to me, but some people report it as a frequent annoyance: when dragging several files to a Dock stack, accidentally missing the target will result in all the files being added to the Dock. Because the Dock scales with size, this can make it unusable.

If deleting all the new icons seems like a little too much work, you can reset your Dock’s icons to the default state (that is, as if you’ve just booted your Mac from new) by deleting its configuration file. Open Finder, hit Shift+Command+G, and type ~/Library/Preferences. Then move the com.apple.dock.plist file to the Trash. Immediately log out and back in again.







	Tip 243
	Reorder Menu Bar Icons




The small icons next to the time display in the top right of the desktop are known as menulets. They’re usually arranged in the order in which they start. To reorder them at any time, just hold down Command and click and drag them. Ensure the other menulets slide out of the way to make space before releasing the mouse button, and be careful not to drag the icon off the menu bar before releasing the mouse button because that will remove the menulet. Note that it’s impossible to move the Spotlight search icon, which always remains in the top right corner of the screen, and several icons that belong to third party apps might also be immutable. 

You should be able to restore any missing icon by opening Finder, hitting Shift+Command+G, and typing /System/Library/CoreServices/Menu Extras; then double-click the menu file corresponding to the missing menulet. 







	Tip 244
	Wake Troublesome Macs




If you open the lid of your Mac and find that it’s having trouble waking up—perhaps it refuses to let you type your password, or perhaps the screen backlighting illuminates but the screen itself remains black—then simply close the lid for a minute or so and reopen. Often things will work properly the second time around. 

If after this the computer still refuses to wake, you’ll need to forcibly reboot your computer, which you can do by holding the power button down for five seconds. Once the computer has powered down, press the button again normally to boot.

If the wake-from-sleep problems continue, try resetting the PRAM—see Tip 81, ​Reset Your Mac’s Hardware Settings​.







	Tip 245
	Play April Fools’ Jokes on Mac-Using Friends




There’s a couple of things you can do to give the impression a Mac is somehow broken. They make excellent tricks to play on April Fools’ Day and are easily reversible.

Making the Dock Go Crazy

You can alter a setting so that the Dock icons expand almost to fill the screen when the mouse is run over them. First, make sure that Dock magnification is enabled in the Dock pane of System Preferences (Apple menu→System Preferences), then open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following: 



	 
	
​defaults write com.apple.dock largesize -float 512;killall Dock​





The changes will take effect immediately.

To reverse the change, simply open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock largesize;killall Dock​





If it’s hard to activate the Terminal because of the Dock icon sizes, use Spotlight to start it—see Tip 3, ​Start Apps Without the Mouse​.
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Figure 38. Causing a window to appear to get stuck





Stalling a Window While Minimizing

This trick will cause a window to appear to get stuck while it’s minimizing.

Open a Terminal window and type the following, but don’t hit Return after typing:



	 
	
​killall Dock​





Now minimize a window in the usual way by clicking the yellow lozenge in the top left corner, but hold down Shift. The window will minimize in slow motion (see Tip 209, ​See OS X Animations in Slow Motion​). Quickly switch to the Terminal window and hit Return to complete the command you typed earlier. 

The minimizing window will appear to get stuck on its way to the Dock but—amazingly—the window will still work fine. You’ll be able to scroll up and down. For an example, see Figure 38, ​Causing a window to appear to get stuck​.

Although it looks serious, what you’re seeing is just a glitch. It can be cleared easily by clicking the minimize button again on the window and then maximizing it again. 

Ramping Up the Weather

This trick is only good if your victim uses the weather widget within Dashboard. By holding down Option+Command and clicking anywhere on the widget, you can cycle through all the weather possibilities the applet can show—from brilliant sunshine to heavy snow. Alas, the place name switches to Nowhere in order to indicate that a test mode for the widget has been activated. However, this in itself might cause some entertaining confusion!

The widget returns to normal again once you switch away from the Dashboard.







	Tip 246
	See the True Size of an Image




You can change a setting within Preview that, when you opt to view an image at the Actual Size setting (View→Actual Size), will mirror the physical dimensions the image will print at when outputted at native resolution (that is, if it’s not scaled). In other words, if you held the printed page up next to a picture viewed at Actual Size, the two will be identical. 

Usually an onscreen image appears smaller than it looks when printed, even when viewed at the 00 percent zoom setting.

To make the change, start Preview (it’s in the Applications list of Finder) and click the application menu, then Preferences. Then click the Images tab and click the radio button next to Size on Screen Equals Size on Printout.







	Tip 247
	Convert Audio and Video Files to Different Formats




OS X makes it easy to switch audio or video files to different formats within Finder.

Transcoding Audio

If you’ve got an AIFF or WAV audio file that you’d like to convert to iTunes’ native MP4 audio format, which usually has the m4a file extension, just right-click it and select Encode Selected Audio Files (you might have to click Services→Encode Selected Audio files). Then select the format you’d like from the Encoder dropdown list. Arguably the High-Quality option in the list is fine for most needs—this will match the quality of the majority of MP3 files currently available. Once you’re done, click the Continue button to start the encoding. The new file will be outputted alongside the old one.

Downsampling Video

Want to shrink a 1080p or 720p movie to a smaller frame size? Right-click it and select Encode Selected Video files (you might have to click Services→Encode Selected Video Files). Then choose the settings you want from the dialog box that appears and click the Continue button to convert the file. Note that it’s not possible to upsample a file; that is, you can’t convert a 480p movie to 720p, for example. You can only downsample movies—converting a 1080p movie to 480p, for example. 







	Tip 248
	Extend Quick Look’s Knowledge of Files





http://qlplugins.com has a range of plugins that allow Quick Look—the window that appears when you select a file and hit Space to preview it—to view all kinds of additional files not typically understood by Macs. Other plugins available at this site replace existing Mac plugins, such as one that allows you to view pictures alongside all the technical information about them (known as EXIF data). Some plugins are free of charge, while others must be paid for.

Most of the plugins come with installers, but some you’ll need to place in the /Library/QuickLook folder manually (hit Shift+Command+G in a Finder window and type the path above to browse straight to the folder). The plugin should work instantly, but if not you can always force the system to update by opening a Terminal window (Finder→Applications→Utilities→Terminal) and typing qlmanage -r.

To remove the plugin at a later date, simply visit the /Library/QuickLook folder and delete it. 







	Tip 249
	Instantly Google Highlighted Text




Highlight some text in (almost) any application, tap Shift+Command+L, and Safari will automatically Google the text for you—even if it’s not already open! This should work in any app that hasn’t defined the Shift+Command+L keyboard shortcut for another function. 







	Tip 250
	Use a Different Animation with Dock Stacks




This is a subtle tip but worth a try for those who truly like to personalize their Mac experience!

When a stack is set to Grid view, the folders appear to pop out with a particular animated effect. You can change this to an alternative that is arguably smoother and prettier. 

First ensure you know what the existing effect looks like by right-clicking one of your Dock stacks and selecting Grid from the menu under the heading that reads View Content As. Expand and contract the stack a few times by clicking the stack icon.

Then open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock use-old-grid-animation -bool TRUE;killall Dock​





The changes take effect immediately, so try clicking the stack again to see the change. You should find that the pop-out window rises more and doesn’t fade into view, as it did previously.

If you decide to revert to the previous pop-out effect, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock use-old-grid-animation;killall Dock​











	Tip 251
	Use a Secret Gesture to Switch to the Previous Space




There’s a secret gesture you can use with Mac multitouch trackpads that lets you double-tap with four fingers to switch back to the most recently used desktop space. For example, should you switch to the Dashboard space from the main desktop, double-tapping in this way will switch back to the desktop. Note that this gesture involves merely tapping on the trackpad, and not clicking. This remains true even if you have Tap to Click turned off in System Preferences.

To activate the gesture, you’ll need to use a hidden setting. Open a Terminal window (Finder→Applications→Utilities→Terminal) and type the following:



	 
	
​defaults write com.apple.dock double-tap-jump-back -bool TRUE;killall Dock​





The changes should take effect right away, so give it a try. Like all gestures, it takes a little practice. Note that it appears that after a minute or two, OS X “forgets” the previous desktop space, so double-tapping to switch a space will no longer work. 

To turn off this new gesture, open a Terminal window and type the following:



	 
	
​defaults delete com.apple.dock double-tap-jump-back;killall Dock​











	Tip 252
	Find Out Where a File Was Downloaded From




Want to know where you downloaded a file from? Just select it on the desktop or within a Finder window, hit Command+I to open the Info dialog box, and look under the Where From heading.







	Tip 253
	Make a Message Window Appear at Login




When Macs are used in public places, such as schools, it’s often necessary to ask users to agree to an acceptable use statement before they start using the computer. Adding one of these to a Mac is very easy to do, but that’s not all this trick can be used for. You could also add messages to remind yourself of something or even add a document that you can read at leisure without having to first log into your computer. 

Adding a Logon Message

Here are the steps required to add a logon message:


	
Create a document with TextEdit, which you’ll find in the Applications list in Finder, and save it as a rich text or plain text file. Note that only rich text files will retain formatting, such as colors or bold text. Make sure you use system-wide fonts rather than any fonts  installed specifically for your user account (this won’t be an issue if you’ve never manually installed fonts, but be careful not to use any Microsoft Office fonts like Candara or Cambria).



	
Save the file to the desktop, giving it the name PolicyBanner.rtf or PolicyBanner.txt, depending on whether it’s rich text format or plain text. 



	
Open a Finder window and hit Shift+Command+G. In the dialog box that appears, type /Library/Security.



	
Click and drag the PolicyBanner file you created to the Finder window. A dialog box will appear, asking you to authenticate, which you’ll need to do, so hit the relevant button and type your login password when prompted.





From now on, you’ll see the document appear in a window when you log in. Clicking the Accept button will clear it, after which you’ll see the standard login options. If your disk is encrypted with FileVault, you’ll see the document whenever you turn on your computer or reboot.

Removing the Logon Message

To permanently eradicate this new addition to the login screen, again just browse to /Library/Security and move the PolicyBanner.rtf or PolicyBanner.txt file to the Trash. You’ll be asked to authenticate again. 







	Tip 254
	Start Time Machine at the Command Line




About to do something risky with a file at the command line? Here’s how to get some Time Machine goodness from the Terminal.

Taking a Backup Snapshot

Assuming your Mac has local snapshots enabled (see Tip 67, ​Make a Time Machine Backup When No Disk Is Attached​), you can force Time Machine to take a snapshot of the system using the following command:



	 
	
​tmutil snapshot​





Remember: This only creates a local backup on your hard disk.

Making a Full Backup

To force a full backup to take place, which involves writing files to the Time Machine disk (the equivalent of clicking the Time Machine icon at the top right of the desktop and clicking Back Up Now), type the following:



	 
	
​tmutil startbackup​





You can also stop the backup if you wish (perhaps if it’s taking too long) with the following command:



	 
	
​tmutil stopbackup​





Deactivating Time Machine

If for any reason you want to switch off Time Machine from the command line (the equivalent of clicking the on/off switch within System Preferences), you can use the following command:



	 
	
​sudo tmutil disable​





You’ll need to type your login password when prompted. The following will enable Time Machine again:



	 
	
​sudo tmutil enable​











	Tip 255
	Repair Disk Problems




Unlike Windows computers, OS X generally takes care of its disk invisibly and requires little user intervention. You’ll never need to defragment an OS X hard disk, for example. However, there are two things you might choose to do periodically in order to ensure the smooth running of your computer. The first is to repair permissions, and the second is to repair the directory and file structure. Some people habitually do both after a major update has been applied to the system.

Repairing Disk Permissions

To repair disk permissions, start Disk Utility, which can be found in the Utilities folder within the Applications list of Finder. In the Disk Utility program window, select the partition on which OS X is installed—usually it’s the indented second entry in the list of disks at the top left of the Disk Utility window. Then make sure the First Aid tab is selected. Now click the Repair Disk Permissions button. The process usually takes about five to ten minutes to complete. For an example, see Figure 39, ​Repairing permissions for a smooth-running computer​.
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Figure 39. Repairing permissions for a smooth-running computer





Repairing the Disk

Although you might see the Repair Disk button in the same program window, don’t click it. In fact it’s impossible to repair the disk while OS X is up and running. Instead you must boot to the recovery system—reboot the computer, then press and hold Command+R just before the boot-time Apple logo appears. Release it when the recovery screen appears and select the Disk Utility option. As for repairing the disk, select the OS X partition and click the First Aid tab, but this time click the Repair Disk button. Again, the repair will take a few minutes to complete.







	Tip 256
	Tear Off Tabs




Some OS X apps, such as Safari and Terminal, make use of tabs. The standard keyboard shortcut in such apps to create a tab is Command+Tab. In most cases the tabs can be “torn off” to create a new program window containing just that tab—just click and hold the tab, drag down, then position the new window where you want before releasing the mouse button.







	Tip 257
	Move a Time Machine Backup to a Larger Disk




If you use Time Machine, you might find the backup disk beginning to get full. You’ll know this because OS X will start to warn you that it’s deleting old backups to make space. The solution is to buy a bigger disk. Migrating your Time Machine backups to the new disk is easy. Here’s how. (These tips assume the disk is new and blank.)


	
Attach the new backup disk directly to your computer’s port, rather than via a hub, to make the whole process of swapping backup disks much faster. Try to have a free USB/Firewire port on your computer ready for attaching to the old backup disk (although you shouldn’t do so at this stage).



	
You’ll need to partition and format the new disk in a Mac-compatible way. Many commercial hard disks are preformatted for Windows, which your Mac can work with in normal circumstances, but Windows formatting isn’t compatible with Time Machine. Start Disk Utility. This can be found in the Utilities folder of the Applications list in Finder. 



	
In the Disk Utility window, select the new disk on the left side of the window (select the main entry for the disk and not the indented entry beneath that shows the partition). Ensure you select the new disk and not the old one, or you could accidentally wipe your old Time Machine data!



	
Click the Partition tab within Disk Utility. Then, in the dropdown list beneath Partition Layout, select 1 Partition.



	
Give the disk a name in the relevant field (something like New Time Machine would be great), then make sure the Format dropdown reads Mac OS Extended (Journaled).



	
Click the Options button. In the dialog box that appears, click the GUID Partition Table entry and click OK. Finally, click the Apply button to partition the disk ready for use. This process might take a minute or two—watch the progress display at the bottom of the Disk Utility window.



	
Once it’s finished, close Disk Utility and open Finder. Locate the new disk in the list in the sidepane. Select it and hit Command+I.



	
In the dialog box that appears, look at the very bottom. Expand out Shared & Permissions and ensure there’s not a check next to Ignore Ownerships on This Volume. If the box is checked, click the padlock icon to unlock the dialog, enter your password when prompted, then click to remove the check. Close the info window when you’re done.



	
Attach the old Time Machine disk, ideally in its own USB/Firewire port on your computer rather than via a USB/Firewire hub. This will make the cloning process much faster. Then open System Preferences (Apple menu→System Preferences) and click the Time Machine entry. Temporarily turn off Time Machine by clicking the switch. 



	
Open a Finder window and locate your old Time Machine disk under the Devices heading in the sidepane. Browse the contents of the disk and click and drag the Backups.backupd folder to the new Time Machine disk. This will copy across the backup files and will probably take some time to complete. Remember that while this is happening you aren’t protected by Time Machine backups, so it might be wise to avoid working on the computer for this period.



	
Once the copy has finished, eject and remove the old Time Machine disk. Again activate System Preferences and click the Time Machine icon. Click the Select Disk button and then select your new Time Machine disk. Then click the Use for Backup button.



	
Reactivate Time Machine by clicking the slider control. 





And that’s all that’s required. Check that your new Time Machine disk works by entering Time Machine in the usual way and browsing back through your file history. If everything is OK, then it’s a wise idea to repartition and reformat the old disk as described in the steps. If you don’t, each time you attach it to your computer you’ll be asked if you want to use it with Time Machine.

If you find there’s an issue with the new Time Machine disk, simply turn off Time Machine, eject the new disk, and reattach the old disk before repeating the steps to designate the old disk for use with Time Machine.







	Tip 258
	View an Email Without Its Formatting




Ever been sent an email that’s got all kinds of crazy text formatting in it, such as replies from others that are in a font size too small to read (or too big)? Just hit Option+Command+P to switch the email currently being viewed to a plain text rendition, sans any kind of formatting. 

This is only temporary, however. Just select another email in your email list, then select the original email again to view it with its formatting intact.







	Tip 259
	Expand Spotlight’s Knowledge of Files




Put simply, Spotlight will only index the content of files it understands, with a bias toward everyday files such as office documents. If you regularly use a different kind of file created by a specialist application, then you might find Spotlight won’t index it. 

The solution is to find a Spotlight plugin that does so. You’ll find many online or at some download sites,[18] but you might also simply Google for the name of the program that generates the file, adding the text “spotlight plugin” to the search query. 

Installing Plugins

In most cases, installation of the plugin should be just like any other program, so you’ll need to run an installer. In some cases, however, you might simply download a file with an mdimporter file extension, in which case the file will need to be manually copied to the ~/Library/Spotlight directory (open a Finder window and hit Shift+Command+G, then type in the directory to visit the folder). If the Spotlight folder doesn’t already exist, you’ll have to create it.

Then open a Terminal window (Finder→Applications→Utilities→Terminal) and type mdimport -r, followed by the full path and location of the new plugin. This will install it. For example, I downloaded a Spotlight plugin called Tarimporter,[19] which lets Spotlight index the contents of tar archives.[20] After creating a Spotlight filter in my Library folder—because it didn’t already exist—and then copying the plugin there, I typed the following to install it:



	 
	
​mdimport -r ~/Library/Spotlight/tarimporter.mdimporter/​





Note the trailing slash, because mdimporter files are actually package bundles, and they appear at the command prompt in their true form as folders.

Uninstalling Plugins

To uninstall a Spotlight plugin, simply delete it from the ~/Library/Spotlight directory and then log out and back in again, or see the plugin’s home page for instructions on how to uninstall it.







	Tip 260
	Diagnose Network Problems




The Network Utility app in the Utilities folder of Applications within Finder offers a GUI way of accessing traditional network diagnostic tools, such as Ping, Traceroute, and Port Scan. In most cases you simply type the network address of the computer or device you’d like to probe into the relevant field, and the results are displayed beneath. See Figure 40, ​Using popular network tools from within OS X​.
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Figure 40. Using popular network tools from within OS X





If you simply want to diagnose your own computer’s connectivity problems, try the Network Diagnostics tool—open a Finder window, then hit Shift+Command+G and type /System/Library/CoreServices into the dialog box that appears. Double-click the Network Diagnostics program icon and follow the wizard.







	Tip 261
	Speed Up Making SSH/SFTP/FTP Connections




If you regularly create command-line connections to remote computers, you can speed up the process by creating bookmarks for the computers within Terminal.

Setting Up

This requires Terminal be added to the Dock, so do so by clicking and dragging it there from the Utilities folder within the Applications view of Finder. Start Terminal, then right-click its icon and select New Remote Connection in the menu that appears.

In the window that appears, select the type of connection you’d like to create (that is, SSH, SFTP, FTP, or Telnet), then click the plus button under the Server list and type the fully qualified domain name (FQDN) or IP address of the remote computer in the dialog box that appears. Then click OK to save the new bookmark. Then to test it, select it from under the Server heading and click Connect to open a new Terminal window that, when it’s connected, will prompt you for your username and password in the usual way (you can speed up the procedure a little by typing your username into the User field of the aforementioned dialog box). 

Making Connections

The bookmark is now stored. To make the connection in future, start Terminal if it’s not already running, then right-click it and again select New Remote Connection. Then in the window that appears, select the bookmark you created and click the Connect button.

Many different server bookmarks can be defined in this way. 







	Tip 262
	Add Your Signature to Docs Using Preview




Preview is OS X’s general purpose image and PDF viewer, but recent versions have brought substantial PDF annotating capacities similar to Adobe Acrobat (open a PDF file and click Tools→Annotate). OS X Lion includes the ability to add your written signature to PDF files, provided your computer has an iSight/FaceTime HD camera or an attached webcam. 
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Figure 41. Adding a written signature to a PDF file





Putting a Signature on File

Here are the steps required to add your signature to Preview.


	
Start by grabbing a white piece of paper and signing your name with a black pen, ideally one with a thicker rather than a thinner nib. Don’t use lined paper or paper with a margin—it must be entirely white. If possible, don’t underline your signature or add any other kind of flourish—this can confuse the scanner tool.  



	
Start Preview (it’s in the Applications list in Finder) and click the application menu, then Preferences (or hit Command+,). 



	
In the dialog box that appears, click the Signatures icon. Then click the Create Signature button.



	
You’ll see a preview of what the camera sees (see Figure 41, ​Adding a written signature to a PDF file​). Hold the written signature you created so that it rests on the blue line in the middle of the preview. You’ll see various snapshots of the signature appear on the right of the window. When you see one you’re happy with, click the Accept button. Then close the Preferences dialog box.





Inserting the Signature

Once the signature is stored on file, inserting it each time you need to is easy.


	
Make sure the PDF into which you want to insert the signature is open. Click View→Show Annotations Toolbar. Then click the signature button on the annotations toolbar that appears—it’s eighth from the left.



	
The cursor will change to a crosshair; click anywhere to insert your signature. Click and drag the handles at the corners to resize it if necessary.





To insert the signature in future, click the signature icon on the annotations toolbar again. Then click to insert it into the document. 

You can add several signatures in this way. Clicking the program menu, then Preferences, then the Signatures icon will let you delete stored signatures—select it in the list and click the minus icon at the bottom left. 







	Tip 263
	Speed Up Mail




If you find Mail has slowed a little, try rebuilding its message index databases. Just click Mailbox→Rebuild. Depending on how many messages you have, it might take some time to complete (look for the spinning icon next to each mailbox name), but it takes place in the background and Mail is still completely usable while rebuilding takes place. You can even quit and restart the program and it’ll just pick up rebuilding where it left off.







	Tip 264
	Make Apps Maximize to Fill the Desktop




Former Windows users might be mystified by OS X’s maximize button (the green blob at the top left of program windows next to the red close and yellow minimize buttons). Rather than filling the desktop with the program window, it simply increases the program window’s size to try and make its contents fit better. Sometimes it’s successful, but often it isn’t.

In fact, OS X can maximize program windows just like Windows can. Hold Shift while clicking the green blob. Hey, presto! The window will fill the available desktop space, regardless of the window’s contents. To restore to the original dimensions, just click the green blob again—no need to hold Shift this time.  







	Tip 265
	Search for System Files




OS X works hard to keep users separate from system files, and this can make tracking down files outside of your Users folder tricky. However, here are two ways to do so.

Using Spotlight

In terms of files, Spotlight searches only those in your personal User folder. This is very limiting, especially if you’re used to the more wide-ranging search tools of other operating systems that can be used to track down system files too.

There’s no way to make the main Spotlight tool search for system files, but you can use Finder’s Spotlight search tool to uncover them. Here’s how.


	
Hit Option+Command+Space to reveal the Finder Spotlight window, no matter which app you’re currently using (if that key combination doesn’t work, try Control+Option+Space).



	
Click the plus button next to the Save button. This will add a new filter for the search. Click the Kind dropdown list and select Other.



	
In the list that appears, put a check next to System Files. Back in the Finder window, change the dropdown list next to System Files so that it reads Are Included.



	
Finally, type your search query into the Spotlight field at the top right of the Finder window and ensure This Mac is selected alongside the Search heading. After a few seconds, you should start seeing the results, which will include system files.



	
If you click the Save button, located just beneath the search field, you can add the system file search to the sidebar of Finder, to be used again (just select it each time and type the search query as described earlier). Otherwise, you’ll have to repeat these steps each time you want to search for a system file.





Using the Locate Command

As a version of Unix, OS X comes complete with the locate command, which can be used at the command line to track down any kind of file—a system file or a user data file. locate relies on a database of file locations and names that are periodically and automatically updated (as such, unlike Spotlight, locate only knows the names of files and doesn’t index their contents). 

However, locate isn’t activated by default. You can do so by opening a Terminal window (Finder→Applications→Utilities→Terminal) and typing the following, entering your login password when prompted: 



	 
	
​sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.locate.plist​





This need only be done once.

To use locate in future, just specify the search query after typing locate -i. For example, to search for the location of the hosts file, you could type the following:



	 
	
​locate -i hosts​





The -i flag tells locate to ignore case sensitivity.

To deactivate locate, type the following, which will deactivate the periodic updating of the locate database:



	 
	
​sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.locate.plist​











	Tip 266
	Set the Default Operating System




If you’ve got Microsoft Windows installed on your Mac alongside OS X, you might always want to boot to it rather than to OS X. Holding down Option when booting will offer a choice of operating systems, but to make Windows the default boot-time choice on your computer, open System Preferences (Apple menu→System Preferences), click the Startup Disk icon, and select the Windows option in the listing. Then hit Restart to restart your computer and make the change permanent.

To revert to OS X being the default boot-time choice, boot to your Mac installation and repeat the steps above, this time selecting the Mac hard disk in the list before clicking the Restart button.







	Tip 267
	Dump a Snapshot of What Your Mac Is Doing




There might be certain situations where you need a snapshot of what your computer is doing. For example, if you spot a bug in a program, the developer might need to know what your computer is doing when the bug occurs. 

Your Mac includes a tool that can do this. sysdiagnose will dump all technical information about your computer’s state and configuration into a series of files. You can use it at the command line by simply typing it or holding down Shift+Control+Option+Command+. (period). If you choose to use the key combination, it’ll take about a minute to complete, although there will be no sign of its progress. Eventually a Finder window will open that shows the data that’s been gathered. This is stored in /private/var/tmp. 

Be aware that some personal data is included in the dump, including the serial number of your computer, the computer name, and your username. Don’t hand over the sysdiagnose data to somebody you don’t trust.







	Tip 268
	Use Relative Paths in Open/Save Dialog Boxes




Here’s a quick trick for those who like to work at the command prompt and who don’t like to take their hands off the keyboard.

Hitting / (forward slash) in a File Open or File Save dialog box will bring up a Go to the Folder dialog box. Here you can type the path of any folder to go straight there (/Users/keir/Documents, for example). However, the Go to the Folder dialog box also understands relative paths. If you’d like to switch to the parent folder of the one you’re currently browsing, type ../. You can also navigate several folders up the file tree from your current position: Documents/Q4 reports/graphics/, for example.

Just like at the command line, you can hit Tab to autocomplete path names in the Go to the Folder dialog box.







	Tip 269
	Cancel Dialog Boxes Instantly




One of the oldest Mac keyboard shortcuts is Command+. (period), which on very old Macs was used to cancel the current task. In OS X it was deprecated but still lingers when it comes to dialog boxes—hitting Command+. will click the Cancel button for you, saving you the bother of reaching for your mouse. 







	Tip 270
	Search for Carriage Returns and Tabs




Holding Option while hitting Tab or Return within a Find or Find and Replace dialog box in most OS X apps will insert an “invisible” tab or carriage return character, allowing you to search for tabs and carriage returns within the document. Such invisibles can be combined with any other search term.







	Tip 271
	Work Better in Sunlight




If you have a portable Mac, you might know how difficult it can be to see the screen in very bright and sunny conditions—even with the screen illumination turned up full. One solution is to invert the screen colors, so that any text becomes white against a black background. To do this, hit Control+Option+Command+8. Hit the key combination again to revert things back to normal. It’s not a perfect solution, but it can be a lifesaver.







	Tip 272
	Whiz Around Save As Dialogs




Here’s a series of small keyboard combinations that, if you can remember them, can save a little time when saving files. Some work in File Open dialog boxes, too.

If you’ve just opened a Save As dialog box and are typing the filename, hitting Control+A will move you to the beginning of the line. Control+E will move you to the end. Control+K will delete everything from the cursor to the end of the line.

Hitting Command+D will switch you instantly to the Desktop folder. 

Holding Command and then 1, 2,  3, and 4 in expanded dialog boxes will switch between Icon, List, Column, and Cover Flow views of files.







	Tip 273
	Quickly Adjust Preferences for Any App




Hitting Command+, (that’s the comma key) will open the Preferences dialog box for the app you’re currently using.







	Tip 274
	See Bigger Thumbnails of Wallpapers




Choosing a new wallpaper in the Desktop & Screen Saver pane of System Preferences? If your Mac has a multitouch trackpad, place the mouse cursor over the thumbnail previews of the wallpapers and use the pinch-and-expand gesture to make the thumbnails larger and smaller. 







	Tip 275
	Switch Tabs Quickly




In an app that uses tabs, like Safari, you can switch between tabs by holding Control and tapping Tab. Add in Shift also to move left in the tab selection. Note that this won’t work in Terminal, because the Control key is used at the command line for other functions.







	Tip 276
	Browse Old Time Machine Disks




If you’ve got an old Time Machine disk from another Mac (or from a previous installation of OS X), you can browse its contents easily and restore files. Here’s how:


	
If you have an existing Time Machine disk for your current Mac, make sure no backup is currently running (look at the indicator icon at the top right of the screen), then eject it within Finder. This will avoid confusion later on.



	
Create a folder in a convenient location to contain the files you’re about to restore.



	
Attach the old backup disk and select not to use it for backup in any dialog box that pops up.



	
Hold down Option before clicking the Time Machine icon at the top right of the screen. Then select Browse Other Backup Disks on the menu that appears and, in the dialog box you see next, select the old backup disk and click Use Selected Disk.



	
You’ll now see the standard Time Machine display and should be able to step back in time to browse the backups. Note that backups are colored purple in the timeline against the right of the screen. If you see any gray entries, they’re likely local snapshots of your own computer made recently, so you can ignore them.



	
Once you’ve found a file or folder you want to restore, right-click it and select Restore To. Then, when you’ve returned the desktop, select a destination to save it to. Repeat this process until you’ve recovered all the files you want. Remember that you can hold Shift and Command in the usual way to select multiple files and folders to restore.



	
Once you’re done, eject the old backup disk and reattach your existing Time Machine disk, if you have one. 











	Tip 277
	Explore Within a Website Using Safari




Ever visited a new website via a link and wanted to explore the site to see what else it has to offer? A quick way of navigating to the site’s home page in Safari is to right-click the page title in the menu bar. This will show the website address truncated in various ways, all the way back to the base URL. Just click the version of the shortened URL that you’re interested in. For an example, see Figure 42, ​Quickly navigating to a site’s homepage in Safari​.
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Figure 42. Quickly navigating to a site’s homepage in Safari











	Tip 278
	Grab Files from Your Mac While Miles Away




While the Back to My Mac service offered by OS X Lion’s iCloud service lets you access files remotely (see ​Exploring OS X Lion: iCloud​), there’s also a DIY way of accessing files when you’re not in the same building as your computer.

OS X features SSH, software that allows command-line logins from remote computers across a network or the Internet. A component of this software is SFTP, which is essentially a secure version of FTP (File Transfer Protocol), which you might have encountered if you’ve ever created a website. SFTP lets you retrieve and transfer files from a computer without the risk of snoops.

Starting the SSH Service

SSH can be enabled by starting System Preferences (Apple menu→System Preferences) and then opening the Sharing pane. Put a check in the Remote Login box in the list on the left. On the right you can allow either all of the users on the system to log in remotely or just some (although this is moot if you’re the only user of your system).

Connecting via SFTP

You can use SFTP from the command line of another computer if it has the correct software, but most graphical FTP clients include SFTP support.

Remember that you’ll also need to ensure your Internet router
	hardware allows SFTP connections. This can be done within its configuration panels. There is no need to deactivate or alter any setting of the OS X firewall—it is automatically opened to allow incoming SSH/SFTP connections.

Configuring FTP

For what it’s worth, OS X includes a standard FTP server that you can enable by typing the following:



	 
	
​sudo -s launchctl load -w /System/Library/LaunchDaemons/ftp.plist​





This will run in the background as a service and there will be no sign it’s running. It will persist across reboots. To permanently deactivate FTP, type the following:



	 
	
​sudo -s launchctl unload -w /System/Library/LaunchDaemons/ftp.plist​





However, bear in mind that every security expert agrees that FTP is too unsecure to use, especially when SFTP is available, which in terms of features is virtually indistinguishable yet is encrypted throughout.







	Tip 279
	Move Back and Forward in Apps 




Along with clicking the back and forward buttons in Finder (and other apps that have such buttons, such as System Preferences and App Store), there are two other ways to move back and forward in your history:


	
Hold down Command, then hit [ or ] to move backward and forward, respectively;



	
if your Mac has a multitouch trackpad, you can hold down Option and swipe three fingers left or right on the trackpad.





This might also work in apps that don’t obey the standard back/forward gestures (that is, swiping two fingers left/right on the trackpad). 







	Tip 280
	Play Games




Got on a flight, intending to work for the journey, but found your mind just isn’t cooperating? A handful of very simple games are included in OS X as part of the Emacs command-line text editor. To play Tetris, open a Terminal window (Finder→Applications→Utilities→Terminal), type emacs, then hold down Esc and hit X. Then type tetris. Use the left/right cursor keys to move the blocks and the up cursor key to rotate them. Hit Q to quit the game, then Control+X followed by Control+C to quit Emacs.

Other games to try—specify them instead of tetris, as above—include pong, solitaire, snake, gomoku, and dunnet (a text adventure game). To see the full game list at the command-prompt, type ls /usr/share/emacs/22.1/lisp/play—the name to type in Emacs is the filename for each game but without the file extensions.







	Tip 281
	See What Disk Space Is Taken Up by Media




OS X’s About This Mac application can show in a crude way how much of your hard disk is taken up by music, movies, photos, apps, and backups (that is, Time Machine snapshots—see Tip 67, ​Make a Time Machine Backup When No Disk Is Attached​). Additionally, if there is any external storage devices attached, you’ll see the same information for those.

To access it, click the Apple menu and select About This Mac. Then in the window that appears, click More Info. In the new program window, click the Storage menu button. For an example, see Figure 43, ​Seeing at a glance what kind of files fill your hard disk​. 
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Figure 43. Seeing at a glance what kind of files fill your hard disk











	Tip 282
	Run X11 Apps Full Screen




If you regularly use any X1 apps, such as the Gimp image editor,[21] then you might be used to the confusion of each X1 app utilizing its own menu bar. A way to make X1 apps easier to work with is to integrate X11 with Mission Control’s spaces and to run X1 full screen. Here are the steps: 


	
Create a space specially for X1. This can be done by starting Mission Control using either the keyboard hotkey or Control+Up, then holding Option and pressing the plus button in the top right corner of the screen.



	
Switch to the new space and start X1 by hitting Command+Space and typing X11. Hit Return to start the program.



	
Right-click the X1 icon in the Dock and click Options→This Desktop. 



	
Click X1’s application menu, then select Preferences. Select the Output tab in the dialog box that appears, and put a check in the boxes alongside Full-Screen Mode and Allow Menu Bar Access in Full-Screen Mode.



	
Close the preferences dialog, then quit X1 (right-click its Dock icon and select Quit).





From now on any apps you start that require X1 will automatically switch to the new space to run, and they will start in full-screen mode without the Dock or OS X menu bar present. However, by nudging the mouse cursor at the top edge of the screen, you can make the main OS X window appear. Here you’ll be able to quit X1 once you’ve quit the app running within it.

X1 takes over the keyboard so all keyboard shortcuts and hotkeys that allow you to switch spaces or activate Mission Control no longer work. However, a curious trick (or possibly a bug!) will let you get around this—nudge the cursor at the top of the screen so that the OS X menu bar appears. Activate a menu by clicking it, then move over to the Help menu. Full-screen X1 will disappear, revealing the desktop. You can now switch spaces in the usual way, or use Mission Control. To return to full-screen X1, just click the X1 icon on the Dock. This will also switch you back to the X1 desktop space.







	Tip 283
	Switch Dashboard Back to Overlay Mode




Up until OS X Lion, the Dashboard magically overlaid the main desktop when it was activated. In OS X Lion, however, it’s been converted into a desktop space.

If you prefer the old way of working, open System Preferences (Apple menu→System Preferences), select the Mission Control icon, and remove the check next to Show Dashboard as a Space. This change will take effect immediately. 

You’ll now have to switch to Dashboard using either its hotkey, if your Mac’s keyboard has one, or by hitting F12 (Fn+F12 on portable Macs and Macs with aluminum keyboards).

A nice side effect of making this switch is that the “ripple” special effect that formerly appeared when a new widget is added to the Dashboard is also restored.







	Tip 284
	Spruce Up iTunes Visualizations




If you’re a fan of the iTunes visualizations that appear when music is playing (View→Show Visualizer), you might be interested to know that often there are configuration options that can be tweaked. To see them, just hit the question mark key while the visualization is playing. This will show a menu indicating other keystrokes that will change the nature of the animations. If you use the classic visualization mode (View→Visualizer→iTunes Classic Visualizer), hitting the question mark key for a second time will bring up a second help menu. 







	Tip 285
	Go to a Particular Line Within TextEdit




There’s a hidden keyboard shortcut within TextEdit that lets you jump straight to a particular line number. This can be useful for programmers, even though there is no option within TextEdit to actually display line numbers! To jump to a particular line, just hit Command+L, then type the number in question.







	Tip 286
	Add Finder to Launchpad




If you’re a fan of Launchpad, you might notice a strange omission—you can’t open a Finder window from within Launchpad. There’s no Finder icon.

The solution is simple. Open a Finder window using the Dock icon, hit Shift+Command+G, and type /System/Library/CoreServices. Then look for a file called Finder (it’ll have the same icon as the Dock’s Finder icon), and drag and drop it on top of the Launchpad icon in the Dock. 

Activate Launchpad and, hey, presto—you now have a Finder icon! It will probably be on the last page of the Launchpad app listing. You can move it to the first page by clicking and dragging it to the left edge of the screen.







	Tip 287
	Bulk-Forward Emails




Ever wanted to attach one or more messages to an email you’re writing? In OS X Mail it’s easy. Just select the messages you’d like to attach from those in the list, then switch back to the new mail window. Finally, hit Option+Command+I. The messages will now appear at the bottom of the email you’re writing, as if you’d chosen to forward them. 







	Tip 288
	Create an Instant Wired Network Between Macs




To create an instant network between two Macs, just connect them together via a standard network cable. Your Mac will take care of the rest. Then enable file sharing on one or either Macs—open System Preferences (Apple menu→System Preferences) and click the Sharing icon. Then put a check next to File Sharing in the list. The other Mac should now appear in Finder under the Shared heading. You’ll need to log into the other Mac using the account you have on that computer. 







	Tip 289
	Get Cool Wallpapers from Screen Saver Packages




You might already use the various picture slideshow screen savers that cycle through images of forests, the cosmos, or beach scenes. All are available within the Desktop & Screen Saver tab of System Preferences (Apple menu→System Preferences). The images used in the slideshows can also be used as desktop wallpaper, although they’re not ultra-high resolution, so they might look a little blurry on 1080p HD monitors, for example. But for smaller monitors, they’re worth investigating.

Here are the steps required to extract the images:


	
Start by creating a folder within your Documents folder where you can store the new wallpapers. It doesn’t matter what you call this.



	
Open a Finder window, hit Shift+Command+G, and type /System/Library/Screen Savers. You should see the screen savers listed by name. We’ll start by extracting the images from the Beach screen saver, although the technique is the same for the others. Right-click Beach.slideSaver and, in the menu that appears, click Show Package Contents. 



	
Use Finder to navigate to the Resources folder. Here you’ll find the images listed, usually in sequence and usually in the JPEG format. In the Beach screen saver, for example, they’re named Beach01.jpg, Beach02.jpg, and so on. Click and drag them all to the new folder you created earlier.



	
Repeat the steps for any other screen savers you’d like to take images from, such as Cosmos.slideSaver or Forest.slideSaver. Only slideSaver files contain images—ignore the other screen saver files.



	
Open System Preferences (Apple menu→System Preferences), click the Desktop & Screen Saver icon, then click the Desktop tab. Open Finder and locate the folder containing your new wallpaper images, and click and drag it to the left of the System Preferences window under the Folders heading. The folder will be added, but note that it’s only a link to the folder you created—if you delete the original folder, the images will disappear from the list.











	Tip 290
	Use Emoji—Japanese Full-Color Emoticons




Emoji are similar to emoticons you might already use: things like :-) for a smiley face, for example. The difference is that they’re full-color high-quality images, and they’re usually distributed as a special font. They’re popular in Japan and are rapidly spreading to the West.
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Figure 44. Accessing Emoji characters





OS X Lion includes default support for Emoji, as do versions 4 and above of iOS, the operating system that runs the iPad and iPhone. Therefore you can add them to email messages, for example, and text documents created with apps like TextEdit, although apps like Microsoft Word don’t currently support Emoji.  

Setting Up Emoji Access

To insert an Emoji, you’ll need to use the hidden Characters tool, so some setup is necessary. Open a Finder window and hit Shift+Command+G. In the dialog box that appears, type /System/Library/Input Methods. Then look for the file called CharacterPalette. This is the tool we’ll regularly use to insert Emoji, so click and drag it to the Dock to create a shortcut for future use. Alternatively you can drag it to the desktop, but before releasing the mouse button, hold Option+Command to create an alias.

Inserting Emoji

Start the CharacterPalette app and, in the left of the program window, select Emoji. Then select a category of Emoji icon from the column next to this—People, Nature, Objects, Places, or Symbols. Finally, select the icon you want from the list of icons and then click and drag it to where you want to insert it into your email, document, and so forth. See Figure 44, ​Accessing Emoji characters​.

Click the dropdown list at the top left of the CharacterPalette window to alter the size of the icon display—selecting Large will show more detail, although this won’t affect the icons’ size when inserted into documents. To alter the size of an Emoji once it’s been inserted into a document, select it and use the standard font point size adjustment tool, usually available on the formatting toolbar. 

Remember that any Emoji you insert into emails and documents will appear when opened by other OS X Lion computers and on iPads and iPhones, but they won’t appear on Windows or Linux systems or on Macs running pre-Lion releases of OS X. Instead, users will see a missing character symbol instead (usually a question mark symbol within a box).

Using Emoji for File and Folder Names

Emoji can also be used in file and folder names. The best technique for inserting them is to open a TextEdit document, insert the Emoji you’d like to use (as described previously), and then copy and paste this when you come to save a file or if you rename a file. 

However, although OS X seems happy to allow Emoji to be used in file and folder names, I suspect this might cause future problems. Should you share a file with a Windows or Linux computer, for example, the filename will appear to be corrupted, although in my brief testing the files still seemed to open correctly.







	Tip 291
	Type and Spellcheck Foreign Languages in TextEdit




This is less of a tip and more of an observation, although it’s worth knowing. If you start typing in a non-English language, TextEdit will automatically switch its spellcheck dictionary to that language. Start typing in German, for example, and it will spot any errors in the German words you type. Right-clicking a misspelled word underlined in red will bring up a list of suggested German language corrections.

Start typing in English, however, and TextEdit will again realize and switch the dictionary for that particular part of the document to English. 







	Tip 292
	Use Safari While Booted to the Recovery System




Hold down Command+R before the Apple logo appears during booting and you’ll boot to the recovery system. Here you can perform disk checks, restore the system via Time Machine, and even reinstall OS X. See Tip 226, ​Make Use of Boot-Time Options​.

You can also unofficially launch apps that are installed within the main OS X installation, although it isn’t easy. You might want to launch Safari to be able to research a problem you’re having, for example.

While booted to the recovery system, click Utilities→Terminal, then type the following:



	 
	
​/Applications/Safari.app/Contents/MacOS/Safari​





Once you’ve finished, hit Command+Q twice to quit Safari as well as the Terminal window that launched it. This will return you to the main recovery options dialog box. To restart the computer, click the Apple menu, then select the Restart option.







	Tip 293
	Migrate from Windows to Mac Without Losing Data




If you’re setting up a Mac for somebody who’s switching from a Windows computer, head over to http://support.apple.com/kb/DL1415 to download the Windows Migration Assistant. This runs on Windows and exports email from Outlook, Outlook Express, Windows Mail, and Windows Live, alongside contacts, calendars, the iTunes library, personal files within the Home directory, browser bookmarks, and localization settings. It transfers this data to a computer running OS X Lion via the network connection (either Wi-Fi or Ethernet), so both computers will need to be online and part of the same network.

Once the Windows app has been started, it will search the network for a Mac computer ready to accept the data. If the Mac has already been set up, start the Migration Assistant app within the Utilities folder of the Application list within Finder. If the Mac has not yet been set up (that is, it’s brand-new and hasn’t even been booted for the first time), switch it on and follow the OS X setup steps until you reach the Transfer Information to This Mac stage. Then, from the list of possible sources, select From a Windows PC.

Whichever route you take, you’ll be prompted to confirm the computer you wish to import from, and a short numeric passcode will be shown on the screen of both computers so you can confirm it is the correct computer. 

Following this, on the Mac you’ll be prompted to select the kind of information you want to transfer. Clicking the Continue button should start the import process. 

Be careful not to wipe the Windows computer too quickly after the process has finished. Check to make sure all your files have been transferred across first. 







	Tip 294
	Expand QuickTime Player’s Knowledge of File Types




This book has largely avoided recommending third-party tools you can download, but there are two exceptions: Perian and Windows Media Components for QuickTime.[22] These are system add-ons that allow your computer to play practically all movie and audio file formats. This is needed because OS X’s support for movie files doesn’t go much beyond its own QuickTime formats and DVD movie discs.

Once installed, Perian will add an entry within System Preferences (Apple menu→System Preferences) by which you can configure some of the options for audio output and so on (although there’s usually no need to). Windows Media Components for QuickTime includes a special player application, accessible within the Applications view of Finder, but you can ignore this because, as the name implies, after installation you’ll find that QuickTime Player is compatible with Windows Media files. 

In order to play all types of media files, many people ignore QuickTime Player completely and use the third-party app VLC instead. Visit http://www.videolan.org/vlc/download-macosx.html for more information.







	Tip 295
	Read Apple Manuals for Your Products




It’s often claimed that, beyond a few pamphlets, Apple doesn’t produce manuals for its products. The truth is that the company does in fact create all kinds of documentation, including manuals. They just don’t include them in the box with the product.

Head over to http://support.apple.com/manuals, where you’ll find various types of documentation for Apple software and hardware products, including OS X Lion.

Alternatively, if you just want to read the manual for your Mac hardware, click the Apple menu, then About This Mac. Click the More Info button in the dialog that appears, and in the new program window click the Support menu button at the right. Then click the User Manual link.







	Tip 296
	Use a Non-Apple Keyboard with Your Mac




It’s possible to use a standard PC keyboard with your Mac. However, in my experience the modifier keys sometimes get mixed up.

Ideally, the “Windows key” (that is, the key with the Windows logo) should operate as the Command key, usually identified on genuine Mac keyboards with a ⌘ symbol, while Option and Control should work as marked on the keys. However, for some reason Option and Command sometimes get swapped.
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Figure 45. Changing modifier key designations for a PC keyboard





Yes, it’s very confusing. But here’s how to fix it:


	
Open System Preferences (Apple menu→System Preferences) and click the Keyboard icon. Make sure the Keyboard tab is selected.



	
Click the Modifier Keys button. At the top of the dialog box that appears, select Unknown External Keyboard in the dropdown list next to the Select Keyboard heading.



	
Using the dropdown list next to the Option ⌥ Key heading, select ⌘Command.



	
In the dropdown list next to the Command ⌘ Key heading, select ⌥Option. Everything should look like Figure 45, ​Changing modifier key designations for a PC keyboard​. Click OK and close System Preferences.





The changes will take effect immediately. 







	Tip 297
	Connect to Network Shares at Login




If you work in an office or have more than one computer in your home, you might be used to connecting to shared folders across the network. However, you’ll also know that your Mac expects you to create a new connection every time the computer boots. This can be annoying.

It’s possible to automatically connect to shared folders upon login, as follows:


	
You’ll first need to make connected servers appear as icons on the desktop. To do so, open Finder and click the application menu, then Preferences. Make sure the General tab is selected, and then put a check next to Connected Servers, under the Show These Items on the Desktop heading.  



	
Once that’s done, connect to the shared folder if you’re not already connected (usually you can do this by clicking the server’s icon in the sidepane of the Finder window, under the Shared heading, but see Tip 213, ​Connect to Shared Folders or Servers​). Be sure to put a check next to the option for remembering the password in the keychain.  



	
Open System Preferences (Apple menu→System Preferences) and select the Users & Groups icon. Unlock System Preferences if necessary by clicking the padlock icon, then make sure your account is selected on the left of the screen. Click the Login Items tab on the right.



	
Then simply click and drag the desktop icon for the server to the list of login items. Note that there’s no need to put a check next to the new entry in the list—that’s used to force login items to start minimized and isn’t relevant here.





And that’s it! If you want to hide desktop icons showing network connections, you can repeat the step above that activated the display of server icons on the desktop, but this time remove the check next to Connected Servers. The tip will work whether they’re shown or not—we just needed to see them to be able to create the startup shortcut. 

If in the future you want to stop connecting to the server at startup, just repeat the steps and remove the server entry from the list of login items for your user account by selecting it and clicking the minus button to the bottom left of the list.







	Tip 298
	Invert a Selection of Files




This is a useful trick if you need to select a lot of files at once, with the exception of a handful. However, it only works on the desktop or in Icon view within Finder.

Start by selecting the files you don’t want to include in your selection. This can be done by holding down Command and clicking them. Then press and hold the Command key and use the mouse to rubber-band-select all the files. You should find that the selection inverts—files that weren’t selected now are, and those that were are automatically unselected. 







	Tip 299
	Open Duplicates of Dashboard Widgets




Here’s a tip that might be obvious to some but mind-blowing to others.

You aren’t limited to just one representation of any Dashboard widget. In other words, you could have as many clocks as you want on the Dashboard, each showing the time in a different time zone—just repeatedly click and drag new clock widgets from the Manage Widgets selection at the bottom of the screen.

You could also have several versions of the weather widget showing conditions at different locations or several versions of the Stickies widget with different color notes.







	Tip 300
	Cue Second-by-Second in Movies




You might already know that if you click the blob within the timeline on the QuickTime Player transport, you can cue back and forth in the movie you’re watching, something known as scrubbing. However, if you click and hold the blob without moving it, you’ll see white bars appear in the timeline. Each of these indicates one second, and the entire timeline will be changed to represent ten seconds. Dragging the blob will now allow precise movement through the movie. Releasing the mouse button will return the timeline to normal. 

Additionally, when the movie is paused, tapping the left and right cursor keys will advance the motion frame by frame. Pressing and holding either key will play the movie in slow motion. 







	Tip 301
	Turn a Website into an App




If you want to simply double-click an app icon to open a website on your desktop, avoiding a full-blown browser, this tip is for you. Here are the steps to turn a website into an app:


	
Start the Automator app. It’s located in the Applications list in Finder.



	
In the document chooser that appears when Automator starts, double-click the Application icon—its icon is a robot. If this doesn’t appear, click File→New.



	
In the list of actions beneath the Name search field, scroll down until you find the Get Specified URLs entry. Double-click it to open it on the right side of the window.



	
Under the new Get Specified URLs heading, double-click the Apple website address and replace it with that of the site you want your new app to visit, including the http:// component. Hint: If you want to specify one of Google’s web apps, you might have to append /?browserok=true to the end of the URL. In other words, something like http://docs.google.com will need to read http://docs.google.com/?browserok=true. Appending the URL causes Google to stop checking to ensure the browser is compatible, which can cause problems.



	
Back in the list of actions under the Name search field, locate the Website Popup entry. It’ll probably be at the bottom of the list. Again, double-click to add it to the right of the window.



	
Under the new Website Popup heading, you can leave most entries as they are. However, in the Site Size and User Agent dropdown lists you can select either iPad or iPhone, which will not only shrink the app window to the size of an iPad or iPhone but also access the iPad or iPhone versions of a site. These are often optimized for small screen sizes, which makes them ideal for our new app. 



	
Once you’re done, click File→Save and give your new app a name. Once that’s done, you can close Automator. The app is ready to use, so double-click it to try it out.





The new app window has Cancel and OK buttons at the bottom right, and both quit the app. You can also quit the app by clicking the cogs icon at the top right of the screen and clicking the close button alongside the entry for your website app.

You can edit the app at any time by starting Automator again and opening it using the File menu.

You can change the icon for your new app to something more identifiable with the site by following Tip 19, ​Personalize Every Icon​. 

Another way to get websites on your desktop within discrete program windows is to create a Dashboard web clip of the site and then follow Tip 21, ​Use Dashboard Widgets on the Desktop​.







	Tip 302
	Put Movie Clips Online




Ever wanted to quickly put a movie clip on Facebook, YouTube, or another site that lets you upload movies? It’s easily done on a Mac. Just load the clip in QuickTime Player and, if necessary, trim the clip as described in Tip 127, ​Edit Movies Within QuickTime Player​. Then click an entry on the Share menu relating to the service you wish to use, and follow the wizard steps. 







	Tip 303
	Create a New Folder Anywhere




Want to create a new folder? Just hit Shift+Command+N. This will work on the desktop, in a Finder window, in a Save As dialog box, and even within a File Open dialog box. In short, practically anywhere you come into contact with files, it should work!







	Tip 304
	Use Quick Look to Skim-Read Sites




Here’s an interesting way of viewing web pages that might be useful for those who are frequently in a hurry and just want to skim the front pages of sites without first loading Safari.

Some setup is required, as follows. Create a new folder, then use Safari to visit the first of the websites you want to regularly skim. Click and drag the small icon just before the web address to the new folder. This will create a web location file—a file-based bookmark for a site, which has the file extension webloc. Repeat with the other websites you want to regularly skim-read. You might choose to rename the web location files to make them easier to identify at a glance.

Setup is now complete. In future, all you need to do to skim the sites is select the first web location file in the list, then hit Space to Quick Look it. The Quick Look window will load the site, looking like a stripped down version of Safari. Once you’ve finished reading, click the next web location file. This will then open in the Quick Look window. Keep going until you’ve finished, then hit Space to close the Quick Look window. 







	Tip 305
	Grab Files from FTP Servers Using Finder




Finder includes basic FTP accessing functionality. You can browse files and folders on an FTP server and download them, but it isn’t possible to upload files. For that you’ll need to use a third-party FTP client.

To connect to an FTP server, open a Finder window and click Go→Connect to Server. In the dialog box that appears, type ftp:// followed by the address into the Server Address field. For example, to connect to the server at ftp.example.com, I would type the following:



	 
	
​ftp://ftp.example.com​





Then click the Connect button. You’ll be prompted for your username and password once you’ve connected.

The protocol to log into public FTP servers is usually to specify anonymous as the username and then provide your email address as the password.

To disconnect from the server, simply close the Finder window.







	Tip 306
	Turn Off the Caps Lock Key




Some people find they accidentally hit the Caps Lock key while typing. Under OS X you can turn it off so that pressing the key does nothing—you won’t even light up the key’s indicator light. To do so, open System Preferences (Apple menu→System Preferences) and click the Keyboard icon. Then make sure the keyboard tab is selected and click the Modifier Keys button. In the dropdown list next to Caps Lock Key, select No Action. The change will take effect immediately.  

To reactivate Caps Lock at a later date, just repeat the steps to access the modifier keys dialog box and select Caps Lock from the Caps Lock Key dropdown list.







	Tip 307
	Make Keyboard Lighting Work 




If your Mac’s keyboard has backlighting, you can adjust it using the keyboard hotkeys (usually on the F5 and F6 keys, above the 5 and 6 keys on the keyboard). However, sometimes the lighting might refuse to activate—you’ll see a “no entry” sign when you tap the hotkeys no matter how many times you press them. 

Don’t worry—nothing is broken. It’s simply that your Mac has detected that the ambient light in the room is bright enough to illuminate your keyboard naturally and so backlighting isn’t needed. Place your finger over the iSight/FaceTime HD camera above the screen; this should fool your Mac into thinking it’s dark and should restore your ability to adjust the keyboard backlighting.

If you want to avoid this confusion in future, open System Preferences (Apple menu→System Preferences) and click the Keyboard icon. Make sure the Keyboard tab is selected, then remove the check next to Automatically Illuminate Keyboard in Low Light. You should now find yourself able to adjust the keyboard backlighting no matter what the ambient conditions are, although beware that using the backlighting drains battery life more quickly than usual. 







	Tip 308
	See the Condition of Your Battery at a Glance




This is a tip for anybody with one of the MacBook range of computers.

If you hold down Option and click the battery life display at the top right of the screen, you’ll be told the condition of your battery. On most Macs this reads “Normal,” which means the battery is in good condition. If instead you see Replace Soon, Replace Now, or Service Battery, there’s likely a fault with the battery and you should take your computer for repair as soon as possible. However, before you do that, consider resetting the System Management Controller, as described in Tip 81, ​Reset Your Mac’s Hardware Settings​. This will remove the possibility of the status being incorrectly reported by corrupted system settings. 

To see many more details about the battery, click the Apple menu, hold down Option, and click the System Information entry on the menu. In the window that appears, click Power in the list on the left side, then look at the details under the Battery Information heading on the right side. 







	Tip 309
	Magnify Sections of Photos or PDFs Easily




When viewing photos or PDFs in Preview, you might use the magnify buttons on the toolbar to get a better view of details. But try this instead: hit the backtick key (left of the top number row on most keyboards, but sometimes left of the Z key) and a magnifying glass will appear. If you have a multitouch trackpad you can use the pinch-and-expand gesture to make the glass zoom in and out. Everybody else can tap the plus and minus keys (hold Command at the same time to also zoom the image/document). To get rid of the glass, just hit the backtick key again or hit Esc. 







	Tip 310
	Get a True Image of the Andromeda Galaxy




Apple chose an image of the Andromeda galaxy for the default wallpaper of OS X Lion and for the Time Machine background. However, they airbrushed out a handful of nearby stars and even a whole galaxy (M110) to make things look prettier. If you want a true image of the galaxy to use as your wallpaper (well, as true as astronomical photographs can be, bearing in mind they’re usually composites), visit http://www.robgendlerastropics.com/M31NMmosaic.html. 







	Tip 311
	Reboot the Dock




Is the Dock on your Mac not working properly or has it become corrupted? Start Launchpad and hit Command+D. This will quit the Dock and restart it again in a similar way to the killall Dock command used in many tips throughout this book.







	Tip 312
	Tell Your Mac to Do Things




We can file this tip under “Innovative features introduced some time ago.”

Your Mac has powerful speech recognition software, and while it won’t let you dictate letters, it does let you command your Mac to do things that can save typing or using the mouse. Of course, you’ll need a Mac with a built-in microphone, although all modern portable Macs and iMacs have this.

Activating Speech Recognition

To activate speech recognition, open System Preferences (Apple menu→System Preferences) and open the Speech pane. Then click the Speech Recognition tab and click the On button next to the Speakable Items heading. A new circular floating window will appear at the top right of the desktop, which lets you know that your Mac is waiting for voice input. All you need do is hold down Esc and speak a command, releasing Esc when you’ve finished. To learn what commands you can speak, hold down Esc and say “Open speech commands window.” This should then show a pop-up window displaying all the commands recognized by default.



	
[image: images/speechrecog.png]




	


Figure 46. Calibrating speech recognition





Calibrating the Microphone

It’s very likely you’ll need to calibrate the microphone to get the best results. To do this, click the Calibrate button in the Speech Recognition pane within System Preferences and, in the window that appears, drag the slider beneath the audio meter to around 25 percent. Then try speaking some of the test phrases listed on the left of the window. They’ll flash if they’ve been recognized. If none seem to work or the results are spotty, try dragging the slider to the left or to the right. Note that on the MacBook Pro I used for testing, I had to drag the slider to the very first bar near the Low heading to get consistently accurate speech recognition, despite the audio meter display appearing to show a perfectly acceptable input at higher settings. See Figure 46, ​Calibrating speech recognition​.

Having Fun

Try saying, “Tell me a joke.” OS X knows quite a few jokes, so try it several times.







	Tip 313
	Use Three Fingers and Revolutionize Your Mac Use




If your Mac has a multitouch trackpad, open System Preferences (Apple menu→System Preferences), click the Trackpad icon, make sure the Point & Click tab is selected, then put a check next to Three Finger Drag.

This will activate several useful features, as follows:


	
Coasting windows: Place three fingers on the trackpad when the mouse cursor is over a title bar and move it a little. Then leave one finger permanently on the trackpad and flick with a neighboring finger—the window will “coast” for a while (think of a puck on an Air Hockey board or of flicking within a list on an iPhone/iPad screen).



	
Copying files: In Finder windows, if you position the mouse cursor over a file or folder and drag with three fingers, you can copy it to a new location instantly (hit Esc to cancel if you change your mind midway through). To drag long distances, lift one finger so that two still touch the trackpad and flick that finger to “coast” (try it and see). 



	
Downloading web images: When viewing web pages, position the mouse over an image, drag with three fingers on a picture, and copy it to the desktop or to a Finder window.



	
Moving windows: You can move windows by positioning the mouse cursor over the title bar and dragging three fingers on the trackpad.



	
Selecting text: You can select text by positioning the mouse cursor over a sentence in a paragraph, putting three fingers on the trackpad and dragging (double-click the first word, then drag to highlight only whole words).



	
Selecting within a list: Drag three fingers across a file listing and you can rubber-band-select them. The same applies to dragging three fingers within any other list within OS X, such as the Inbox in Mail.





Note that when the three-finger drag is activated, the three-finger gesture is switched to four fingers—swiping four fingers left or right will switch spaces, and swiping four fingers up will activate Mission Control. 







	Tip 314
	Use AirDrop Even on Incompatible Macs




AirDrop allows you to share files between compatible Macs (see ​Exploring OS X Lion: AirDrop​), but by altering a hidden setting, some computers that Apple states are incompatible can also join the AirDrop network (although all the computers must be running OS X Lion).

However, unlike regular AirDrop networking—which lets users share files even if they’re connected to different Wi-Fi networks—AirDrop enabled this way works only if the Macs to which you want to send or receive files are part of the same network. However, unlike with regular AirDrop, this network can be either wired (Ethernet) or Wi-Fi.

It’s important to note that this is strictly an unofficial tweak—you might find it works perfectly, or it might not work at all. Just give it a try! If it doesn’t work, simply disable the tweak as described at the end of this tip.

Enabling AirDrop on Incompatible Macs

Open a Terminal window (Finder→Applications→Utilities→Terminal) and, on the Mac not supported by AirDrop, type the following:



	 
	
​defaults write com.apple.NetworkBrowser BrowseAllInterfaces -int 1​





Then restart the computer. Repeat this tweak on every other Mac to which you want to transfer files via AirDrop, even if they are already compatible with AirDrop. Reboot each after making the tweak.

Using AirDrop on Incompatible Macs

Once enabled on all the computers concerned, you should find AirDrop works exactly as described in ​Exploring OS X Lion: AirDrop​—just drag and drop files on the icons of other Macs that appear within the radar view that appears when AirDrop is selected in Finder. Their users can drag and drop files on your icon to transfer files to you, too. 

You might find that some Macs don’t appear on your AirDrop radar, even though you appear on theirs. Once someone has transferred a file to you, however, you should find that that Mac becomes visible.

Bear in mind that the standard AirDrop service is intentionally limited by distance because it’s intended for sharing files with those physically nearby. Enabling this tweak will open up AirDrop to each Mac in the network, which, in an office environment, could cover an entire building—or more.

Disabling the AirDrop Setting

To disable this tweak, open a Terminal window and type the following, again rebooting your computer afterward:



	 
	
​defaults delete com.apple.NetworkBrowser BrowseAllInterfaces​





Don’t forget to do so on all the computers on which you made the tweak.







	Tip 315
	Continue Your Mac Adventure: Some Must-Have Apps




In this book I’ve deliberately avoided recommending third-party apps. There are a handful of exceptions where apps are needed to make up for rare deficiencies in OS X’s functionality—for example, Tip 294, ​Expand QuickTime Player’s Knowledge of File Types​—but throughout the book a DIY approach and faith in OS X’s extensive built-in toolkit is encouraged.  

That said, there are some add-in apps that are part of a standard Mac setup for many users. I’ve listed a handful below. Unless otherwise marked, the apps are free of charge and can be downloaded from the websites mentioned.


	
Growl (http://growl.info/): Adds a simple notification system to OS X so that apps can report when they’ve finished a task, for example. Plugins are available for many built-in OS X apps, and lots of third-party apps support Growl too.



	
ClamXav (http://www.clamxav.com): Adds on-demand virus scanning to OS X. Unlike other antivirus programs,[23] ClamXav doesn’t remain present in memory. You can run it to scan any files that look suspicious, such as those you’ve downloaded from a less reputable website. Available via the App Store.



	
Xcode (http://developer.apple.com/technologies/tools/): Apple’s own programming toolkit and integrated development environment is free of charge via the App Store for anybody who purchased OS X Lion. It allows you to create apps for OS X and iOS and also create Dashboard widgets. 



	
The Unarchiver (http://wakaba.c3.cx/s/apps/unarchiver.html): Significantly expands OS X’s knowledge of compressed file formats, specifically adding in the ability to expand RAR, 7-zip, LhA, and StuffIt formats.[24] Available via the App Store.



	
Little Snitch (http://www.obdev.at/products/littlesnitch/index.html): OS X already has a powerful firewall protecting your computer from inbound connections, but Little Snitch adds outgoing firewall protection to OS X. This lets you control which apps have access to the Internet and thereby potentially put a block on malicious software or just stop software from “phoning home.” Little Snitch can be purchased from the author’s website.
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Figure 47. Continuing the Mac adventure with third-party apps







	
Transmission (http://www.transmissionbt.com): There are a variety of BitTorrent clients for OS X, but this is perhaps the most fully featured and is frequently updated with new features.



	
Cyberduck (http://cyberduck.ch): File transfer program that works with FTP, SFTP, WebDav, Amazon S3, Google Storage (including Google Docs), Microsoft Azure, and Rackspace Cloud Files. Can be purchased via the App Store, but a free-to-try “donationware” version is available from the website.



	
iWork (http://www.apple.com/iwork/): Apple’s own office suite, consisting of Pages (word processor), Numbers (spreadsheet), and Keynote (presentations). All are packed with features plus the ease of use and excellent design expected of Apple products, but, perhaps crucially, the apps also integrate 100 percent with OS X Lion’s features, such as Versions and iCloud, and there are versions available for the iPhone/iPad too. Each component of iWork for OS X is purchased individually from the App Store, or boxed copies of the suite can be bought from Apple stores.



	
VMware Fusion (http://www.vmware.com/products/fusion/overview.html): Creates virtual computers within software that let you run Microsoft Windows, Linux, or even additional installations of OS X Lion. Fusion is useful if you need to run some Windows software or games but not enough to warrant a full BootCamp installation of Windows, and you can also access pre-built machines sometimes offered for download. VMware Fusion can be purchased from the VMware website. 



	
iTerm 2 (http://www.iterm2.com): Those who work at the command line might come up against limitations of OS X’s built-in Terminal program. iTerm 2 is a third-party replacement that offers many more features plus increased compatibility when making remote connections.



	
Adium (http://adium.im/): Instant messaging client that supports just about every chat protocol in existence and integrates fully with OS X’s Address Book. 





Additionally, it should be noted that the makers of most major Windows software usually produce an OS X version too. There’s a Mac version of Microsoft Office,[25] for example, and Mac versions of Skype and Yahoo! Messenger (see Figure 47, ​Continuing the Mac adventure with third-party apps​).[26] Additionally, you’ll usually find Mac versions of major open source projects such as LibreOffice and Gimp.[27] Note that some open source software uses X11, which is preinstalled on all OS X Lion systems and activated automatically when the apps run.  



Footnotes



	
[3]

	

http://interfacelift.com/icons, for example.





	
[4]

	

http://www.coconut-flavour.com/coconutbattery






	
[5]

	

http://support.apple.com/kb/HT4783






	
[6]

	

http://store.apple.com/us/product/MD256?mco=MjQ1MzkyMDY






	
[7]

	
CMYK has a smaller color gamut compared to RGB, so any values returned by the color picker will be nearest approximated values.





	
[8]

	

https://appleid.apple.com






	
[9]

	

http://maps.google.com






	
[10]

	

http://www.macports.org and http://www.finkproject.org, respectively.





	
[11]

	

http://www.adobe.com/products/acrobat.html






	
[12]

	

http://www.apple.com/ilife/imovie/






	
[13]

	

http://www.realvnc.com






	
[14]

	

http://www.apple.com/timecapsule/






	
[15]

	

http://docs.info.apple.com/article.html?path=Server/10.7/en/t_EnablePodcastLibrary.html for both.





	
[16]

	

http://support.apple.com/kb/ht1661






	
[17]

	

http://macromates.com






	
[18]

	
For example, http://mac.softpedia.com/get/Spotlight-Plugins---Utilities/






	
[19]

	

http://www.macupdate.com/app/mac/21178/tarimporter






	
[20]

	
Tar archives are the default archive type under Unix.





	
[21]

	

http://www.gimp.org/macintosh/






	
[22]

	

http://perian.org/ and http://windows.microsoft.com/en-US/windows/products/windows-media-player/wmcomponents, respectively.





	
[23]

	
For example, Sophos Anti-Virus for Mac Home Edition: http://www.sophos.com/en-us/products/free-tools/sophos-antivirus-for-mac-home-edition.aspx.





	
[24]

	
The official app by the creators of the StuffIt format, StuffIt Expander, is a free download from the App Store.





	
[25]

	

http://www.microsoft.com/mac/






	
[26]

	

http://www.skype.com/intl/en-us/get-skype/on-your-computer/macosx/ and http://messenger.yahoo.com/mac/, respectively.





	
[27]

	

http://www.libreoffice.org and http://www.gimp.org/macintosh, respectively.
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